]> git.pld-linux.org Git - packages/crossmingw32-freetype.git/blobdiff - crossmingw32-freetype.spec
- updated to 2.3.12
[packages/crossmingw32-freetype.git] / crossmingw32-freetype.spec
index e8d9fbcf3aa1a754b31e4b5273dfd2243fae1b36..b650bade9d15e1e67531ea189e3956652b9ae5db 100644 (file)
@@ -1,27 +1,23 @@
 #
 # Conditional build:
-%bcond_without bytecode        # without TT bytecode interpreter
-#               (patents pending in USA, Japan etc., but now it includes
-#                also patent-free hinting workaround)
-%bcond_without lcd             # disable filters reducing color fringes when
-#                 subpixel rendering for LCD (only used with a new 2.3.0 API;
-#                 patents pending)
+%bcond_without bytecode        # without TT bytecode interpreter (Apple patents in USA)
+%bcond_without lcd             # without LCD subpixel color filtering (Microsoft patents in USA)
 #
-%define                _realname   freetype
+%define                realname   freetype
 Summary:       TrueType font rasterizer - Mingw32 cross version
 Summary(pl.UTF-8):Rasteryzer fontów TrueType - wersja skrośna dla Mingw32
-Name:          crossmingw32-%{_realname}
-Version:       2.3.5
+Name:          crossmingw32-%{realname}
+Version:       2.3.12
 Release:       1
 License:       GPL or FTL
 Group:         Development/Libraries
-Source0:       http://savannah.nongnu.org/download/freetype/%{_realname}-%{version}.tar.bz2
-# Source0-md5: 65234327c5ac46ee00ebda15995d4c1c
+Source0:       http://downloads.sourceforge.net/freetype/%{realname}-%{version}.tar.bz2
+# Source0-md5: e974a82e5939be8e05ee65f07275d7c5
 URL:           http://www.freetype.org/
 BuildRequires: crossmingw32-gcc
-BuildRequires: crossmingw32-zlib
+BuildRequires: crossmingw32-zlib >= 1.2.3-2
 BuildRequires: python
-Requires:      crossmingw32-zlib
+Requires:      crossmingw32-zlib >= 1.2.3-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                specflags_ia32  -fomit-frame-pointer
@@ -32,15 +28,22 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                target                  i386-mingw32
 %define                target_platform         i386-pc-mingw32
-%define                arch                    %{_prefix}/%{target}
 
 %define                _sysprefix              /usr
 %define                _prefix                 %{_sysprefix}/%{target}
-%define                _pkgconfigdir           %{_libdir}/pkgconfig
+%define                _libdir                 %{_prefix}/lib
+%define                _pkgconfigdir           %{_prefix}/lib/pkgconfig
 %define                _dlldir                 /usr/share/wine/windows/system
 %define                __cc                    %{target}-gcc
 %define                __cxx                   %{target}-g++
 
+%ifnarch %{ix86}
+# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
+%define                optflags        -O2
+%endif
+# -z options are invalid for mingw linker
+%define                filterout_ld    -Wl,-z,.*
+
 %description
 The FreeType engine is a free and portable TrueType font rendering
 engine. It has been developed to provide TrueType support to a great
@@ -96,7 +99,7 @@ DLL freetype library for Windows.
 Biblioteka DLL freetype dla Windows.
 
 %prep
-%setup -q -n %{_realname}-%{version}
+%setup -q -n %{realname}-%{version}
 
 %build
 CFLAGS="%{rpmcflags} \
@@ -110,59 +113,14 @@ CFLAGS="%{rpmcflags} \
 
 %{__make}
 
-# link shared library
-cd objs/.libs
-%{__cc} \
-       --shared *.o -lm -o libfreetype.dll \
-       -Wl,--enable-auto-image-base -Wl,--out-implib,libfreetype.dll.a -lz
-cd ../..
-
-cat << "EOF" >> libfreetype.la
-# libfreetype.la - a libtool library file
-# Generated by ltmain.sh - GNU libtool 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
-
-# The name that we can dlopen(3).
-dlname=''
-
-# Names of this library.
-library_names='libfreetype.dll.a'
-
-# The name of the static archive.
-old_library='libfreetype.a'
-
-# Libraries that this one depends upon.
-dependency_libs=' -lz'
-
-# Version information for libfreetype.
-current=9
-age=3
-revision=16
-
-# Is this an already installed library?
-installed=yes
-
-# Should we warn about portability when linking against -modules?
-shouldnotlink=no
-
-# Files to dlopen/dlpreopen
-dlopen=''
-dlpreopen=''
-
-# Directory that this library needs to be installed in:
-libdir='%{_libdir}'
-EOF
-
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install libfreetype.la $RPM_BUILD_ROOT%{_libdir}
-
 install -d $RPM_BUILD_ROOT%{_dlldir}
-install objs/.libs/libfreetype.dll $RPM_BUILD_ROOT%{_dlldir}
-install objs/.libs/libfreetype.dll.a $RPM_BUILD_ROOT%{_libdir}
+mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
 
 %if 0%{!?debug:1}
 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
@@ -177,12 +135,11 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc docs/{CHANGES,FTL.TXT,LICENSE.TXT,PATENTS,TODO,formats.txt,raster.txt}
-%{_bindir}/freetype-config
 %{_libdir}/libfreetype.dll.a
 %{_libdir}/libfreetype.la
 %{_includedir}/freetype2
-%{_includedir}/*.h
-%{_pkgconfigdir}/*.pc
+%{_includedir}/ft2build.h
+%{_pkgconfigdir}/freetype2.pc
 
 %files static
 %defattr(644,root,root,755)
@@ -190,4 +147,4 @@ rm -rf $RPM_BUILD_ROOT
 
 %files dll
 %defattr(644,root,root,755)
-%{_dlldir}/libfreetype.dll
+%{_dlldir}/libfreetype-*.dll
This page took 0.101423 seconds and 4 git commands to generate.