]> git.pld-linux.org Git - packages/crossmingw32-freetype.git/blob - crossmingw32-freetype.spec
429f222688ff5c92fb4af4a299c3f540da26616a
[packages/crossmingw32-freetype.git] / crossmingw32-freetype.spec
1 #
2 # Conditional build:
3 %bcond_without  bytecode        # without TT bytecode interpreter
4 #                (patents pending in USA, Japan etc., but now it includes
5 #                 also patent-free hinting workaround)
6 %bcond_without  lcd             # disable filters reducing color fringes when
7 #                 subpixel rendering for LCD (only used with a new 2.3.0 API;
8 #                 patents pending)
9 #
10 %define         realname   freetype
11 Summary:        TrueType font rasterizer - Mingw32 cross version
12 Summary(pl.UTF-8):Rasteryzer fontów TrueType - wersja skrośna dla Mingw32
13 Name:           crossmingw32-%{realname}
14 Version:        2.3.5
15 Release:        1
16 License:        GPL or FTL
17 Group:          Development/Libraries
18 Source0:        http://savannah.nongnu.org/download/freetype/%{realname}-%{version}.tar.bz2
19 # Source0-md5:  65234327c5ac46ee00ebda15995d4c1c
20 URL:            http://www.freetype.org/
21 BuildRequires:  crossmingw32-gcc
22 BuildRequires:  crossmingw32-zlib >= 1.2.3-2
23 BuildRequires:  python
24 Requires:       crossmingw32-zlib >= 1.2.3-2
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         specflags_ia32  -fomit-frame-pointer
28 # see <freetype/internal/ftserv.h>, the real horror
29 %define         specflags       -fno-strict-aliasing
30
31 %define         no_install_post_strip   1
32
33 %define         target                  i386-mingw32
34 %define         target_platform         i386-pc-mingw32
35
36 %define         _sysprefix              /usr
37 %define         _prefix                 %{_sysprefix}/%{target}
38 %define         _libdir                 %{_prefix}/lib
39 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
40 %define         _dlldir                 /usr/share/wine/windows/system
41 %define         __cc                    %{target}-gcc
42 %define         __cxx                   %{target}-g++
43
44 %description
45 The FreeType engine is a free and portable TrueType font rendering
46 engine. It has been developed to provide TrueType support to a great
47 variety of platforms and environments.
48
49 Note that FreeType is a *library*. It is not a font server for your
50 favorite platform, even though it was designed to be used in many of
51 them. Note also that it is *not* a complete text-rendering library.
52 Its purpose is simply to open and manage font files, as well as load,
53 hint and render individual glyphs efficiently. You can also see it as
54 a "TrueType driver" for a higher-level library, though rendering text
55 with it is extremely easy, as demo-ed by the test programs.
56
57 This package contains the cross version for Win32.
58
59 %description -l pl.UTF-8
60 FreeType jest biblioteką służącą do rasteryzacji fontów
61 TrueType. Jest to jedynie biblioteka, a nie serwer fontów, chociaż
62 została ona zaprojektowana do używania także w takich serwerach.
63 Nie jest to też kompletna biblioteka do rasteryzacji tekstu. Jej
64 celem jest tylko odczytywanie i zarządzanie plikami z fontami oraz
65 wczytywanie i wykonywanie hintingu i rasteryzacji poszczególnych
66 glifów. Może być także uważana za "sterownik TrueType" dla
67 bibliotek wyższego poziomu, jednak użycie samej biblioteki FreeType
68 do rasteryzacji jest bardzo proste, co można zobaczyć w programach
69 demonstracyjnych.
70
71 Ten pakiet zawiera wersję skrośną dla Win32.
72
73 %package static
74 Summary:        Static freetype library (cross mingw32 version)
75 Summary(pl.UTF-8):      Statyczna biblioteka freetype (wersja skrośna mingw32)
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78
79 %description static
80 Static freetype library (cross mingw32 version).
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka freetype (wersja skrośna mingw32).
84
85 %package dll
86 Summary:        DLL freetype library for Windows
87 Summary(pl.UTF-8):      Biblioteka DLL freetype dla Windows
88 Group:          Applications/Emulators
89 Requires:       crossmingw32-zlib-dll
90 Requires:       wine
91
92 %description dll
93 DLL freetype library for Windows.
94
95 %description dll -l pl.UTF-8
96 Biblioteka DLL freetype dla Windows.
97
98 %prep
99 %setup -q -n %{realname}-%{version}
100
101 %build
102 CFLAGS="%{rpmcflags} \
103 %{?with_bytecode:-DTT_CONFIG_OPTION_BYTECODE_INTERPRETER} \
104 %{?with_lcd:-DFT_CONFIG_OPTION_SUBPIXEL_RENDERING}" \
105 %configure \
106         --target=%{target} \
107         --build=i686-pc-linux-gnu \
108         --host=%{target} \
109         --enable-shared
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 install -d $RPM_BUILD_ROOT%{_dlldir}
120 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
121
122 %if 0%{!?debug:1}
123 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
124 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
125 %endif
126
127 rm -rf $RPM_BUILD_ROOT%{_datadir}/aclocal
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files
133 %defattr(644,root,root,755)
134 %doc docs/{CHANGES,FTL.TXT,LICENSE.TXT,PATENTS,TODO,formats.txt,raster.txt}
135 %{_libdir}/libfreetype.dll.a
136 %{_libdir}/libfreetype.la
137 %{_includedir}/freetype2
138 %{_includedir}/*.h
139 %{_pkgconfigdir}/*.pc
140
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/libfreetype.a
144
145 %files dll
146 %defattr(644,root,root,755)
147 %{_dlldir}/libfreetype-*.dll
This page took 0.027243 seconds and 2 git commands to generate.