]> git.pld-linux.org Git - packages/crossmingw32-freetype.git/blame - crossmingw32-freetype.spec
- release 2
[packages/crossmingw32-freetype.git] / crossmingw32-freetype.spec
CommitLineData
3294533f 1#
2# Conditional build:
46479e07 3%bcond_without lcd # without LCD subpixel color filtering (Microsoft patents in USA)
32e34d75 4%bcond_without harfbuzz # harfbuzz based autohinting
1e7243e1 5#
8bddf7fd 6%define realname freetype
7b9bae77
JB
7Summary: TrueType font rasterizer - MinGW32 cross version
8Summary(pl.UTF-8): Rasteryzer fontów TrueType - wersja skrośna dla MinGW32
8bddf7fd 9Name: crossmingw32-%{realname}
c54b2961 10Version: 2.6
d69e3eaf 11Release: 2
b5e35991 12License: GPL v2 or FTL
1e7243e1 13Group: Development/Libraries
bbd9e633 14Source0: http://download.savannah.gnu.org/releases/freetype/%{realname}-%{version}.tar.bz2
c54b2961 15# Source0-md5: 5682890cb0267f6671dd3de6eabd3e69
3294533f 16URL: http://www.freetype.org/
31924283 17BuildRequires: crossmingw32-bzip2
3c4380bc 18BuildRequires: crossmingw32-gcc
32e34d75 19%{?with_harfbuzz:BuildRequires: crossmingw32-harfbuzz >= 0.9.19}
1f1d4f67 20BuildRequires: crossmingw32-libpng
8bddf7fd 21BuildRequires: crossmingw32-zlib >= 1.2.3-2
c54b2961 22BuildRequires: pkgconfig >= 1:0.24
3294533f 23BuildRequires: python
31924283 24Requires: crossmingw32-bzip2
32e34d75 25%{?with_harfbuzz:Requires: crossmingw32-harfbuzz >= 0.9.19}
1f1d4f67 26Requires: crossmingw32-libpng
8bddf7fd 27Requires: crossmingw32-zlib >= 1.2.3-2
3294533f 28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%define specflags_ia32 -fomit-frame-pointer
31# see <freetype/internal/ftserv.h>, the real horror
32%define specflags -fno-strict-aliasing
33
34%define no_install_post_strip 1
35
36%define target i386-mingw32
37%define target_platform i386-pc-mingw32
3294533f 38
39%define _sysprefix /usr
40%define _prefix %{_sysprefix}/%{target}
b5aa177c
JB
41%define _libdir %{_prefix}/lib
42%define _pkgconfigdir %{_prefix}/lib/pkgconfig
1e7243e1 43%define _dlldir /usr/share/wine/windows/system
3294533f 44%define __cc %{target}-gcc
45%define __cxx %{target}-g++
d230bce9 46%define __pkgconfig_provides %{nil}
dce5a0f7 47%define __pkgconfig_requires %{nil}
3294533f 48
46479e07
JB
49%ifnarch %{ix86}
50# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
51%define optflags -O2
52%endif
4f990096 53# -z options are invalid for mingw linker, most of -f options are Linux-specific
46479e07 54%define filterout_ld -Wl,-z,.*
1f1d4f67 55%define filterout_c -f[-a-z0-9=]*
46479e07 56
3294533f 57%description
58The FreeType engine is a free and portable TrueType font rendering
59engine. It has been developed to provide TrueType support to a great
60variety of platforms and environments.
61
62Note that FreeType is a *library*. It is not a font server for your
63favorite platform, even though it was designed to be used in many of
64them. Note also that it is *not* a complete text-rendering library.
65Its purpose is simply to open and manage font files, as well as load,
66hint and render individual glyphs efficiently. You can also see it as
67a "TrueType driver" for a higher-level library, though rendering text
68with it is extremely easy, as demo-ed by the test programs.
69
1e7243e1 70This package contains the cross version for Win32.
3294533f 71
72%description -l pl.UTF-8
73FreeType jest biblioteką służącą do rasteryzacji fontów
74TrueType. Jest to jedynie biblioteka, a nie serwer fontów, chociaż
75została ona zaprojektowana do używania także w takich serwerach.
76Nie jest to też kompletna biblioteka do rasteryzacji tekstu. Jej
77celem jest tylko odczytywanie i zarządzanie plikami z fontami oraz
78wczytywanie i wykonywanie hintingu i rasteryzacji poszczególnych
79glifów. Może być także uważana za "sterownik TrueType" dla
80bibliotek wyższego poziomu, jednak użycie samej biblioteki FreeType
81do rasteryzacji jest bardzo proste, co można zobaczyć w programach
82demonstracyjnych.
83
1e7243e1
JB
84Ten pakiet zawiera wersję skrośną dla Win32.
85
86%package static
7b9bae77
JB
87Summary: Static freetype library (cross MinGW32 version)
88Summary(pl.UTF-8): Statyczna biblioteka freetype (wersja skrośna MinGW32)
1e7243e1
JB
89Group: Development/Libraries
90Requires: %{name} = %{version}-%{release}
91
92%description static
7b9bae77 93Static freetype library (cross MinGW32 version).
1e7243e1
JB
94
95%description static -l pl.UTF-8
7b9bae77 96Statyczna biblioteka freetype (wersja skrośna MinGW32).
1e7243e1
JB
97
98%package dll
99Summary: DLL freetype library for Windows
100Summary(pl.UTF-8): Biblioteka DLL freetype dla Windows
101Group: Applications/Emulators
1f1d4f67 102Requires: crossmingw32-bzip2-dll
32e34d75 103%{?with_harfbuzz:Requires: crossmingw32-harfbuzz-dll >= 0.9.19}
1f1d4f67 104Requires: crossmingw32-libpng-dll
1e7243e1
JB
105Requires: crossmingw32-zlib-dll
106Requires: wine
107
108%description dll
109DLL freetype library for Windows.
110
111%description dll -l pl.UTF-8
112Biblioteka DLL freetype dla Windows.
3294533f 113
114%prep
8bddf7fd 115%setup -q -n %{realname}-%{version}
3294533f 116
117%build
1f1d4f67 118export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
3294533f 119CFLAGS="%{rpmcflags} \
1c57a66b
JB
120%{?with_lcd:-DFT_CONFIG_OPTION_SUBPIXEL_RENDERING} \
121-DTT_CONFIG_OPTION_SUBPIXEL_HINTING \
122" \
3294533f 123%configure \
1f1d4f67
JB
124 LIBPNG_CFLAGS="$(pkg-config --cflags libpng)" \
125 LIBPNG_LDFLAGS="$(pkg-config --libs libpng)" \
3294533f 126 --target=%{target} \
6181c873 127 --build=i686-pc-linux-gnu \
128 --host=%{target} \
badc5f1d
JB
129 --enable-shared \
130 %{!?with_harfbuzz:--without-harfbuzz}
3294533f 131
132%{__make}
133
134%install
135rm -rf $RPM_BUILD_ROOT
3294533f 136
137%{__make} install \
138 DESTDIR=$RPM_BUILD_ROOT
139
1e7243e1 140install -d $RPM_BUILD_ROOT%{_dlldir}
1f1d4f67 141%{__mv} -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
1e7243e1
JB
142
143%if 0%{!?debug:1}
144%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
145%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
146%endif
147
32e34d75
JB
148%{__rm} $RPM_BUILD_ROOT%{_bindir}/freetype-config \
149 $RPM_BUILD_ROOT%{_mandir}/man1/freetype-config.1
150
1f1d4f67 151%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/aclocal
1e7243e1 152
3294533f 153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%files
157%defattr(644,root,root,755)
0443e0ca 158%doc docs/{CHANGES,FTL.TXT,LICENSE.TXT,TODO,formats.txt,raster.txt}
1e7243e1
JB
159%{_libdir}/libfreetype.dll.a
160%{_libdir}/libfreetype.la
3294533f 161%{_includedir}/freetype2
5bc110d4 162%{_pkgconfigdir}/freetype2.pc
1e7243e1
JB
163
164%files static
165%defattr(644,root,root,755)
166%{_libdir}/libfreetype.a
167
168%files dll
169%defattr(644,root,root,755)
8bddf7fd 170%{_dlldir}/libfreetype-*.dll
This page took 0.123153 seconds and 4 git commands to generate.