]> git.pld-linux.org Git - packages/crossmingw32-fontconfig.git/blobdiff - crossmingw32-fontconfig.spec
- updated to 2.15.0
[packages/crossmingw32-fontconfig.git] / crossmingw32-fontconfig.spec
index e1b4bcbdff277834fd97ac0d81f0c503fc1ebb81..2c408e905b6bb613bbb085eb52d4769420fbeed1 100644 (file)
@@ -1,28 +1,30 @@
 %define                realname   fontconfig
-Summary:       Font configuration and customization tools - cross Mingw32 versoin
-Summary(pl.UTF-8):     Narzędzia do konfigurowania fontów - wersja skrośna dla Mingw32
+Summary:       Font configuration and customization tools - cross MinGW32 version
+Summary(pl.UTF-8):     Narzędzia do konfigurowania fontów - wersja skrośna dla MinGW32
 Name:          crossmingw32-%{realname}
-Version:       2.8.0
+Version:       2.15.0
 Release:       1
 License:       MIT
 Group:         Development/Libraries
-Source0:       http://fontconfig.org/release/%{realname}-%{version}.tar.gz
-# Source0-md5: 77e15a92006ddc2adbb06f840d591c0e
-Patch0:                %{realname}-blacklist.patch
-Patch1:                %{realname}-bitstream-cyberbit.patch
+Source0:       https://www.freedesktop.org/software/fontconfig/release/%{realname}-%{version}.tar.xz
+# Source0-md5: 5bb3a2829aecb22ae553c39099bd0d6a
+Patch0:                %{realname}-bitstream-cyberbit.patch
 URL:           http://fontconfig.org/
-BuildRequires: autoconf
-BuildRequires: automake
+BuildRequires: autoconf >= 2.71
+BuildRequires: automake >= 1:1.11
 BuildRequires: crossmingw32-expat
-BuildRequires: crossmingw32-freetype >= 2.1.5
+BuildRequires: crossmingw32-freetype >= 2.8.1
 BuildRequires: crossmingw32-gcc
-BuildRequires: libtool
+BuildRequires: gettext-tools >= 0.19.8
+BuildRequires: libtool >= 2:2.2
 BuildRequires: pkgconfig >= 1:0.15
+BuildRequires: sed >= 4.0
 Requires:      crossmingw32-expat
-Requires:      crossmingw32-freetype >= 2.1.5
+Requires:      crossmingw32-freetype >= 2.8.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                no_install_post_strip   1
+%define                _enable_debug_packages  0
 
 %define                target                  i386-mingw32
 %define                target_platform         i386-pc-mingw32
@@ -34,13 +36,17 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _dlldir                 /usr/share/wine/windows/system
 %define                __cc                    %{target}-gcc
 %define                __cxx                   %{target}-g++
+%define                __pkgconfig_provides    %{nil}
+%define                __pkgconfig_requires    %{nil}
 
 %ifnarch %{ix86}
 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
-%define                optflags        -O2
+# i486 instructions required for atomic operations
+%define                optflags        -O2 -march=i486
 %endif
-# -z options are invalid for mingw linker
+# -z options are invalid for mingw linker, most of -f options are Linux-specific
 %define                filterout_ld    -Wl,-z,.*
+%define                filterout_c     -f[-a-z0-9=]*
 
 %description
 Fontconfig is designed to locate fonts within the system and select
@@ -55,23 +61,23 @@ systemie i wybierania ich w zależności od potrzeb aplikacji.
 Paket ten zawiera wersję skrośną dla Win32.
 
 %package static
-Summary:       Static freetype library (cross mingw32 version)
-Summary(pl.UTF-8):     Statyczna biblioteka freetype (wersja skrośna mingw32)
+Summary:       Static freetype library (cross MinGW32 version)
+Summary(pl.UTF-8):     Statyczna biblioteka freetype (wersja skrośna MinGW32)
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description static
-Static freetype library (cross mingw32 version).
+Static freetype library (cross MinGW32 version).
 
 %description static -l pl.UTF-8
-Statyczna biblioteka freetype (wersja skrośna mingw32).
+Statyczna biblioteka freetype (wersja skrośna MinGW32).
 
 %package dll
 Summary:       DLL freetype library for Windows
 Summary(pl.UTF-8):     Biblioteka DLL freetype dla Windows
 Group:         Applications/Emulators
 Requires:      crossmingw32-expat-dll
-Requires:      crossmingw32-freetype-dll >= 2.1.5
+Requires:      crossmingw32-freetype-dll >= 2.8.1
 Requires:      wine
 
 %description dll
@@ -83,12 +89,12 @@ Biblioteka DLL freetype dla Windows.
 %prep
 %setup -q -n %{realname}-%{version}
 %patch0 -p1
-%patch1 -p1
 
 %build
 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
+%{__gettextize}
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
@@ -96,34 +102,41 @@ export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
        --target=%{target} \
        --host=%{target} \
        --with-arch=%{target} \
-       --disable-docs
+       --disable-docs \
+       --disable-silent-rules \
+       --enable-static
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
+# fc_cachedir=/dummy is to avoid creating ${DESTDIR}LOCAL_APPDATA_FONTCONFIG_CACHE dir
 %{__make} -j1 install \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       fc_cachedir=/dummy
 
 install -d $RPM_BUILD_ROOT%{_dlldir}
-mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
+%{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
 
 %if 0%{!?debug:1}
 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
 %endif
 
-rm -rf $RPM_BUILD_ROOT%{_datadir}/man
 # runtime
-rm -rf $RPM_BUILD_ROOT/etc/fonts
+%{__rm} -r $RPM_BUILD_ROOT/etc/fonts \
+       $RPM_BUILD_ROOT%{_datadir}/{fontconfig,locale,xml/fontconfig}
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/fc-*.exe
+# if needed, use ITS data from native package
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gettext/its
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS COPYING ChangeLog README
+%doc AUTHORS COPYING ChangeLog NEWS README.md
 %{_libdir}/libfontconfig.dll.a
 %{_libdir}/libfontconfig.la
 %{_libdir}/fontconfig.def
This page took 0.520123 seconds and 4 git commands to generate.