]> git.pld-linux.org Git - packages/crossmingw32-fontconfig.git/blob - crossmingw32-fontconfig.spec
2e7077242b95433dab137690fa7c02f1eb723838
[packages/crossmingw32-fontconfig.git] / crossmingw32-fontconfig.spec
1 %define         realname   fontconfig
2 Summary:        Font configuration and customization tools - cross MinGW32 version
3 Summary(pl.UTF-8):      Narzędzia do konfigurowania fontów - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        2.14.2
6 Release:        2
7 License:        MIT
8 Group:          Development/Libraries
9 Source0:        https://www.freedesktop.org/software/fontconfig/release/%{realname}-%{version}.tar.xz
10 # Source0-md5:  95261910ea727b5dd116b06fbfd84b1f
11 Patch0:         %{realname}-bitstream-cyberbit.patch
12 URL:            http://fontconfig.org/
13 BuildRequires:  autoconf >= 2.61
14 BuildRequires:  automake >= 1:1.11
15 BuildRequires:  crossmingw32-expat
16 BuildRequires:  crossmingw32-freetype >= 2.8.1
17 BuildRequires:  crossmingw32-gcc
18 BuildRequires:  gettext-tools >= 0.19.8
19 BuildRequires:  libtool >= 2:2.2
20 BuildRequires:  pkgconfig >= 1:0.15
21 BuildRequires:  sed >= 4.0
22 Requires:       crossmingw32-expat
23 Requires:       crossmingw32-freetype >= 2.8.1
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         no_install_post_strip   1
27 %define         _enable_debug_packages  0
28
29 %define         target                  i386-mingw32
30 %define         target_platform         i386-pc-mingw32
31
32 %define         _sysprefix              /usr
33 %define         _prefix                 %{_sysprefix}/%{target}
34 %define         _libdir                 %{_prefix}/lib
35 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
36 %define         _dlldir                 /usr/share/wine/windows/system
37 %define         __cc                    %{target}-gcc
38 %define         __cxx                   %{target}-g++
39 %define         __pkgconfig_provides    %{nil}
40 %define         __pkgconfig_requires    %{nil}
41
42 %ifnarch %{ix86}
43 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
44 # i486 instructions required for atomic operations
45 %define         optflags        -O2 -march=i486
46 %endif
47 # -z options are invalid for mingw linker, most of -f options are Linux-specific
48 %define         filterout_ld    -Wl,-z,.*
49 %define         filterout_c     -f[-a-z0-9=]*
50
51 %description
52 Fontconfig is designed to locate fonts within the system and select
53 them according to requirements specified by applications.
54
55 This package contains the cross version for Win32.
56
57 %description -l pl.UTF-8
58 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
59 systemie i wybierania ich w zależności od potrzeb aplikacji.
60
61 Paket ten zawiera wersję skrośną dla Win32.
62
63 %package static
64 Summary:        Static freetype library (cross MinGW32 version)
65 Summary(pl.UTF-8):      Statyczna biblioteka freetype (wersja skrośna MinGW32)
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68
69 %description static
70 Static freetype library (cross MinGW32 version).
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka freetype (wersja skrośna MinGW32).
74
75 %package dll
76 Summary:        DLL freetype library for Windows
77 Summary(pl.UTF-8):      Biblioteka DLL freetype dla Windows
78 Group:          Applications/Emulators
79 Requires:       crossmingw32-expat-dll
80 Requires:       crossmingw32-freetype-dll >= 2.8.1
81 Requires:       wine
82
83 %description dll
84 DLL freetype library for Windows.
85
86 %description dll -l pl.UTF-8
87 Biblioteka DLL freetype dla Windows.
88
89 %prep
90 %setup -q -n %{realname}-%{version}
91 %patch0 -p1
92
93 %build
94 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
95 %{__gettextize}
96 %{__libtoolize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         --target=%{target} \
103         --host=%{target} \
104         --with-arch=%{target} \
105         --disable-docs \
106         --disable-silent-rules \
107         --enable-static
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 # fc_cachedir=/dummy is to avoid creating ${DESTDIR}LOCAL_APPDATA_FONTCONFIG_CACHE dir
115 %{__make} -j1 install \
116         DESTDIR=$RPM_BUILD_ROOT \
117         fc_cachedir=/dummy
118
119 install -d $RPM_BUILD_ROOT%{_dlldir}
120 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
121
122 %if 0%{!?debug:1}
123 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
124 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
125 %endif
126
127 # runtime
128 %{__rm} -r $RPM_BUILD_ROOT/etc/fonts \
129         $RPM_BUILD_ROOT%{_datadir}/{fontconfig,locale,xml/fontconfig}
130 %{__rm} $RPM_BUILD_ROOT%{_bindir}/fc-*.exe
131 # if needed, use ITS data from native package
132 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gettext/its
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %doc AUTHORS COPYING ChangeLog README
140 %{_libdir}/libfontconfig.dll.a
141 %{_libdir}/libfontconfig.la
142 %{_libdir}/fontconfig.def
143 %dir %{_includedir}/fontconfig
144 %{_includedir}/fontconfig/*.h
145 %{_pkgconfigdir}/fontconfig.pc
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libfontconfig.a
150
151 %files dll
152 %defattr(644,root,root,755)
153 %{_dlldir}/libfontconfig-*.dll
This page took 0.27855 seconds and 2 git commands to generate.