]> git.pld-linux.org Git - packages/crossmingw32-boost.git/blobdiff - crossmingw32-boost.spec
- up to 1.61.0
[packages/crossmingw32-boost.git] / crossmingw32-boost.spec
index 1442cba9394ee2938e5376430130cd7cdc768236..f8d8ff7d2539d44f1559d188d7a0a382ffa42cd0 100644 (file)
@@ -1,18 +1,21 @@
+# TODO: fix serialization
 #
 # Conditional build:
-%bcond_with    context         # enable Boost Context [gas+PE combination not supported]
+%bcond_without context         # Boost Context and dependent modules [gas+PE not supported by upstream]
+%bcond_with    serialization   # Boost Serialization [broken for MinGW in 1.61: https://svn.boost.org/trac/boost/ticket/12205]
 #
 %define                realname        boost
 Summary:       The Boost C++ Libraries - MinGW32 cross version
 Summary(pl.UTF-8):     Biblioteki C++ "Boost" - wersja skrośna dla MinGW32
 Name:          crossmingw32-%{realname}
-Version:       1.55.0
+Version:       1.61.0
 %define        fver    %(echo %{version} | tr . _)
 Release:       1
 License:       Boost Software License and others
 Group:         Development/Libraries
 Source0:       http://downloads.sourceforge.net/boost/%{realname}_%{fver}.tar.bz2
-# Source0-md5: d6eef4b4cacb2183f2bf265a5a03a354
+# Source0-md5: 6095876341956f65f9d35939ccea1a9f
+Patch0:                boost-windows-decl.patch
 URL:           http://www.boost.org/
 BuildRequires: crossmingw32-bzip2
 BuildRequires: crossmingw32-gcc-c++
@@ -46,7 +49,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                filterout_c     -f[-a-z0-9=]*
 %define                filterout_cxx   -f[-a-z0-9=]*
 
-%define                abi_tag         1_55
+%define                abi_tag         1_61
 
 %description
 The Boost web site provides free peer-reviewed portable C++ source
@@ -94,12 +97,15 @@ Boost - biblioteki DLL dla Windows.
 
 %prep
 %setup -q -n %{realname}_%{fver}
+%patch0 -p1
 
-echo 'using gcc : : %{target}-g++ : <cxxflags>"%{rpmcxxflags}"' \
-       '<archiver>%{target}-ar ;' >tools/build/v2/user-config.jam
+echo 'using gcc : : %{target}-g++ : ' \
+       '<cxxflags>"%{rpmcxxflags}"' \
+       '<archiver>%{target}-ar' \
+       '<rc>%{target}-windres ;' >tools/build/src/user-config.jam
 
 # use Windows Message Compiler, not Midnight Commander
-%{__sed} -i -e 's,mc $(MCFLAGS),%{target}-windmc $(MCFLAGS),' tools/build/v2/tools/mc.jam
+%{__sed} -i -e 's,mc $(MCFLAGS),%{target}-windmc $(MCFLAGS),' tools/build/src/tools/mc.jam
 
 %build
 ./bootstrap.sh --prefix=%{_prefix}
@@ -108,9 +114,12 @@ echo 'using gcc : : %{target}-g++ : <cxxflags>"%{rpmcxxflags}"' \
        %{_smp_mflags} \
        -sBZIP2_BINARY=bzip2 \
        --layout=versioned \
-       %{!?with_context:--without-context --without-coroutine} \
+       %{!?with_context:--without-context --without-coroutine --without-coroutine2} \
        --without-python \
+       %{!?with_serialization:--without-serialization} \
        --without-test \
+       abi=ms \
+       binary-format=pe \
        debug-symbols=on \
        inlining=on \
        link=static,shared \
@@ -140,6 +149,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libboost_atomic-mgw*-mt-%{abi_tag}.dll.a
 %{_libdir}/libboost_chrono-mgw*-mt-%{abi_tag}.dll.a
+%{_libdir}/libboost_container-mgw*-mt-%{abi_tag}.dll.a
 %{?with_context:%{_libdir}/libboost_context-mgw*-mt-%{abi_tag}.dll.a}
 %{?with_context:%{_libdir}/libboost_coroutine-mgw*-mt-%{abi_tag}.dll.a}
 %{_libdir}/libboost_date_time-mgw*-mt-%{abi_tag}.dll.a
@@ -158,21 +168,24 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libboost_program_options-mgw*-mt-%{abi_tag}.dll.a
 %{_libdir}/libboost_random-mgw*-mt-%{abi_tag}.dll.a
 %{_libdir}/libboost_regex-mgw*-mt-%{abi_tag}.dll.a
-%{_libdir}/libboost_serialization-mgw*-mt-%{abi_tag}.dll.a
+%{?with_serialization:%{_libdir}/libboost_serialization-mgw*-mt-%{abi_tag}.dll.a}
 %{_libdir}/libboost_signals-mgw*-mt-%{abi_tag}.dll.a
 %{_libdir}/libboost_system-mgw*-mt-%{abi_tag}.dll.a
 %{_libdir}/libboost_thread_win32-mgw*-mt-%{abi_tag}.dll.a
 %{_libdir}/libboost_timer-mgw*-mt-%{abi_tag}.dll.a
+%{_libdir}/libboost_type_erasure-mgw*-mt-%{abi_tag}.dll.a
 %{_libdir}/libboost_wave-mgw*-mt-%{abi_tag}.dll.a
-%{_libdir}/libboost_wserialization-mgw*-mt-%{abi_tag}.dll.a
+%{?with_serialization:%{_libdir}/libboost_wserialization-mgw*-mt-%{abi_tag}.dll.a}
 # static-only
 %{_libdir}/libboost_exception-mgw*-mt-%{abi_tag}.a
+%{_libdir}/libboost_unit_test_framework-mgw*-mt-%{abi_tag}.a
 %{_includedir}/boost
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libboost_atomic-mgw*-mt-%{abi_tag}.a
 %{_libdir}/libboost_chrono-mgw*-mt-%{abi_tag}.a
+%{_libdir}/libboost_container-mgw*-mt-%{abi_tag}.a
 %{?with_context:%{_libdir}/libboost_context-mgw*-mt-%{abi_tag}.a}
 %{?with_context:%{_libdir}/libboost_coroutine-mgw*-mt-%{abi_tag}.a}
 %{_libdir}/libboost_date_time-mgw*-mt-%{abi_tag}.a
@@ -191,20 +204,22 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libboost_program_options-mgw*-mt-%{abi_tag}.a
 %{_libdir}/libboost_random-mgw*-mt-%{abi_tag}.a
 %{_libdir}/libboost_regex-mgw*-mt-%{abi_tag}.a
-%{_libdir}/libboost_serialization-mgw*-mt-%{abi_tag}.a
+%{?with_serialization:%{_libdir}/libboost_serialization-mgw*-mt-%{abi_tag}.a}
 %{_libdir}/libboost_signals-mgw*-mt-%{abi_tag}.a
 %{_libdir}/libboost_system-mgw*-mt-%{abi_tag}.a
 %{_libdir}/libboost_thread_win32-mgw*-mt-%{abi_tag}.a
 %{_libdir}/libboost_timer-mgw*-mt-%{abi_tag}.a
+%{_libdir}/libboost_type_erasure-mgw*-mt-%{abi_tag}.a
 %{_libdir}/libboost_wave-mgw*-mt-%{abi_tag}.a
-%{_libdir}/libboost_wserialization-mgw*-mt-%{abi_tag}.a
+%{?with_serialization:%{_libdir}/libboost_wserialization-mgw*-mt-%{abi_tag}.a}
 
 %files dll
 %defattr(644,root,root,755)
 %{_dlldir}/libboost_atomic-mgw*-mt-%{abi_tag}.dll
 %{_dlldir}/libboost_chrono-mgw*-mt-%{abi_tag}.dll
-%{?with_context:%{_libdir}/libboost_context-mgw*-mt-%{abi_tag}.dll}
-%{?with_context:%{_libdir}/libboost_coroutine-mgw*-mt-%{abi_tag}.dll}
+%{_dlldir}/libboost_container-mgw*-mt-%{abi_tag}.dll
+%{?with_context:%{_dlldir}/libboost_context-mgw*-mt-%{abi_tag}.dll}
+%{?with_context:%{_dlldir}/libboost_coroutine-mgw*-mt-%{abi_tag}.dll}
 %{_dlldir}/libboost_date_time-mgw*-mt-%{abi_tag}.dll
 %{_dlldir}/libboost_filesystem-mgw*-mt-%{abi_tag}.dll
 %{_dlldir}/libboost_graph-mgw*-mt-%{abi_tag}.dll
@@ -221,10 +236,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_dlldir}/libboost_program_options-mgw*-mt-%{abi_tag}.dll
 %{_dlldir}/libboost_random-mgw*-mt-%{abi_tag}.dll
 %{_dlldir}/libboost_regex-mgw*-mt-%{abi_tag}.dll
-%{_dlldir}/libboost_serialization-mgw*-mt-%{abi_tag}.dll
+%{?with_serialization:%{_dlldir}/libboost_serialization-mgw*-mt-%{abi_tag}.dll}
 %{_dlldir}/libboost_signals-mgw*-mt-%{abi_tag}.dll
 %{_dlldir}/libboost_system-mgw*-mt-%{abi_tag}.dll
 %{_dlldir}/libboost_thread_win32-mgw*-mt-%{abi_tag}.dll
 %{_dlldir}/libboost_timer-mgw*-mt-%{abi_tag}.dll
+%{_dlldir}/libboost_type_erasure-mgw*-mt-%{abi_tag}.dll
 %{_dlldir}/libboost_wave-mgw*-mt-%{abi_tag}.dll
-%{_dlldir}/libboost_wserialization-mgw*-mt-%{abi_tag}.dll
+%{?with_serialization:%{_dlldir}/libboost_wserialization-mgw*-mt-%{abi_tag}.dll}
This page took 0.134515 seconds and 4 git commands to generate.