]> git.pld-linux.org Git - packages/crossmingw32-boost.git/blob - crossmingw32-boost.spec
419b9b5a01556a78801489110b3c26845b37f35d
[packages/crossmingw32-boost.git] / crossmingw32-boost.spec
1 #
2 # Conditional build:
3 %bcond_with     serialization   # enable Boost Serialization
4 #
5 %define         realname        boost
6 Summary:        The Boost C++ Libraries - MinGW32 cross version
7 Summary(pl.UTF-8):      Biblioteki C++ "Boost" - wersja skrośna dla MinGW32
8 Name:           crossmingw32-%{realname}
9 Version:        1.44.0
10 %define fver    %(echo %{version} | tr . _)
11 Release:        1
12 License:        Boost Software License and others
13 Group:          Development/Libraries
14 Source0:        http://downloads.sourceforge.net/boost/%{realname}_%{fver}.tar.bz2
15 # Source0-md5:  f02578f5218f217a9f20e9c30e119c6a
16 URL:            http://www.boost.org/
17 BuildRequires:  boost-jam >= 3.1.12
18 BuildRequires:  crossmingw32-bzip2
19 BuildRequires:  crossmingw32-gcc-c++
20 BuildRequires:  crossmingw32-runtime
21 BuildRequires:  crossmingw32-w32api
22 BuildRequires:  crossmingw32-zlib
23 %{?with_serialization:BuildRequires:    wine-programs}
24 Requires:       crossmingw32-bzip2
25 Requires:       crossmingw32-runtime
26 Requires:       crossmingw32-zlib
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         no_install_post_strip   1
30
31 %define         target          i386-mingw32
32 %define         target_platform i386-pc-mingw32
33
34 %define         _sysprefix      /usr
35 %define         _prefix         %{_sysprefix}/%{target}
36 %define         _libdir         %{_prefix}/lib
37 %define         _dlldir         /usr/share/wine/windows/system
38
39 %define         __cc            %{target}-gcc
40 %define         __cxx           %{target}-g++
41
42 %ifnarch %{ix86}
43 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
44 %define         optflags        -O2
45 %endif
46
47 %description
48 The Boost web site provides free peer-reviewed portable C++ source
49 libraries. The emphasis is on libraries which work well with the C++
50 Standard Library. One goal is to establish "existing practice" and
51 provide reference implementations so that the Boost libraries are
52 suitable for eventual standardization. Some of the libraries have
53 already been proposed for inclusion in the C++ Standards Committee's
54 upcoming C++ Standard Library Technical Report.
55
56 %description -l pl.UTF-8
57 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
58 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
59 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
60 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
61 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
62 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
63 Raporcie Technicznym Biblioteki Standardowej C++.
64
65 %package static
66 Summary:        Static Boost libraries (cross MinGW32 version)
67 Summary(pl.UTF-8):      Statyczne biblioteki Boost (wersja skrośna MinGW32)
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70
71 %description static
72 Static Boost libraries (cross MinGW32 version).
73
74 %description static -l pl.UTF-8
75 Statyczne biblioteki Boost (wersja skrośna MinGW32).
76
77 %package dll
78 Summary:        Boost - DLL libraries for Windows
79 Summary(pl.UTF-8):      Boost - biblioteki DLL dla Windows
80 Group:          Applications/Emulators
81 Requires:       crossmingw32-bzip2-dll
82 Requires:       crossmingw32-zlib-dll
83 Requires:       wine
84
85 %description dll
86 Boost - DLL libraries for Windows.
87
88 %description dll -l pl.UTF-8
89 Boost - biblioteki DLL dla Windows.
90
91 %prep
92 %setup -q -n %{realname}_%{fver}
93
94 echo 'using gcc : : %{target}-g++ : <cxxflags>"%{rpmcxxflags}"' \
95         '<archiver>%{target}-ar ;' >tools/build/v2/user-config.jam
96
97 %build
98 %if %{with serialization}
99 export WINEPREFIX=`pwd`/wineprefix
100 install -d wineprefix/drive_c/windows/system32
101 install %{_prefix}/bin/mingwm10.dll wineprefix/drive_c/windows/system32/
102 %endif
103
104 bjam \
105         -d2 \
106         --layout=versioned \
107         -sBZIP2_BINARY=bzip2 \
108         --toolset=gcc \
109         --without-python \
110         %{!?with_serialization:--without-serialization} \
111         --without-test \
112         variant=release \
113         debug-symbols=on \
114         inlining=on \
115         link=static,shared \
116         target-os=windows \
117         threading=multi \
118         threadapi=win32
119
120 %if 0%{!?debug:1}
121 %{target}-strip stage/lib/*.dll
122 %{target}-strip -g -R.comment -R.note stage/lib/*.a
123 %endif
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir},%{_dlldir}}
128
129 cp -r boost $RPM_BUILD_ROOT%{_includedir}
130 cp -a stage/lib/*.a $RPM_BUILD_ROOT%{_libdir}
131 install stage/lib/*.dll $RPM_BUILD_ROOT%{_dlldir}
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files
137 %defattr(644,root,root,755)
138 %{_libdir}/libboost_*-mgw*-mt-1_44.dll.a
139 %{_libdir}/libboost_*-mgw*-mt.dll.a
140 %{_includedir}/boost
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libboost_*-mgw*-mt-1_44.a
145 %{_libdir}/libboost_*-mgw*-mt.a
146
147 %files dll
148 %defattr(644,root,root,755)
149 %{_dlldir}/libboost_*-mgw*-mt-*.dll
This page took 0.10097 seconds and 3 git commands to generate.