]> git.pld-linux.org Git - packages/crossmingw32-binutils.git/blob - crossmingw32-binutils.spec
c3e147fe93fa88d49a7c114686759e50e3d9db2d
[packages/crossmingw32-binutils.git] / crossmingw32-binutils.spec
1 Summary:        Cross MinGW32 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW32 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW32 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW32 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW32 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW32 binutils
7 Name:           crossmingw32-binutils
8 Version:        2.35
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Tools
12 Source0:        https://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.lz
13 # Source0-md5:  28a8e8831b93de22468df1d8a9a74b00
14 URL:            http://sources.redhat.com/binutils/
15 BuildRequires:  autoconf >= 2.69
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  bash
18 BuildRequires:  bison
19 BuildRequires:  flex
20 BuildRequires:  gettext-tools
21 BuildRequires:  lzip
22 BuildRequires:  perl-tools-pod
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  texinfo >= 4.2
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         target          i386-mingw32
28 %define         arch            %{_prefix}/%{target}
29
30 %description
31 crossmingw32 is a complete cross-compiling development system for
32 building stand-alone Microsoft Windows applications under Linux using
33 the MinGW32 build libraries. This includes a binutils, gcc with g++
34 and objc, and libstdc++, all cross targeted to i386-mingw32, along
35 with supporting Win32 libraries in 'coff' format from free sources.
36
37 This package contains cross targeted binutils.
38
39 %description -l pl.UTF-8
40 crossmingw32 jest kompletnym systemem do kroskompilacji, pozwalającym
41 budować aplikacje MS Windows pod Linuksem używając bibliotek MinGW32.
42 System składa się z binutils, gcc z g++ i objc, libstdc++ - wszystkie
43 generujące kod dla platformy i386-mingw32, oraz z bibliotek w formacie
44 COFF.
45
46 Ten pakiet zawiera binutils generujące skrośnie binaria dla Win32.
47
48 %prep
49 %setup -q -n binutils-%{version}
50
51 # file contains hacks for ac 2.69 only
52 %{__rm} config/override.m4
53 %{__sed} -i '/^m4_include(config\/override\.m4/d' configure.ac
54
55 %build
56 cp -f /usr/share/automake/config.* .
57 %{__aclocal}
58 %{__autoconf}
59
60 # non-standard regeneration (needed because of libdir patch)
61 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
62 for dir in gas bfd; do
63         cd $dir || exit 1
64         %{__aclocal} -I .. -I ../config -I ../bfd
65         %{__automake} Makefile
66         %{__automake} doc/Makefile
67         %{__autoconf}
68         cd ..
69 done
70
71 # We don't install libbfd (nor use shared binutils libraries) to avoid
72 # conflict with native binutils.
73
74 # ldscripts won't be generated properly if SHELL is not bash...
75 CFLAGS="%{rpmcflags}" \
76 LDFLAGS="%{rpmldflags}" \
77 CONFIG_SHELL="/bin/bash" \
78 ./configure \
79         --disable-nls \
80         --disable-shared \
81         --prefix=%{_prefix} \
82         --libdir=%{_libdir} \
83         --mandir=%{_mandir} \
84         --infodir=%{_infodir} \
85         --host=%{_target_platform} \
86         --build=%{_target_platform} \
87         --target=%{target}
88
89 %{__make} all \
90         tooldir=%{_prefix}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         INSTALL='$$s/install-sh -c' \
97         prefix=$RPM_BUILD_ROOT%{_prefix} \
98         mandir=$RPM_BUILD_ROOT%{_mandir} \
99         infodir=$RPM_BUILD_ROOT%{_infodir} \
100         libdir=$RPM_BUILD_ROOT%{_libdir}
101
102 # not prefixed, keep infos only from native packages
103 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
104
105 # "filesystem" for crossmingw32-* packages (move to crossmingw32-dirs?)
106 install -d $RPM_BUILD_ROOT%{arch}/lib/pkgconfig
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %doc README
114 # mingw32 directory tree
115 %dir %{arch}
116 %dir %{arch}/lib
117 %dir %{arch}/lib/pkgconfig
118 %dir %{arch}/bin
119 # binutils files
120 %attr(755,root,root) %{arch}/bin/ar
121 %attr(755,root,root) %{arch}/bin/as
122 %attr(755,root,root) %{arch}/bin/dlltool
123 %attr(755,root,root) %{arch}/bin/ld
124 %attr(755,root,root) %{arch}/bin/ld.bfd
125 %attr(755,root,root) %{arch}/bin/nm
126 %attr(755,root,root) %{arch}/bin/objcopy
127 %attr(755,root,root) %{arch}/bin/objdump
128 %attr(755,root,root) %{arch}/bin/ranlib
129 %attr(755,root,root) %{arch}/bin/readelf
130 %attr(755,root,root) %{arch}/bin/strip
131 %{arch}/lib/ldscripts
132 %attr(755,root,root) %{_bindir}/%{target}-addr2line
133 %attr(755,root,root) %{_bindir}/%{target}-ar
134 %attr(755,root,root) %{_bindir}/%{target}-as
135 %attr(755,root,root) %{_bindir}/%{target}-c++filt
136 %attr(755,root,root) %{_bindir}/%{target}-dlltool
137 %attr(755,root,root) %{_bindir}/%{target}-dllwrap
138 %attr(755,root,root) %{_bindir}/%{target}-elfedit
139 %attr(755,root,root) %{_bindir}/%{target}-gprof
140 %attr(755,root,root) %{_bindir}/%{target}-ld
141 %attr(755,root,root) %{_bindir}/%{target}-ld.bfd
142 %attr(755,root,root) %{_bindir}/%{target}-nm
143 %attr(755,root,root) %{_bindir}/%{target}-objcopy
144 %attr(755,root,root) %{_bindir}/%{target}-objdump
145 %attr(755,root,root) %{_bindir}/%{target}-ranlib
146 %attr(755,root,root) %{_bindir}/%{target}-readelf
147 %attr(755,root,root) %{_bindir}/%{target}-size
148 %attr(755,root,root) %{_bindir}/%{target}-strings
149 %attr(755,root,root) %{_bindir}/%{target}-strip
150 %attr(755,root,root) %{_bindir}/%{target}-windmc
151 %attr(755,root,root) %{_bindir}/%{target}-windres
152 %{_mandir}/man1/%{target}-addr2line.1*
153 %{_mandir}/man1/%{target}-ar.1*
154 %{_mandir}/man1/%{target}-as.1*
155 %{_mandir}/man1/%{target}-c++filt.1*
156 %{_mandir}/man1/%{target}-dlltool.1*
157 %{_mandir}/man1/%{target}-elfedit.1*
158 %{_mandir}/man1/%{target}-gprof.1*
159 %{_mandir}/man1/%{target}-ld.1*
160 %{_mandir}/man1/%{target}-nm.1*
161 %{_mandir}/man1/%{target}-objcopy.1*
162 %{_mandir}/man1/%{target}-objdump.1*
163 %{_mandir}/man1/%{target}-ranlib.1*
164 %{_mandir}/man1/%{target}-readelf.1*
165 %{_mandir}/man1/%{target}-size.1*
166 %{_mandir}/man1/%{target}-strings.1*
167 %{_mandir}/man1/%{target}-strip.1*
168 %{_mandir}/man1/%{target}-windmc.1*
169 %{_mandir}/man1/%{target}-windres.1*
This page took 0.365816 seconds and 2 git commands to generate.