]> git.pld-linux.org Git - packages/crossmingw32-binutils.git/blob - crossmingw32-binutils.spec
6abc3b5a96a5dc2c127b115b11939dde3d68f05f
[packages/crossmingw32-binutils.git] / crossmingw32-binutils.spec
1 Summary:        Cross MinGW32 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW32 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW32 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW32 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW32 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW32 binutils
7 Name:           crossmingw32-binutils
8 Version:        2.20.51.0.11
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Tools
12 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
13 # Source0-md5:  d2306466e669700abbb3d1a64b10d5d2
14 URL:            http://sources.redhat.com/binutils/
15 BuildRequires:  automake
16 BuildRequires:  bash
17 BuildRequires:  bison
18 BuildRequires:  flex
19 BuildRequires:  gettext-devel
20 BuildRequires:  perl-tools-pod
21 BuildRequires:  texinfo >= 4.2
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         target          i386-mingw32
25 %define         arch            %{_prefix}/%{target}
26
27 %description
28 crossmingw32 is a complete cross-compiling development system for
29 building stand-alone Microsoft Windows applications under Linux using
30 the MinGW32 build libraries. This includes a binutils, gcc with g++
31 and objc, and libstdc++, all cross targeted to i386-mingw32, along
32 with supporting Win32 libraries in 'coff' format from free sources.
33
34 This package contains cross targeted binutils.
35
36 %description -l pl.UTF-8
37 crossmingw32 jest kompletnym systemem do kroskompilacji, pozwalającym
38 budować aplikacje MS Windows pod Linuksem używając bibliotek MinGW32.
39 System składa się z binutils, gcc z g++ i objc, libstdc++ - wszystkie
40 generujące kod dla platformy i386-mingw32, oraz z bibliotek w formacie
41 COFF.
42
43 Ten pakiet zawiera binutils generujące skrośnie binaria dla Win32.
44
45 %prep
46 %setup -q -n binutils-%{version}
47
48 %build
49 cp /usr/share/automake/config.sub .
50
51 # Because of a bug in binutils-2.9.1, a cross libbfd.so* is not named
52 # lib<target>bfd.so*. To prevent confusion with native binutils, we
53 # forget about shared libraries right now, and do not install libbfd.a
54 # [the same applies to binutils 2.10.1.0.4]
55
56 # ldscripts won't be generated properly if SHELL is not bash...
57 CFLAGS="%{rpmcflags}" \
58 LDFLAGS="%{rpmldflags}" \
59 CONFIG_SHELL="/bin/bash" \
60 ./configure \
61         --disable-nls \
62         --disable-shared \
63         --prefix=%{_prefix} \
64         --libdir=%{_libdir} \
65         --mandir=%{_mandir} \
66         --infodir=%{_infodir} \
67         --host=%{_target_platform} \
68         --build=%{_target_platform} \
69         --target=%{target}
70
71 %{__make} all \
72         tooldir=%{_prefix}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         INSTALL='$$s/install-sh -c' \
79         prefix=$RPM_BUILD_ROOT%{_prefix} \
80         mandir=$RPM_BUILD_ROOT%{_mandir} \
81         infodir=$RPM_BUILD_ROOT%{_infodir} \
82         libdir=$RPM_BUILD_ROOT%{_libdir}
83
84 # remove this man page unless we cross-build for netware platform.
85 # however, this should be done in Makefiles.
86 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/*nlmconv.1
87
88 # libiberty.a is ELF not PE
89 rm -f $RPM_BUILD_ROOT%{arch}/lib/libiberty.a
90
91 # "filesystem" for crossmingw32-* packages (move to crossmingw32-dirs?)
92 install -d $RPM_BUILD_ROOT%{arch}/lib/pkgconfig
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc README
100 # mingw32 directory tree
101 %dir %{arch}
102 %dir %{arch}/lib
103 %dir %{arch}/lib/pkgconfig
104 %dir %{arch}/bin
105 # binutils files
106 %attr(755,root,root) %{arch}/bin/ar
107 %attr(755,root,root) %{arch}/bin/as
108 %attr(755,root,root) %{arch}/bin/dlltool
109 %attr(755,root,root) %{arch}/bin/ld
110 %attr(755,root,root) %{arch}/bin/nm
111 %attr(755,root,root) %{arch}/bin/objcopy
112 %attr(755,root,root) %{arch}/bin/objdump
113 %attr(755,root,root) %{arch}/bin/ranlib
114 %attr(755,root,root) %{arch}/bin/strip
115 %{arch}/lib/ldscripts
116 %attr(755,root,root) %{_bindir}/%{target}-addr2line
117 %attr(755,root,root) %{_bindir}/%{target}-ar
118 %attr(755,root,root) %{_bindir}/%{target}-as
119 %attr(755,root,root) %{_bindir}/%{target}-c++filt
120 %attr(755,root,root) %{_bindir}/%{target}-dlltool
121 %attr(755,root,root) %{_bindir}/%{target}-dllwrap
122 %attr(755,root,root) %{_bindir}/%{target}-elfedit
123 %attr(755,root,root) %{_bindir}/%{target}-gprof
124 %attr(755,root,root) %{_bindir}/%{target}-ld
125 %attr(755,root,root) %{_bindir}/%{target}-nm
126 %attr(755,root,root) %{_bindir}/%{target}-objcopy
127 %attr(755,root,root) %{_bindir}/%{target}-objdump
128 %attr(755,root,root) %{_bindir}/%{target}-ranlib
129 %attr(755,root,root) %{_bindir}/%{target}-readelf
130 %attr(755,root,root) %{_bindir}/%{target}-size
131 %attr(755,root,root) %{_bindir}/%{target}-strings
132 %attr(755,root,root) %{_bindir}/%{target}-strip
133 %attr(755,root,root) %{_bindir}/%{target}-windmc
134 %attr(755,root,root) %{_bindir}/%{target}-windres
135 %{_mandir}/man1/%{target}-addr2line.1*
136 %{_mandir}/man1/%{target}-ar.1*
137 %{_mandir}/man1/%{target}-as.1*
138 %{_mandir}/man1/%{target}-c++filt.1*
139 %{_mandir}/man1/%{target}-dlltool.1*
140 %{_mandir}/man1/%{target}-elfedit.1*
141 %{_mandir}/man1/%{target}-gprof.1*
142 %{_mandir}/man1/%{target}-ld.1*
143 %{_mandir}/man1/%{target}-nm.1*
144 %{_mandir}/man1/%{target}-objcopy.1*
145 %{_mandir}/man1/%{target}-objdump.1*
146 %{_mandir}/man1/%{target}-ranlib.1*
147 %{_mandir}/man1/%{target}-readelf.1*
148 %{_mandir}/man1/%{target}-size.1*
149 %{_mandir}/man1/%{target}-strings.1*
150 %{_mandir}/man1/%{target}-strip.1*
151 %{_mandir}/man1/%{target}-windmc.1*
152 %{_mandir}/man1/%{target}-windres.1*
This page took 0.062945 seconds and 2 git commands to generate.