]> git.pld-linux.org Git - packages/crossmingw32-atk.git/blob - crossmingw32-atk.spec
c6e06cc0bb95f3fc28cfe05238ad2f521d4da9fc
[packages/crossmingw32-atk.git] / crossmingw32-atk.spec
1 %define         realname   atk
2 Summary:        ATK - Accessibility Toolkit - cross MinGW32 version
3 Summary(pl.UTF-8):      ATK - biblioteka ułatwiająca niepełnosprawnym korzystanie z komputerów - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        2.8.0
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/atk/2.8/%{realname}-%{version}.tar.xz
10 # Source0-md5:  c652bd25530825d604dae1c1ebd2da02
11 URL:            http://library.gnome.org/devel/atk/
12 BuildRequires:  autoconf >= 2.63
13 BuildRequires:  automake >= 1:1.10
14 BuildRequires:  crossmingw32-gcc
15 BuildRequires:  crossmingw32-glib2 >= 2.32.0
16 BuildRequires:  libtool >= 2:2.2
17 BuildRequires:  perl-base
18 BuildRequires:  pkgconfig >= 1:0.15
19 BuildRequires:  rpmbuild(macros) >= 1.197
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 Requires:       crossmingw32-glib2 >= 2.32.0
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29
30 %define         _sysprefix              /usr
31 %define         _prefix                 %{_sysprefix}/%{target}
32 %define         _libdir                 %{_prefix}/lib
33 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
34 %define         _dlldir                 /usr/share/wine/windows/system
35 %define         __cc                    %{target}-gcc
36 %define         __cxx                   %{target}-g++
37
38 %ifnarch %{ix86}
39 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
40 %define         optflags        -O2
41 %endif
42 # -z options are invalid for mingw linker, most of -f options are Linux-specific
43 %define         filterout_ld    -Wl,-z,.*
44 %define         filterout_c     -f[-a-z0-9=]*
45
46 %description
47 The ATK library provides a set of interfaces for adding accessibility
48 support to applications and graphical user interface toolkits. By
49 supporting the ATK interfaces, an application or toolkit can be used
50 as tools such as screen readers and magnifiers, and alternative input
51 devices.
52
53 This package contains the cross version for Win32.
54
55 %description -l pl.UTF-8
56 Biblioteka ATK udostępnia zestaw interfejsów ułatwiających
57 niepełnosprawnym korzystanie z aplikacji i poszczególnych elementów
58 graficznego interfejsu użytkownika. Poprzez wykorzystanie interfejsów
59 ATK, aplikacja lub element interfejsu może być używany z takimi
60 narzędziami jak czytniki ekranu i narzędzia powiększające oraz
61 alternatywnymi urządzeniami wejściowymi.
62
63 Ten pakiet zawiera wersję skrośną dla Win32.
64
65 %package static
66 Summary:        Static atk library (cross MinGW32 version)
67 Summary(pl.UTF-8):      Statyczna biblioteka atk (wersja skrośna MinGW32)
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70
71 %description static
72 Static atk library (cross MinGW32 version).
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka atk (wersja skrośna MinGW32).
76
77 %package dll
78 Summary:        DLL atk library for Windows
79 Summary(pl.UTF-8):      Biblioteka DLL atk dla Windows
80 Group:          Applications/Emulators
81 Requires:       crossmingw32-glib2-dll >= 2.32.0
82 Requires:       wine
83
84 %description dll
85 DLL atk library for Windows.
86
87 %description dll -l pl.UTF-8
88 Biblioteka DLL atk dla Windows.
89
90 %prep
91 %setup -q -n %{realname}-%{version}
92
93 %build
94 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         --target=%{target} \
102         --host=%{target} \
103         --disable-gtk-doc \
104         --disable-silent-rules \
105         --enable-static
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} -j1 install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 install -d $RPM_BUILD_ROOT%{_dlldir}
116 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
117
118 %if 0%{!?debug:1}
119 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
120 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
121 %endif
122
123 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gtk-doc
124 # runtime
125 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS NEWS README
133 %{_libdir}/libatk-1.0.dll.a
134 %{_libdir}/libatk-1.0.la
135 %{_libdir}/atk-1.0.def
136 %{_includedir}/atk-1.0
137 %{_pkgconfigdir}/atk.pc
138
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/libatk-1.0.a
142
143 %files dll
144 %defattr(644,root,root,755)
145 %{_dlldir}/libatk-1.0-*.dll
This page took 0.081372 seconds and 2 git commands to generate.