]> git.pld-linux.org Git - packages/crossmingw32-atk.git/blame - crossmingw32-atk.spec
do not provide pkgconfig deps in system namespace
[packages/crossmingw32-atk.git] / crossmingw32-atk.spec
CommitLineData
83f64ac4 1%define realname atk
b28b1bf5
JB
2Summary: ATK - Accessibility Toolkit - cross MinGW32 version
3Summary(pl.UTF-8): ATK - biblioteka ułatwiająca niepełnosprawnym korzystanie z komputerów - wersja skrośna dla MinGW32
83f64ac4 4Name: crossmingw32-%{realname}
954ff1d6 5Version: 2.8.0
e0548e4b 6Release: 2
7412a699 7License: LGPL v2+
5a48950d 8Group: Development/Libraries
954ff1d6
JB
9Source0: http://ftp.gnome.org/pub/GNOME/sources/atk/2.8/%{realname}-%{version}.tar.xz
10# Source0-md5: c652bd25530825d604dae1c1ebd2da02
00f642c5 11URL: http://library.gnome.org/devel/atk/
0ce0ae78
JB
12BuildRequires: autoconf >= 2.63
13BuildRequires: automake >= 1:1.10
5a48950d 14BuildRequires: crossmingw32-gcc
75a76f18 15BuildRequires: crossmingw32-glib2 >= 2.32.0
cd45d277 16BuildRequires: libtool >= 2:2.2
7412a699 17BuildRequires: perl-base
b5e017bc 18BuildRequires: pkgconfig >= 1:0.15
7412a699 19BuildRequires: rpmbuild(macros) >= 1.197
cd45d277
JB
20BuildRequires: tar >= 1:1.22
21BuildRequires: xz
75a76f18 22Requires: crossmingw32-glib2 >= 2.32.0
7412a699 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define no_install_post_strip 1
26
27%define target i386-mingw32
28%define target_platform i386-pc-mingw32
7412a699 29
30%define _sysprefix /usr
31%define _prefix %{_sysprefix}/%{target}
83f64ac4 32%define _libdir %{_prefix}/lib
7412a699 33%define _pkgconfigdir %{_prefix}/lib/pkgconfig
5a48950d 34%define _dlldir /usr/share/wine/windows/system
7412a699 35%define __cc %{target}-gcc
36%define __cxx %{target}-g++
e0548e4b 37%define __pkgconfig_provides %{nil}
7412a699 38
2c1f632c
JB
39%ifnarch %{ix86}
40# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
41%define optflags -O2
42%endif
e6ed5599 43# -z options are invalid for mingw linker, most of -f options are Linux-specific
2c1f632c 44%define filterout_ld -Wl,-z,.*
e6ed5599 45%define filterout_c -f[-a-z0-9=]*
2c1f632c 46
7412a699 47%description
48The ATK library provides a set of interfaces for adding accessibility
49support to applications and graphical user interface toolkits. By
50supporting the ATK interfaces, an application or toolkit can be used
51as tools such as screen readers and magnifiers, and alternative input
52devices.
53
5a48950d
JB
54This package contains the cross version for Win32.
55
7412a699 56%description -l pl.UTF-8
57Biblioteka ATK udostępnia zestaw interfejsów ułatwiających
58niepełnosprawnym korzystanie z aplikacji i poszczególnych elementów
e5c005db
JB
59graficznego interfejsu użytkownika. Poprzez wykorzystanie interfejsów
60ATK, aplikacja lub element interfejsu może być używany z takimi
61narzędziami jak czytniki ekranu i narzędzia powiększające oraz
62alternatywnymi urządzeniami wejściowymi.
7412a699 63
5a48950d
JB
64Ten pakiet zawiera wersję skrośną dla Win32.
65
66%package static
b28b1bf5
JB
67Summary: Static atk library (cross MinGW32 version)
68Summary(pl.UTF-8): Statyczna biblioteka atk (wersja skrośna MinGW32)
5a48950d
JB
69Group: Development/Libraries
70Requires: %{name} = %{version}-%{release}
71
72%description static
b28b1bf5 73Static atk library (cross MinGW32 version).
5a48950d
JB
74
75%description static -l pl.UTF-8
b28b1bf5 76Statyczna biblioteka atk (wersja skrośna MinGW32).
5a48950d
JB
77
78%package dll
79Summary: DLL atk library for Windows
80Summary(pl.UTF-8): Biblioteka DLL atk dla Windows
81Group: Applications/Emulators
75a76f18 82Requires: crossmingw32-glib2-dll >= 2.32.0
5a48950d
JB
83Requires: wine
84
85%description dll
86DLL atk library for Windows.
87
88%description dll -l pl.UTF-8
89Biblioteka DLL atk dla Windows.
7412a699 90
91%prep
83f64ac4 92%setup -q -n %{realname}-%{version}
7412a699 93
94%build
b5e017bc 95export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
7412a699 96%{__libtoolize}
97%{__aclocal}
98%{__autoconf}
99%{__autoheader}
100%{__automake}
101%configure \
7412a699 102 --target=%{target} \
bedcf096 103 --host=%{target} \
104 --disable-gtk-doc \
cd45d277 105 --disable-silent-rules \
bedcf096 106 --enable-static
7412a699 107
108%{__make}
109
110%install
111rm -rf $RPM_BUILD_ROOT
112
f8b559df 113%{__make} -j1 install \
7412a699 114 DESTDIR=$RPM_BUILD_ROOT
115
5a48950d
JB
116install -d $RPM_BUILD_ROOT%{_dlldir}
117mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
118
119%if 0%{!?debug:1}
120%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
121%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
122%endif
123
cd45d277 124%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gtk-doc
5a48950d 125# runtime
cd45d277 126%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale
7412a699 127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
5a48950d 131%files
7412a699 132%defattr(644,root,root,755)
133%doc AUTHORS NEWS README
5a48950d
JB
134%{_libdir}/libatk-1.0.dll.a
135%{_libdir}/libatk-1.0.la
136%{_libdir}/atk-1.0.def
137%{_includedir}/atk-1.0
e5c005db 138%{_pkgconfigdir}/atk.pc
5a48950d
JB
139
140%files static
141%defattr(644,root,root,755)
142%{_libdir}/libatk-1.0.a
143
144%files dll
145%defattr(644,root,root,755)
146%{_dlldir}/libatk-1.0-*.dll
This page took 0.106879 seconds and 4 git commands to generate.