]> git.pld-linux.org Git - packages/crossmingw32-SDL_mixer.git/blob - crossmingw32-SDL_mixer.spec
e85c35f7c446bc409006e8e5ffd1c761f2017314
[packages/crossmingw32-SDL_mixer.git] / crossmingw32-SDL_mixer.spec
1 %define         realname        SDL_mixer
2 Summary:        Simple DirectMedia Layer - Sample Mixer Library - MinGW32 cross version
3 Name:           crossmingw32-%{realname}
4 Version:        1.2.12
5 Release:        1
6 License:        Zlib-like
7 Group:          Libraries
8 Source0:        http://www.libsdl.org/projects/SDL_mixer/release/%{realname}-%{version}.tar.gz
9 # Source0-md5:  e03ff73d77a55e3572ad0217131dc4a1
10 URL:            http://www.libsdl.org/projects/SDL_mixer/
11 BuildRequires:  crossmingw32-SDL
12 BuildRequires:  crossmingw32-gcc
13 BuildRequires:  crossmingw32-libvorbis
14 BuildRequires:  crossmingw32-w32api
15 Requires:       crossmingw32-SDL
16 Requires:       crossmingw32-runtime
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         no_install_post_strip   1
20
21 %define         target                  i386-mingw32
22 %define         target_platform         i386-pc-mingw32
23
24 %define         _sysprefix              /usr
25 %define         _prefix                 %{_sysprefix}/%{target}
26 %define         _libdir                 %{_prefix}/lib
27 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
28 %define         _dlldir                 /usr/share/wine/windows/system
29 %define         __cc                    %{target}-gcc
30 %define         __cxx                   %{target}-g++
31 %define         __pkgconfig_provides    %{nil}
32 %define         __pkgconfig_requires    %{nil}
33
34 # -z options are invalid for mingw linker
35 %define         filterout_ld            -Wl,-z,.*
36
37 %description
38 Due to popular demand, here is a simple multi-channel audio mixer. It
39 supports 4 channels of 16 bit stereo audio, plus a single channel of
40 music, mixed by the popular MikMod MOD, Timidity MIDI and SMPEG MP3
41 libraries.
42
43 This package contains the cross version for Win32.
44
45 %package static
46 Summary:        Static SDL_mixer libraries
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}-%{release}
49
50 %description static
51 Static SDL_mixer libraries (cross MinGW32 version).
52
53 %package dll
54 Summary:        SDL_mixer - DLL library for Windows
55 Group:          Applications/Emulators
56 Requires:       crossmingw32-SDL-dll >= 1.2.10
57 Requires:       wine
58
59 %description dll
60 SDL_mixer - DLL library for Windows.
61
62 %prep
63 %setup -q -n %{realname}-%{version}
64
65 %build
66 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
67 %configure \
68         --host=%{target} \
69         --target=%{target} \
70         --with-sdl-prefix=%{_prefix}
71
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 install -d $RPM_BUILD_ROOT%{_dlldir}
81 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
82
83 %if 0%{!?debug:1}
84 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
85 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
86 %endif
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc CHANGES COPYING README
94 %{_libdir}/libSDL_mixer.dll.a
95 %{_libdir}/libSDL_mixer.la
96 %{_includedir}/SDL/SDL_mixer.h
97 %{_pkgconfigdir}/SDL_mixer.pc
98
99 %files static
100 %defattr(644,root,root,755)
101 %{_libdir}/libSDL_mixer.a
102
103 %files dll
104 %defattr(644,root,root,755)
105 %{_dlldir}/SDL_mixer.dll
This page took 0.065211 seconds and 2 git commands to generate.