]> git.pld-linux.org Git - packages/crossmingw32-SDL_image.git/blob - crossmingw32-SDL_image.spec
- release 2 (by relup.sh)
[packages/crossmingw32-SDL_image.git] / crossmingw32-SDL_image.spec
1 %define         realname        SDL_image
2 Summary:        Simple DirectMedia Layer - Sample Image Loading Library - MinGW32 cross version
3 Summary(pl.UTF-8):      Przykładowa biblioteka do ładowania obrazków - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        1.2.12
6 Release:        2
7 License:        Zlib-like
8 Group:          Libraries
9 Source0:        http://www.libsdl.org/projects/SDL_image/release/%{realname}-%{version}.tar.gz
10 # Source0-md5:  a0f9098ebe5400f0bdc9b62e60797ecb
11 URL:            http://www.libsdl.org/projects/SDL_image/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  crossmingw32-SDL >= 1.2.10
15 BuildRequires:  crossmingw32-gcc
16 BuildRequires:  crossmingw32-libjpeg >= 7
17 BuildRequires:  crossmingw32-libpng >= 1.5.0
18 BuildRequires:  crossmingw32-libtiff >= 4
19 BuildRequires:  crossmingw32-libwebp >= 0.1.3
20 BuildRequires:  crossmingw32-w32api
21 BuildRequires:  libtool >= 2:2.0
22 BuildRequires:  pkgconfig >= 1:0.9.0
23 Requires:       crossmingw32-SDL >= 1.2.10
24 Requires:       crossmingw32-runtime
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         no_install_post_strip   1
28
29 %define         target                  i386-mingw32
30 %define         target_platform         i386-pc-mingw32
31
32 %define         _sysprefix              /usr
33 %define         _prefix                 %{_sysprefix}/%{target}
34 %define         _libdir                 %{_prefix}/lib
35 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
36 %define         _dlldir                 /usr/share/wine/windows/system
37 %define         __cc                    %{target}-gcc
38 %define         __cxx                   %{target}-g++
39 %define         __pkgconfig_provides    %{nil}
40
41 %ifnarch %{ix86}
42 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
43 %define         optflags        -O2
44 %endif
45 # -z options are invalid for mingw linker
46 %define         filterout_ld    -Wl,-z,.*
47
48 %description
49 This is a simple library to load images of various formats as SDL
50 surfaces. This library currently supports BMP, GIF, JPEG, LBM, PCX,
51 PNG, PNM (PBM/PGM/PPM), TGA, TIFF, WebP, XCF and XPM formats.
52
53 This package contains the cross version for Win32.
54
55 %description -l pl.UTF-8
56 Jest to prosta biblioteka służąca do ładowania różnego formatu
57 obrazków jako powierzchni SDL. W chwili obecnej biblioteka obsługuje
58 następujące formaty: BMP, GIF, JPEG, LBM, PCX, PNG, PNM (PBM/PGM/PPM),
59 TGA, TIFF, WebP, XCF oraz XPM.
60
61 Ten pakiet zawiera wersję skrośną dla Win32.
62
63 %package static
64 Summary:        Static SDL_image library (cross MinGW32 version)
65 Summary(pl.UTF-8):      Statyczna biblioteka SDL_image (wersja skrośna MinGW32)
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68
69 %description static
70 Static SDL_image library (cross MinGW32 version).
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka SDL_image (wersja skrośna MinGW32).
74
75 %package dll
76 Summary:        SDL_image - DLL library for Windows
77 Summary(pl.UTF-8):      SDL_image - biblioteka DLL dla Windows
78 Group:          Applications/Emulators
79 Requires:       crossmingw32-SDL-dll >= 1.2.10
80 Requires:       wine
81
82 %description dll
83 SDL_image - DLL library for Windows.
84
85 %description dll -l pl.UTF-8
86 SDL_image - biblioteka DLL dla Windows.
87
88 %prep
89 %setup -q -n %{realname}-%{version}
90
91 %build
92 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
93 %{__libtoolize}
94 %{__aclocal}
95 %{__autoconf}
96 %{__automake}
97 # no sdl test, because it requires configured wine to work
98 %configure \
99         --host=%{target} \
100         --target=%{target} \
101         --with-sdl-prefix=%{_prefix} \
102         --disable-sdltest
103
104 # LIBS hack for libtool not detecting libraries without .la files
105 %{__make} \
106         LIBS="$(%{_bindir}/sdl-config --libs | sed -e 's/\(-lmingw32\|-lSDLmain\)/-Wl,\1/g')"
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 install -d $RPM_BUILD_ROOT%{_dlldir}
115 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
116
117 %if 0%{!?debug:1}
118 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
119 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
120 %endif
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(644,root,root,755)
127 %doc CHANGES README
128 %{_libdir}/libSDL_image.dll.a
129 %{_libdir}/libSDL_image.la
130 %{_includedir}/SDL/SDL_image.h
131 %{_pkgconfigdir}/SDL_image.pc
132
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/libSDL_image.a
136
137 %files dll
138 %defattr(644,root,root,755)
139 %{_dlldir}/libSDL_image-*.dll
This page took 0.131756 seconds and 3 git commands to generate.