]> git.pld-linux.org Git - packages/crossmingw32-SDL_image.git/blob - crossmingw32-SDL_image.spec
baaa90ed502234c0fe991526baea146e5f9c38a7
[packages/crossmingw32-SDL_image.git] / crossmingw32-SDL_image.spec
1 %define         realname        SDL_image
2 Summary:        Simple DirectMedia Layer - Sample Image Loading Library - MinGW32 cross version
3 Summary(pl.UTF-8):      Przykładowa biblioteka do ładowania obrazków - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        1.2.12
6 Release:        1
7 License:        Zlib-like
8 Group:          Libraries
9 Source0:        http://www.libsdl.org/projects/SDL_image/release/%{realname}-%{version}.tar.gz
10 # Source0-md5:  a0f9098ebe5400f0bdc9b62e60797ecb
11 URL:            http://www.libsdl.org/projects/SDL_image/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  crossmingw32-SDL >= 1.2.10
15 BuildRequires:  crossmingw32-gcc
16 BuildRequires:  crossmingw32-libjpeg >= 7
17 BuildRequires:  crossmingw32-libpng >= 1.5.0
18 BuildRequires:  crossmingw32-libtiff >= 4
19 BuildRequires:  crossmingw32-libwebp >= 0.1.3
20 BuildRequires:  crossmingw32-w32api
21 BuildRequires:  libtool >= 2:2.0
22 BuildRequires:  pkgconfig >= 1:0.9.0
23 Requires:       crossmingw32-SDL >= 1.2.10
24 Requires:       crossmingw32-runtime
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         no_install_post_strip   1
28
29 %define         target                  i386-mingw32
30 %define         target_platform         i386-pc-mingw32
31
32 %define         _sysprefix              /usr
33 %define         _prefix                 %{_sysprefix}/%{target}
34 %define         _libdir                 %{_prefix}/lib
35 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
36 %define         _dlldir                 /usr/share/wine/windows/system
37 %define         __cc                    %{target}-gcc
38 %define         __cxx                   %{target}-g++
39
40 %ifnarch %{ix86}
41 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
42 %define         optflags        -O2
43 %endif
44 # -z options are invalid for mingw linker
45 %define         filterout_ld    -Wl,-z,.*
46
47 %description
48 This is a simple library to load images of various formats as SDL
49 surfaces. This library currently supports BMP, GIF, JPEG, LBM, PCX,
50 PNG, PNM (PBM/PGM/PPM), TGA, TIFF, WebP, XCF and XPM formats.
51
52 This package contains the cross version for Win32.
53
54 %description -l pl.UTF-8
55 Jest to prosta biblioteka służąca do ładowania różnego formatu
56 obrazków jako powierzchni SDL. W chwili obecnej biblioteka obsługuje
57 następujące formaty: BMP, GIF, JPEG, LBM, PCX, PNG, PNM (PBM/PGM/PPM),
58 TGA, TIFF, WebP, XCF oraz XPM.
59
60 Ten pakiet zawiera wersję skrośną dla Win32.
61
62 %package static
63 Summary:        Static SDL_image library (cross MinGW32 version)
64 Summary(pl.UTF-8):      Statyczna biblioteka SDL_image (wersja skrośna MinGW32)
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67
68 %description static
69 Static SDL_image library (cross MinGW32 version).
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka SDL_image (wersja skrośna MinGW32).
73
74 %package dll
75 Summary:        SDL_image - DLL library for Windows
76 Summary(pl.UTF-8):      SDL_image - biblioteka DLL dla Windows
77 Group:          Applications/Emulators
78 Requires:       crossmingw32-SDL-dll >= 1.2.10
79 Requires:       wine
80
81 %description dll
82 SDL_image - DLL library for Windows.
83
84 %description dll -l pl.UTF-8
85 SDL_image - biblioteka DLL dla Windows.
86
87 %prep
88 %setup -q -n %{realname}-%{version}
89
90 %build
91 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
92 %{__libtoolize}
93 %{__aclocal}
94 %{__autoconf}
95 %{__automake}
96 # no sdl test, because it requires configured wine to work
97 %configure \
98         --host=%{target} \
99         --target=%{target} \
100         --with-sdl-prefix=%{_prefix} \
101         --disable-sdltest
102
103 # LIBS hack for libtool not detecting libraries without .la files
104 %{__make} \
105         LIBS="$(%{_bindir}/sdl-config --libs | sed -e 's/\(-lmingw32\|-lSDLmain\)/-Wl,\1/g')"
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 install -d $RPM_BUILD_ROOT%{_dlldir}
114 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
115
116 %if 0%{!?debug:1}
117 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
118 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
119 %endif
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %doc CHANGES README
127 %{_libdir}/libSDL_image.dll.a
128 %{_libdir}/libSDL_image.la
129 %{_includedir}/SDL/SDL_image.h
130 %{_pkgconfigdir}/SDL_image.pc
131
132 %files static
133 %defattr(644,root,root,755)
134 %{_libdir}/libSDL_image.a
135
136 %files dll
137 %defattr(644,root,root,755)
138 %{_dlldir}/libSDL_image-*.dll
This page took 0.037743 seconds and 2 git commands to generate.