]> git.pld-linux.org Git - packages/crossfire.git/blob - crossfire.spec
- BR: autoconf; more specific Requires
[packages/crossfire.git] / crossfire.spec
1 Summary:        Multiplayer roguelike game server
2 Summary(pl):    Serwer gry roguelike dla wielu graczy
3 Name:           crossfire
4 Version:        1.3.0
5 Release:        1
6 License:        GPL
7 Group:          Applications/Games
8 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/crossfire/%{name}-%{version}.tar.bz2
9 Source1:        %{name}.init
10 Source2:        %{name}.sysconfig
11 Source3:        %{name}.logrotate
12 Patch0:         %{name}-DESTDIR.patch
13 Patch1:         %{name}-directories.patch
14 Patch2:         %{name}-tmp_maps.patch
15 Patch3:         %{name}-python.patch
16 URL:            http://crossfire.real-time.com/
17 BuildRequires:  XFree86-devel
18 BuildRequires:  autoconf
19 Requires(post,preun):   /sbin/chkconfig
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _prefix         /usr/X11R6
23 %define         _localstatedir  /var/lib
24
25 %description 
26 This is a multiplayer graphical arcade and adventure game made for the
27 X-Window environment. There are also Windows and Java clients
28 available.
29
30 It has certain flavours from other games, especially Gauntlet (TM) and
31 Nethack/Moria.
32
33 Any number of players can move around in their own window, finding and
34 sing items and battle monsters. They can choose to cooperate or
35 compete in the same "world".
36
37 %description -l pl
38 To jest graficzna gra przygodowa dla ¶rodowiska X-Window. S± tak¿e
39 dostêpni klienci pod Windows i w Javie.
40
41 %package editor
42 Summary:        Crossfire map editor
43 Summary(pl):    Edytor map crossfire
44 Group:          Applications/Games
45
46 %description editor
47 Crossfire map editor.
48
49 %description editor -l pl
50 Edytor map crossfire.
51
52 %package doc
53 Summary:        Crossfire game documentation
54 Summary(pl):    Dokumentacja gry crossfire
55 Group:          Applications/Games
56
57 %description doc
58 Crossfire documentation for players. Includes handbook and spoiler.
59
60 %description doc -l pl
61 Dokumentacja dla graczy Crossfire. Zawiera podrêczniek oraz spoiler.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66 %patch1 -p1
67 %patch2 -p1
68 # don't apply, its unfinished
69 #%patch3 -p1
70 cd lib
71
72 %build
73 %{__autoconf}
74 %configure
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT{/var/log,/etc/{sysconfig,%{name},logrotate.d},/etc/rc.d/init.d} \
80         $RPM_BUILD_ROOT%{_localstatedir}/%{name}/{tmp,maps}
81
82 %{__make} install DESTDIR="$RPM_BUILD_ROOT"
83
84 mv -f $RPM_BUILD_ROOT%{_datadir}/%{name}/{ban_file,settings,dm_file,motd,forbid} \
85         $RPM_BUILD_ROOT/etc/%{name}
86
87 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
88 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
89 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
90
91 touch $RPM_BUILD_ROOT%{_localstatedir}/%{name}/clockdata \
92         $RPM_BUILD_ROOT/var/log/crossfire
93
94 rm doc/Developers/Makefile*
95  
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 /sbin/chkconfig --add crossfire
101 if [ -r /var/lock/subsys/crossfire ]; then
102         /etc/rc.d/init.d/crossfire restart >&2
103 else
104         echo "Run \"/etc/rc.d/init.d/crossfire start\" to start Crossfire server."
105 fi
106
107 %preun
108 if [ "$1" = "0" ]; then
109         if [ -r /var/lock/subsys/crossfire ]; then
110                 /etc/rc.d/init.d/crossfire stop >&2
111         fi
112         /sbin/chkconfig --del crossfire
113 fi
114
115 %files
116 %defattr(644,root,root,755)
117 %doc CHANGES CREDITS DEVELOPERS README TODO
118 %doc doc/{alchemy.doc,experience,multigod,spell_params.doc} 
119 %doc doc/{spell-paths,spellcasters_guide_to_runes,metaserver} 
120 %doc doc/Developers
121 %attr(750,root,games) %{_bindir}/crossfire
122 %attr(750,root,games) %{_bindir}/random_map
123 %dir %attr(750,root,games) %{_datadir}/crossfire
124 %{_datadir}/crossfire/*
125 %{_mandir}/man?/crossfire*
126 %dir %attr(750,root,games) %{_localstatedir}/crossfire
127 %dir %attr(770,root,games) %{_localstatedir}/crossfire/players
128 %dir %attr(770,root,games) %{_localstatedir}/crossfire/unique-items
129 %dir %attr(770,root,games) %{_localstatedir}/crossfire/tmp
130 %dir %attr(770,root,games) %{_localstatedir}/crossfire/maps
131 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/bookarch
132 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/highscore
133 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/temp.maps
134 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/clockdata
135 %dir /etc/crossfire
136 %config(noreplace) %verify(not size mtime md5) /etc/crossfire/*
137 %attr(754,root,root) /etc/rc.d/init.d/crossfire
138 %attr(660,root,root) /etc/logrotate.d/crossfire
139 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/crossfire
140 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) /var/log/crossfire
141
142 %files editor
143 %defattr(644,root,root,755)
144 %doc doc/Crossedit.doc crossedit/doc/*.doc
145 %attr(755,root,root) %{_bindir}/crossedit
146 %{_mandir}/man?/crossedit*
147
148 %files doc
149 %defattr(644,root,root,755)
150 %doc doc/{handbook.ps,spoiler.ps}
151 %doc doc/{PlayerStats,RunTimeCommands,SurvivalGuide} 
152 %doc doc/{skills.doc,spellcasters_guide_to_runes,spells*} 
This page took 0.082183 seconds and 4 git commands to generate.