]> git.pld-linux.org Git - packages/crossfire-client.git/blob - crossfire-client.spec
- trying to fix build on big endian machines
[packages/crossfire-client.git] / crossfire-client.spec
1 %define         sndver  1.4.0
2 %define         imgver  1.7.0
3 Summary:        Crossfire client
4 Summary(pl):    Klient Crossfire
5 Name:           crossfire-client
6 Version:        1.7.0
7 Release:        1.1
8 License:        GPL
9 Group:          Applications/Games
10 Source0:        http://dl.sourceforge.net/crossfire/%{name}-%{version}.tar.gz
11 # Source0-md5:  ef405f78d54be0bf22feeef6b4fc0d73
12 Source1:        http://dl.sourceforge.net/crossfire/%{name}-sounds-%{sndver}.tar.gz
13 # Source1-md5:  1b33401d9d2af0d391fee7ad04282cfd
14 Source2:        http://dl.sourceforge.net/crossfire/%{name}-images-%{imgver}.tar.gz
15 # Source2-md5:  cbf4b4480bd6fd28cf0e71a06b288127
16 Patch0:         %{name}-big_endian.patch
17 URL:            http://crossfire.real-time.com/
18 BuildRequires:  SDL-devel
19 BuildRequires:  SDL_image-devel
20 BuildRequires:  XFree86-devel
21 BuildRequires:  autoconf
22 BuildRequires:  gtk+-devel
23 BuildRequires:  perl
24 Requires:       %{name}-common = %{version}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 X11 client to crossfire.
29
30 Crossfire is a multiplayer graphical arcade and adventure game made
31 for the X-Window environment. There are also Windows and Java clients
32 available.
33
34 It has certain flavours from other games, especially Gauntlet (TM) and
35 Nethack/Moria.
36
37 Any number of players can move around in their own window, finding and
38 sing items and battle monsters. They can choose to cooperate or
39 compete in the same "world".
40
41 %description -l pl
42 Klient Crossfire pod X11.
43
44 Crossfire to graficzna gra przygodowa dla ¶rodowiska X-Window. S±
45 tak¿e dostêpni klienci pod Windows i w Javie. £±czy cechy z kilku
46 gier, g³ównie Gauntleta i Nethacka/Morii.
47
48 Dowolna liczba graczy mo¿e siê poruszaæ w swoich oknach, szukaj±c
49 przedmiotów i walcz±c z potworami. Mog± graæ w kooperacji lub
50 przeciwko sobie w tym samym "¶wiecie".
51
52 %package sounds
53 Summary:        Crossfire sounds
54 Summary(pl):    D¼wiêki do Crossfire
55 Group:          Applications/Games
56 Requires:       %{name}-common = %{version}
57
58 %description sounds
59 Some sound files and the sound server for crossfire.
60
61 %description sounds -l pl
62 Pliki d¼wiêkowe i serwer d¼wiêku dla Crossfire.
63
64 %package gtk
65 Summary:        GTK Crossfire client
66 Summary(pl):    Klient Crossfire pod GTK
67 Group:          Applications/Games
68 Requires:       %{name}-common = %{version}
69
70 %description gtk
71 GTK client to crossfire.
72
73 Crossfire is a multiplayer graphical arcade and adventure game made
74 for the X-Window environment. There are also Windows and Java clients
75 available.
76
77 It has certain flavours from other games, especially Gauntlet (TM) and
78 Nethack/Moria.
79
80 Any number of players can move around in their own window, finding and
81 sing items and battle monsters. They can choose to cooperate or
82 compete in the same "world".
83
84 %description gtk -l pl
85 Klient Crossfire pod GTK.
86
87 Crossfire to graficzna gra przygodowa dla ¶rodowiska X-Window. S±
88 tak¿e dostêpni klienci pod Windows i w Javie. £±czy cechy z kilku
89 gier, g³ównie Gauntleta i Nethacka/Morii.
90
91 Dowolna liczba graczy mo¿e siê poruszaæ w swoich oknach, szukaj±c
92 przedmiotów i walcz±c z potworami. Mog± graæ w kooperacji lub
93 przeciwko sobie w tym samym "¶wiecie".
94
95 %package images
96 Summary:        Crossfire images
97 Summary(pl):    Obrazki do Crossfire
98 Group:          Applications/Games
99 Requires:       %{name}-common = %{version}
100
101 %description images
102 Some images extracted from server for Crossfire.
103
104 %description images -l pl
105 Trochê obrazków wyci±gniêtych z serwera do Crossfire.
106
107 %package common
108 Summary:        Common Crossfire clients files
109 Summary(pl):    Pliki wspólne wszystkich klientów Crossfire
110 Group:          Applications/Games
111
112 %description common
113 This package includes files common to all Crossfire clients.
114
115 %description common -l pl
116 Ten pakiet zawiera pliki wspólne dla wszystkich klientów Crossfire.
117
118 %prep
119 %setup  -q -a1
120 %patch0 -p1
121 mv -f sounds cfsounds
122 %if %{?_without_images:0}%{?!_without_images:1}
123 install -d images
124 cd images
125 tar xzf %{SOURCE2}
126 cd ..
127 %endif
128
129 %build
130 %configure \
131         --disable-alsa \
132         --with-sound-dir=%{_datadir}/%{name}/sounds
133 perl -i -p -e 's/\#define HAVE_DMALLOC_H 1/\/\* \#undef HAVE_DMALLOC_H \*\//' common/config.h
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_datadir}/%{name}/sounds}
139
140 install x11/cfclient gtk/gcfclient sound-src/cfsndserv $RPM_BUILD_ROOT%{_bindir}
141 install x11/cfclient.man $RPM_BUILD_ROOT%{_mandir}/man1/cfclient.1
142 install gtk/gcfclient.man $RPM_BUILD_ROOT%{_mandir}/man1/gcfclient.1
143 install cfsounds/*.raw $RPM_BUILD_ROOT%{_datadir}/%{name}/sounds/
144 %if %{?_without_images:0}%{?!_without_images:1}
145 install images/bmaps.client images/crossfire.base images/crossfire.clsc \
146         $RPM_BUILD_ROOT%{_datadir}/%{name}
147 %endif
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %files
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_bindir}/cfclient
155 %{_mandir}/man?/cf*
156
157 %files common
158 %defattr(644,root,root,755)
159 %doc CHANGES README
160 %dir %{_datadir}/%{name}
161
162 %files sounds
163 %defattr(644,root,root,755)
164 %doc cfsounds/README
165 %attr(755,root,root) %{_bindir}/cfsndserv
166 %{_datadir}/%{name}/sounds
167
168 %if %{?_without_images:0}%{?!_without_images:1}
169 %files images
170 %defattr(644,root,root,755)
171 %{_datadir}/%{name}/bmaps.client
172 %{_datadir}/%{name}/crossfire.base
173 %{_datadir}/%{name}/crossfire.clsc
174 %endif
175
176 %files gtk
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_bindir}/g*
179 %{_mandir}/man?/g*
This page took 0.069687 seconds and 3 git commands to generate.