]> git.pld-linux.org Git - packages/crossdjgpp-binutils.git/blob - crossdjgpp-binutils.spec
- other stuff for DJGPP, nfy
[packages/crossdjgpp-binutils.git] / crossdjgpp-binutils.spec
1 Summary:        DJGPP GNU Binary Utility Development Utilities - binutils
2 Name:           crossdjgpp-binutils
3 Version:        2.11.90.0.19
4 Release:        1
5 License:        GPL
6 Group:          Development/Tools
7 Group(de):      Entwicklung/Werkzeuge
8 Group(fr):      Development/Outils
9 Group(pl):      Programowanie/Narzêdzia
10 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
11 BuildRequires:  flex
12 BuildRequires:  bison
13 BuildRequires:  /bin/bash
14 Requires:       crossdjgpp-platform
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         target          i386-pc-msdosdjgpp
18 %define         arch            %{_prefix}/%{target}
19
20 %description
21 DJGPP is a port of GNU GCC to the DOS environment. (It stands for
22 DJ's Gnu Programming Platform, if it has to stand for something, but
23 it's best left ambiguous.)
24
25 This package contains cross targeted binutils.
26
27 %prep
28 %setup -q -n binutils-%{version}
29
30 %build
31 rm -rf $RPM_BUILD_ROOT
32
33 # Because of a bug in binutils-2.9.1, a cross libbfd.so* is not named
34 # lib<target>bfd.so*. To prevent confusion with native binutils, we
35 # forget about shared libraries right now, and do not install libbfd.a
36 # [the same applies to binutils 2.10.1.0.4]
37
38 # ldscripts won't be generated properly if SHELL is not bash...
39 CFLAGS="%{rpmcflags}" LDFLAGS="%{rpmldflags}" \
40 CONFIG_SHELL="/bin/bash" \
41 ./configure \
42         --prefix=%{_prefix} \
43         --libdir=%{_libdir} \
44         --mandir=%{_mandir} \
45         --infodir=%{_infodir} \
46         --target=%{target}
47
48 %{__make} tooldir=%{_prefix} EXEEXT="" all
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         prefix=$RPM_BUILD_ROOT%{_prefix} \
55         mandir=$RPM_BUILD_ROOT%{_mandir} \
56         infodir=$RPM_BUILD_ROOT%{_infodir} \
57         libdir=$RPM_BUILD_ROOT%{_libdir}
58
59 %files
60 %defattr(644,root,root,755)
61 %attr(755,root,root) %{arch}/bin/*
62 %{arch}/lib/*
63 %attr(755,root,root) %{_bindir}/%{target}-*
64 %{_mandir}/man1/%{target}-*
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
This page took 0.090573 seconds and 3 git commands to generate.