]> git.pld-linux.org Git - packages/crossavr32-binutils.git/blob - crossavr32-binutils.spec
- updated gettext BR
[packages/crossavr32-binutils.git] / crossavr32-binutils.spec
1 Summary:        Cross AVR32 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - AVR32 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - AVR32 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla AVR32 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - AVR32 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - AVR32 binutils
7 Name:           crossavr32-binutils
8 Version:        2.17
9 Release:        0.6
10 License:        GPL v2+
11 Group:          Development/Tools
12 Source0:        http://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.bz2
13 # Source0-md5:  e26e2e06b6e4bf3acf1dc8688a94c0d1
14 #based on http://www.avr32linux.org/twiki/bin/viewfile/Main/DevelopmentTools?rev=1;filename=500-avr32.patch.gz
15 Patch0:         %{name}.patch
16 #http://www.avr32linux.org/twiki/bin/viewfile/Main/DevelopmentTools?rev=1;filename=501-avr32-sreldyn-fix.patch.gz
17 Patch1:         %{name}-sreldyn-fix.patch
18 #http://www.avr32linux.org/twiki/bin/viewfile/Main/DevelopmentTools?rev=1;filename=502-avr32-bfd-dont-allow-direct-refs-to-bss.patch.gz
19 Patch2:         %{name}-bfd-dont-allow-direct-refs-to-bss.patch
20 URL:            http://sources.redhat.com/binutils/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  bash
24 BuildRequires:  bison
25 BuildRequires:  flex
26 BuildRequires:  gettext-tools
27 %ifarch sparc sparc32
28 BuildRequires:  sparc32
29 %endif
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         target          avr32-pld-linux
33 %define         arch            %{_prefix}/%{target}
34
35 %description
36 Binutils is a collection of binary utilities, including:
37 - ar - create, modify and extract from archives,
38 - nm - lists symbols from object files,
39 - objcopy - copy and translate object files,
40 - objdump - display information from object files,
41 - ranlib - generate an index for the contents of an archive,
42 - size - list the section sizes of an object or archive file,
43 - strings - list printable strings from files,
44 - strip - discard symbols,
45 - c++filt - a filter for demangling encoded C++ symbols,
46 - addr2line - convert addresses to file and line,
47 - nlmconv - convert object code into an NLM.
48
49 This package contains the cross version for Atmel AVR.
50
51 %description -l pl.UTF-8
52 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
53 programów. Znajdują się tutaj między innymi assembler,
54 konsolidator (linker), a także inne narzędzia do manipulowania
55 binarnymi plikami programów i bibliotek.
56
57 Ten pakiet zawiera wersję skrośną generującą kod dla platformy Atmel
58 AVR.
59
60 %prep
61 %setup -q -n binutils-%{version}
62
63 %patch0 -p1
64 %patch1 -p1
65 %patch2 -p1
66
67 %build
68 cp /usr/share/automake/config.sub .
69
70 for i in bfd binutils gas ld opcodes
71 do
72   cd $i
73   %{__aclocal}
74   %{__automake}
75   %{__autoconf}
76   cd ..
77 done
78
79 # ldscripts won't be generated properly if SHELL is not bash...
80 CFLAGS="%{rpmcflags}" \
81 LDFLAGS="%{rpmldflags}" \
82 CONFIG_SHELL="/bin/bash" \
83 %ifarch sparc
84 sparc32 \
85 %endif
86 ./configure \
87         --enable-shared \
88         --prefix=%{_prefix} \
89         --libdir=%{_libdir} \
90         --mandir=%{_mandir} \
91         --infodir=%{_infodir} \
92         --target=%{target}
93
94 %{__make} all \
95         tooldir=%{_prefix} \
96         EXEEXT=""
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT%{_prefix}
101
102 %{__make} install \
103         prefix=$RPM_BUILD_ROOT%{_prefix} \
104         mandir=$RPM_BUILD_ROOT%{_mandir} \
105         infodir=$RPM_BUILD_ROOT%{_infodir} \
106         libdir=$RPM_BUILD_ROOT%{_libdir}
107
108 # remove these man pages unless we cross-build for win*/netware platforms.
109 # however, this should be done in Makefiles.
110 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
111
112 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/*.mo
113 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
114 rm -rf $RPM_BUILD_ROOT%{_infodir}
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files
120 %defattr(644,root,root,755)
121 %doc README
122 %attr(755,root,root) %{_bindir}/%{target}-*
123 %dir %{arch}
124 %dir %{arch}/bin
125 %attr(755,root,root) %{arch}/bin/*
126 %dir %{arch}/lib
127 %dir %{arch}/lib/*
128 %{arch}/lib/*/*
129 %{_mandir}/man?/%{target}-*
130 %{_prefix}/i686-pc-linux-gnu/%{target}
This page took 0.101418 seconds and 3 git commands to generate.