]> git.pld-linux.org Git - packages/crossavr32-binutils.git/blame - crossavr32-binutils.spec
- initial, works but result are untested
[packages/crossavr32-binutils.git] / crossavr32-binutils.spec
CommitLineData
bb569ee0 1Summary: Cross AVR32 GNU binary utility development utilities - binutils
2Summary(es.UTF-8): Utilitarios para desarrollo de binarios de la GNU - AVR32 binutils
3Summary(fr.UTF-8): Utilitaires de développement binaire de GNU - AVR32 binutils
4Summary(pl.UTF-8): Skrośne narzędzia programistyczne GNU dla AVR32 - binutils
5Summary(pt_BR.UTF-8): Utilitários para desenvolvimento de binários da GNU - AVR32 binutils
6Summary(tr.UTF-8): GNU geliştirme araçları - AVR32 binutils
7Name: crossavr32-binutils
8Version: 2.17
9Release: 0.6
10License: GPL
11Group: Development/Tools
12Source0: http://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.bz2
13# Source0-md5: e26e2e06b6e4bf3acf1dc8688a94c0d1
14#based on http://www.avr32linux.org/twiki/bin/viewfile/Main/DevelopmentTools?rev=1;filename=500-avr32.patch.gz
15Patch0: %{name}.patch
16#http://www.avr32linux.org/twiki/bin/viewfile/Main/DevelopmentTools?rev=1;filename=501-avr32-sreldyn-fix.patch.gz
17Patch1: %{name}-sreldyn-fix.patch
18#http://www.avr32linux.org/twiki/bin/viewfile/Main/DevelopmentTools?rev=1;filename=502-avr32-bfd-dont-allow-direct-refs-to-bss.patch.gz
19Patch2: %{name}-bfd-dont-allow-direct-refs-to-bss.patch
20URL: http://sources.redhat.com/binutils/
21BuildRequires: automake
22BuildRequires: bash
23BuildRequires: bison
24BuildRequires: flex
25BuildRequires: gettext-devel
26%ifarch sparc sparc32
27BuildRequires: sparc32
28%endif
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%define target avr32-pld-linux
32%define arch %{_prefix}/%{target}
33
34%description
35Binutils is a collection of binary utilities, including:
36- ar - create, modify and extract from archives,
37- nm - lists symbols from object files,
38- objcopy - copy and translate object files,
39- objdump - display information from object files,
40- ranlib - generate an index for the contents of an archive,
41- size - list the section sizes of an object or archive file,
42- strings - list printable strings from files,
43- strip - discard symbols,
44- c++filt - a filter for demangling encoded C++ symbols,
45- addr2line - convert addresses to file and line,
46- nlmconv - convert object code into an NLM.
47
48This package contains the cross version for Atmel AVR.
49
50%description -l pl.UTF-8
51Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
52programów. Znajdują się tutaj między innymi assembler,
53konsolidator (linker), a także inne narzędzia do manipulowania
54binarnymi plikami programów i bibliotek.
55
56Ten pakiet zawiera wersję skrośną generującą kod dla Atmel AVR.
57
58%prep
59%setup -q -n binutils-%{version}
60
61%patch0 -p1
62%patch1 -p1
63%patch2 -p1
64
65%build
66cp /usr/share/automake/config.sub .
67
68for i in bfd binutils gas ld opcodes
69do
70 cd $i
71 %{__aclocal}
72 %{__automake}
73 %{__autoconf}
74 cd ..
75done
76
77# ldscripts won't be generated properly if SHELL is not bash...
78CFLAGS="%{rpmcflags}" \
79LDFLAGS="%{rpmldflags}" \
80CONFIG_SHELL="/bin/bash" \
81%ifarch sparc
82sparc32 \
83%endif
84./configure \
85 --enable-shared \
86 --prefix=%{_prefix} \
87 --libdir=%{_libdir} \
88 --mandir=%{_mandir} \
89 --infodir=%{_infodir} \
90 --target=%{target}
91
92%{__make} all \
93 tooldir=%{_prefix} \
94 EXEEXT=""
95
96%install
97rm -rf $RPM_BUILD_ROOT
98install -d $RPM_BUILD_ROOT%{_prefix}
99
100%{__make} install \
101 prefix=$RPM_BUILD_ROOT%{_prefix} \
102 mandir=$RPM_BUILD_ROOT%{_mandir} \
103 infodir=$RPM_BUILD_ROOT%{_infodir} \
104 libdir=$RPM_BUILD_ROOT%{_libdir}
105
106# remove these man pages unless we cross-build for win*/netware platforms.
107# however, this should be done in Makefiles.
108rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
109
110rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/*.mo
111rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
112rm -rf $RPM_BUILD_ROOT%{_infodir}
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%files
118%defattr(644,root,root,755)
119%doc README
120%attr(755,root,root) %{_bindir}/%{target}-*
121%dir %{arch}
122%dir %{arch}/bin
123%attr(755,root,root) %{arch}/bin/*
124%dir %{arch}/lib
125%dir %{arch}/lib/*
126%{arch}/lib/*/*
127%{_mandir}/man?/%{target}-*
128%{_prefix}/i686-pc-linux-gnu/%{target}
This page took 0.092227 seconds and 4 git commands to generate.