]> git.pld-linux.org Git - packages/crossavr-gdb.git/commitdiff
- updated auto/th/gdb-6_8_50-0_20090101_1 auto/th/gdb-6_8_50-0_20090101_2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 26 Nov 2008 16:34:43 +0000 (16:34 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gdb-pretty-print-by-default.patch -> 1.3
    gdb-readline.patch -> 1.15

gdb-pretty-print-by-default.patch
gdb-readline.patch

index 006886d5752df8563e326b435fd62ae55a7511e7..c9a278a47d59843f693ec719821d8ea21396be2a 100644 (file)
@@ -1,37 +1,19 @@
---- gdb-6.5/gdb/cp-valprint.c.orig     2005-12-17 23:33:59.000000000 +0100
-+++ gdb-6.5/gdb/cp-valprint.c  2006-08-22 19:10:53.242715750 +0200
-@@ -861,8 +861,8 @@
-                          &setprintlist, &showprintlist);
-   /* Give people the defaults which they are used to.  */
--  objectprint = 0;
--  vtblprint = 0;
-+  objectprint = 1;
-+  vtblprint = 1;
-   obstack_begin (&dont_print_vb_obstack, 32 * sizeof (struct type *));
-   obstack_specify_allocation (&dont_print_statmem_obstack,
-                             32 * sizeof (CORE_ADDR), sizeof (CORE_ADDR),
---- gdb-6.5/gdb/valprint.c.orig        2006-08-22 19:11:55.000000000 +0200
-+++ gdb-6.5/gdb/valprint.c     2006-08-22 19:12:08.597733500 +0200
-@@ -1511,8 +1511,8 @@
-                            &setprintlist, &showprintlist);
-   /* Give people the defaults which they are used to.  */
--  prettyprint_structs = 0;
--  prettyprint_arrays = 0;
-+  prettyprint_structs = 1;
-+  prettyprint_arrays = 1;
-   unionprint = 1;
-   addressprint = 1;
-   print_max = PRINT_MAX_DEFAULT;
---- gdb-6.8/gdb/utils.c.orig   2008-01-01 23:53:13.000000000 +0100
-+++ gdb-6.8/gdb/utils.c        2008-04-04 10:23:07.000000000 +0200
-@@ -146,7 +146,7 @@
-    C++/ObjC form even in assembler language displays.  If this is set, but
-    DEMANGLE is zero, names are printed raw, i.e. DEMANGLE controls.  */
--int asm_demangle = 0;
-+int asm_demangle = 1;
- static void
- show_asm_demangle (struct ui_file *file, int from_tty,
-                  struct cmd_list_element *c, const char *value)
+--- gdb-6.8.50.20081125/gdb/valprint.c~        2008-11-26 17:29:53.836145817 +0100
++++ gdb-6.8.50.20081125/gdb/valprint.c 2008-11-26 17:31:59.193231994 +0100
+@@ -65,12 +65,12 @@
+ struct value_print_options user_print_options =
+ {
+   Val_pretty_default,         /* pretty */
+-  0,                          /* prettyprint_arrays */
+-  0,                          /* prettyprint_structs */
+-  0,                          /* vtblprint */
++  1,                          /* prettyprint_arrays */
++  1,                          /* prettyprint_structs */
++  1,                          /* vtblprint */
+   1,                          /* unionprint */
+   1,                          /* addressprint */
+-  0,                          /* objectprint */
++  1,                          /* objectprint */
+   PRINT_MAX_DEFAULT,          /* print_max */
+   10,                         /* repeat_count_threshold */
+   0,                          /* output_format */
index 832689daf115afc25953081ebaf5dd99d1835003..ef1ca51e8eb2529e0b6e995b8315a4d4859085f4 100644 (file)
@@ -1,15 +1,3 @@
-diff -ur gdb-6.7.org/gdb/gdbserver/Makefile.in gdb-6.7/gdb/gdbserver/Makefile.in
---- gdb-6.7.org/gdb/gdbserver/Makefile.in      2007-06-13 20:50:38.000000000 +0200
-+++ gdb-6.7/gdb/gdbserver/Makefile.in  2007-10-10 21:10:05.379655356 +0200
-@@ -78,7 +78,7 @@
- # Where is the source dir for the READLINE library?  Traditionally in .. or .
- # (For the binary library built from it, we use ${READLINE_DIR}${subdir}.)
--READLINE_DIR = ${srcdir}/../readline
-+READLINE_DIR = /usr/lib
- READLINE_DEP = $$(READLINE_DIR)
- # All the includes used for CFLAGS and for lint.
 diff -ur gdb-6.7.org/gdb/Makefile.in gdb-6.7/gdb/Makefile.in
 --- gdb-6.7.org/gdb/Makefile.in        2007-09-05 02:14:02.000000000 +0200
 +++ gdb-6.7/gdb/Makefile.in    2007-10-10 21:11:18.119976680 +0200
@@ -30,12 +18,12 @@ diff -ur gdb-6.7.org/gdb/Makefile.in gdb-6.7/gdb/Makefile.in
  
  # Where is expat?  This will be empty if expat was not available.
  LIBEXPAT = @LIBEXPAT@
-@@ -388,7 +388,7 @@
-       $(XM_CLIBS) $(TM_CLIBS) $(NAT_CLIBS) $(GDBTKLIBS) @LIBS@ \
+@@ -416,7 +416,7 @@
+       $(XM_CLIBS) $(NAT_CLIBS) $(GDBTKLIBS) @LIBS@ \
        $(LIBICONV) $(LIBEXPAT) \
        $(LIBIBERTY) $(WIN32LIBS) $(LIBGNU)
--CDEPS = $(XM_CDEPS) $(TM_CDEPS) $(NAT_CDEPS) $(SIM) $(BFD) $(READLINE_DEPS) \
-+CDEPS = $(XM_CDEPS) $(TM_CDEPS) $(NAT_CDEPS) $(SIM) $(BFD) \
+-CDEPS = $(XM_CDEPS) $(NAT_CDEPS) $(SIM) $(BFD) $(READLINE_DEPS) \
++CDEPS = $(XM_CDEPS) $(NAT_CDEPS) $(SIM) $(BFD) \
        $(OPCODES) $(INTL_DEPS) $(LIBIBERTY) $(CONFIG_DEPS) $(LIBGNU)
  
  ADD_FILES = $(XM_ADD_FILES) $(TM_ADD_FILES) $(NAT_ADD_FILES)
This page took 0.096177 seconds and 4 git commands to generate.