]> git.pld-linux.org Git - packages/crossavr-gdb.git/blobdiff - gdb-readline.patch
- updated
[packages/crossavr-gdb.git] / gdb-readline.patch
index afc309894640708079c47b38f7e874c62ca543c7..ef1ca51e8eb2529e0b6e995b8315a4d4859085f4 100644 (file)
@@ -1,36 +1,36 @@
-diff -urN gdb-6.0.org/gdb/gdbserver/Makefile.in gdb-6.0/gdb/gdbserver/Makefile.in
---- gdb-6.0.org/gdb/gdbserver/Makefile.in      2003-10-09 19:42:41.000000000 +0200
-+++ gdb-6.0/gdb/gdbserver/Makefile.in  2003-10-09 19:48:08.000000000 +0200
-@@ -76,7 +76,7 @@
- # Where is the source dir for the READLINE library?  Traditionally in .. or .
- # (For the binary library built from it, we use ${READLINE_DIR}${subdir}.)
--READLINE_DIR = ${srcdir}/../readline
-+READLINE_DIR = /usr/lib
- READLINE_DEP = $$(READLINE_DIR)
- # All the includes used for CFLAGS and for lint.
-diff -urN gdb-6.0.org/gdb/Makefile.in gdb-6.0/gdb/Makefile.in
---- gdb-6.0.org/gdb/Makefile.in        2003-10-09 19:42:39.000000000 +0200
-+++ gdb-6.0/gdb/Makefile.in    2003-10-09 19:48:08.000000000 +0200
-@@ -116,10 +116,10 @@
+diff -ur gdb-6.7.org/gdb/Makefile.in gdb-6.7/gdb/Makefile.in
+--- gdb-6.7.org/gdb/Makefile.in        2007-09-05 02:14:02.000000000 +0200
++++ gdb-6.7/gdb/Makefile.in    2007-10-10 21:11:18.119976680 +0200
+@@ -126,11 +126,11 @@
  BFD_CFLAGS = -I$(BFD_DIR) -I$(BFD_SRC)
  
  # Where is the READLINE library?  Typically in ../readline.
 -READLINE_DIR = ../readline
--READLINE = $(READLINE_DIR)/libreadline.a
 -READLINE_SRC = $(srcdir)/$(READLINE_DIR)
--READLINE_CFLAGS = -I$(READLINE_SRC)/..
+-READLINE = @READLINE@
+-READLINE_DEPS = @READLINE_DEPS@
+-READLINE_CFLAGS = @READLINE_CFLAGS@
 +READLINE_DIR = /usr/include/readline
 +READLINE = -lreadline
 +READLINE_SRC = /usr/include/readline
++READLINE_DEPS =
 +READLINE_CFLAGS = -I/usr/include/readline
  
- WARN_CFLAGS = @WARN_CFLAGS@
- WERROR_CFLAGS = @WERROR_CFLAGS@
---- gdb-6.1/Makefile.in.orig   2004-04-03 18:52:09.000000000 +0200
-+++ gdb-6.1/Makefile.in        2004-04-17 22:43:50.603804248 +0200
-@@ -571,7 +571,6 @@
+ # Where is expat?  This will be empty if expat was not available.
+ LIBEXPAT = @LIBEXPAT@
+@@ -416,7 +416,7 @@
+       $(XM_CLIBS) $(NAT_CLIBS) $(GDBTKLIBS) @LIBS@ \
+       $(LIBICONV) $(LIBEXPAT) \
+       $(LIBIBERTY) $(WIN32LIBS) $(LIBGNU)
+-CDEPS = $(XM_CDEPS) $(NAT_CDEPS) $(SIM) $(BFD) $(READLINE_DEPS) \
++CDEPS = $(XM_CDEPS) $(NAT_CDEPS) $(SIM) $(BFD) \
+       $(OPCODES) $(INTL_DEPS) $(LIBIBERTY) $(CONFIG_DEPS) $(LIBGNU)
+ ADD_FILES = $(XM_ADD_FILES) $(TM_ADD_FILES) $(NAT_ADD_FILES)
+diff -ur gdb-6.7.org/Makefile.in gdb-6.7/Makefile.in
+--- gdb-6.7.org/Makefile.in    2007-10-10 19:09:32.000000000 +0200
++++ gdb-6.7/Makefile.in        2007-10-10 21:10:23.310556251 +0200
+@@ -664,7 +664,6 @@
      maybe-configure-perl \
      maybe-configure-prms \
      maybe-configure-rcs \
@@ -38,345 +38,103 @@ diff -urN gdb-6.0.org/gdb/Makefile.in gdb-6.0/gdb/Makefile.in
      maybe-configure-release \
      maybe-configure-recode \
      maybe-configure-sed \
-@@ -661,7 +660,6 @@
-     maybe-all-perl \
-     maybe-all-prms \
-     maybe-all-rcs \
--    maybe-all-readline \
-     maybe-all-release \
-     maybe-all-recode \
-     maybe-all-sed \
-@@ -755,7 +753,6 @@
-     maybe-info-perl \
-     maybe-info-prms \
-     maybe-info-rcs \
--    maybe-info-readline \
-     maybe-info-release \
-     maybe-info-recode \
-     maybe-info-sed \
-@@ -1724,28 +1721,6 @@
-         || exit 1
--.PHONY: maybe-info-readline info-readline
--maybe-info-readline:
--
--info-readline: \
--    configure-readline 
--      @[ -f ./readline/Makefile ] || exit 0; \
--      r=`${PWD_COMMAND}`; export r; \
--      s=`cd $(srcdir); ${PWD_COMMAND}`; export s; \
--      $(SET_LIB_PATH) \
--      for flag in $(EXTRA_HOST_FLAGS); do \
--        eval `echo "$$flag" | sed -e "s|^\([^=]*\)=\(.*\)|\1='\2'; export \1|"`; \
--      done; \
--      echo "Doing info in readline" ; \
--      (cd readline && \
--        $(MAKE) $(BASE_FLAGS_TO_PASS) "AR=$${AR}" "AS=$${AS}" \
--                "CC=$${CC}" "CXX=$${CXX}" "LD=$${LD}" "NM=$${NM}" \
--                "RANLIB=$${RANLIB}" \
--                "DLLTOOL=$${DLLTOOL}" "WINDRES=$${WINDRES}" \
--                info) \
--        || exit 1
--
--
- .PHONY: maybe-info-release info-release
- maybe-info-release:
-@@ -2654,7 +2629,6 @@
-     maybe-dvi-perl \
-     maybe-dvi-prms \
-     maybe-dvi-rcs \
--    maybe-dvi-readline \
-     maybe-dvi-release \
-     maybe-dvi-recode \
-     maybe-dvi-sed \
-@@ -3623,28 +3597,6 @@
-         || exit 1
--.PHONY: maybe-dvi-readline dvi-readline
--maybe-dvi-readline:
--
--dvi-readline: \
--    configure-readline 
--      @[ -f ./readline/Makefile ] || exit 0; \
--      r=`${PWD_COMMAND}`; export r; \
--      s=`cd $(srcdir); ${PWD_COMMAND}`; export s; \
--      $(SET_LIB_PATH) \
--      for flag in $(EXTRA_HOST_FLAGS); do \
--        eval `echo "$$flag" | sed -e "s|^\([^=]*\)=\(.*\)|\1='\2'; export \1|"`; \
--      done; \
--      echo "Doing dvi in readline" ; \
--      (cd readline && \
--        $(MAKE) $(BASE_FLAGS_TO_PASS) "AR=$${AR}" "AS=$${AS}" \
--                "CC=$${CC}" "CXX=$${CXX}" "LD=$${LD}" "NM=$${NM}" \
--                "RANLIB=$${RANLIB}" \
--                "DLLTOOL=$${DLLTOOL}" "WINDRES=$${WINDRES}" \
--                dvi) \
--        || exit 1
--
--
- .PHONY: maybe-dvi-release dvi-release
- maybe-dvi-release:
-@@ -4553,7 +4505,6 @@
-     maybe-TAGS-perl \
-     maybe-TAGS-prms \
-     maybe-TAGS-rcs \
--    maybe-TAGS-readline \
-     maybe-TAGS-release \
-     maybe-TAGS-recode \
-     maybe-TAGS-sed \
-@@ -5522,28 +5473,6 @@
-         || exit 1
--.PHONY: maybe-TAGS-readline TAGS-readline
--maybe-TAGS-readline:
--
--TAGS-readline: \
--    configure-readline 
--      @[ -f ./readline/Makefile ] || exit 0; \
--      r=`${PWD_COMMAND}`; export r; \
--      s=`cd $(srcdir); ${PWD_COMMAND}`; export s; \
--      $(SET_LIB_PATH) \
--      for flag in $(EXTRA_HOST_FLAGS); do \
--        eval `echo "$$flag" | sed -e "s|^\([^=]*\)=\(.*\)|\1='\2'; export \1|"`; \
--      done; \
--      echo "Doing TAGS in readline" ; \
--      (cd readline && \
--        $(MAKE) $(BASE_FLAGS_TO_PASS) "AR=$${AR}" "AS=$${AS}" \
--                "CC=$${CC}" "CXX=$${CXX}" "LD=$${LD}" "NM=$${NM}" \
--                "RANLIB=$${RANLIB}" \
--                "DLLTOOL=$${DLLTOOL}" "WINDRES=$${WINDRES}" \
--                TAGS) \
--        || exit 1
--
--
- .PHONY: maybe-TAGS-release TAGS-release
- maybe-TAGS-release:
-@@ -6452,7 +6381,6 @@
-     maybe-install-info-perl \
-     maybe-install-info-prms \
-     maybe-install-info-rcs \
--    maybe-install-info-readline \
-     maybe-install-info-release \
-     maybe-install-info-recode \
-     maybe-install-info-sed \
-@@ -7463,29 +7391,6 @@
-         || exit 1
--.PHONY: maybe-install-info-readline install-info-readline
--maybe-install-info-readline:
--
--install-info-readline: \
--    configure-readline \
--    info-readline 
--      @[ -f ./readline/Makefile ] || exit 0; \
--      r=`${PWD_COMMAND}`; export r; \
--      s=`cd $(srcdir); ${PWD_COMMAND}`; export s; \
--      $(SET_LIB_PATH) \
--      for flag in $(EXTRA_HOST_FLAGS); do \
--        eval `echo "$$flag" | sed -e "s|^\([^=]*\)=\(.*\)|\1='\2'; export \1|"`; \
--      done; \
--      echo "Doing install-info in readline" ; \
--      (cd readline && \
--        $(MAKE) $(BASE_FLAGS_TO_PASS) "AR=$${AR}" "AS=$${AS}" \
--                "CC=$${CC}" "CXX=$${CXX}" "LD=$${LD}" "NM=$${NM}" \
--                "RANLIB=$${RANLIB}" \
--                "DLLTOOL=$${DLLTOOL}" "WINDRES=$${WINDRES}" \
--                install-info) \
--        || exit 1
--
--
- .PHONY: maybe-install-info-release install-info-release
- maybe-install-info-release:
-@@ -8433,7 +8338,6 @@
-     maybe-installcheck-perl \
-     maybe-installcheck-prms \
-     maybe-installcheck-rcs \
--    maybe-installcheck-readline \
-     maybe-installcheck-release \
-     maybe-installcheck-recode \
-     maybe-installcheck-sed \
-@@ -9402,28 +9306,6 @@
-         || exit 1
--.PHONY: maybe-installcheck-readline installcheck-readline
--maybe-installcheck-readline:
--
--installcheck-readline: \
--    configure-readline 
--      @[ -f ./readline/Makefile ] || exit 0; \
--      r=`${PWD_COMMAND}`; export r; \
--      s=`cd $(srcdir); ${PWD_COMMAND}`; export s; \
--      $(SET_LIB_PATH) \
--      for flag in $(EXTRA_HOST_FLAGS); do \
--        eval `echo "$$flag" | sed -e "s|^\([^=]*\)=\(.*\)|\1='\2'; export \1|"`; \
--      done; \
--      echo "Doing installcheck in readline" ; \
--      (cd readline && \
--        $(MAKE) $(BASE_FLAGS_TO_PASS) "AR=$${AR}" "AS=$${AS}" \
--                "CC=$${CC}" "CXX=$${CXX}" "LD=$${LD}" "NM=$${NM}" \
--                "RANLIB=$${RANLIB}" \
--                "DLLTOOL=$${DLLTOOL}" "WINDRES=$${WINDRES}" \
--                installcheck) \
--        || exit 1
--
--
- .PHONY: maybe-installcheck-release installcheck-release
- maybe-installcheck-release:
-@@ -10332,7 +10214,6 @@
-     maybe-mostlyclean-perl \
-     maybe-mostlyclean-prms \
-     maybe-mostlyclean-rcs \
--    maybe-mostlyclean-readline \
-     maybe-mostlyclean-release \
-     maybe-mostlyclean-recode \
-     maybe-mostlyclean-sed \
-@@ -11245,27 +11126,6 @@
-         || exit 1
--.PHONY: maybe-mostlyclean-readline mostlyclean-readline
--maybe-mostlyclean-readline:
--
--mostlyclean-readline: 
--      @[ -f ./readline/Makefile ] || exit 0; \
--      r=`${PWD_COMMAND}`; export r; \
--      s=`cd $(srcdir); ${PWD_COMMAND}`; export s; \
--      $(SET_LIB_PATH) \
--      for flag in $(EXTRA_HOST_FLAGS); do \
--        eval `echo "$$flag" | sed -e "s|^\([^=]*\)=\(.*\)|\1='\2'; export \1|"`; \
--      done; \
--      echo "Doing mostlyclean in readline" ; \
--      (cd readline && \
--        $(MAKE) $(BASE_FLAGS_TO_PASS) "AR=$${AR}" "AS=$${AS}" \
--                "CC=$${CC}" "CXX=$${CXX}" "LD=$${LD}" "NM=$${NM}" \
--                "RANLIB=$${RANLIB}" \
--                "DLLTOOL=$${DLLTOOL}" "WINDRES=$${WINDRES}" \
--                mostlyclean) \
--        || exit 1
--
--
- .PHONY: maybe-mostlyclean-release mostlyclean-release
- maybe-mostlyclean-release:
-@@ -12107,7 +11967,6 @@
-     maybe-clean-perl \
-     maybe-clean-prms \
-     maybe-clean-rcs \
--    maybe-clean-readline \
-     maybe-clean-release \
-     maybe-clean-recode \
-     maybe-clean-sed \
-@@ -13034,27 +12893,6 @@
-         || exit 1
--.PHONY: maybe-clean-readline clean-readline
--maybe-clean-readline:
--
--clean-readline: 
--      @[ -f ./readline/Makefile ] || exit 0; \
--      r=`${PWD_COMMAND}`; export r; \
--      s=`cd $(srcdir); ${PWD_COMMAND}`; export s; \
--      $(SET_LIB_PATH) \
--      for flag in $(EXTRA_HOST_FLAGS); do \
--        eval `echo "$$flag" | sed -e "s|^\([^=]*\)=\(.*\)|\1='\2'; export \1|"`; \
--      done; \
--      echo "Doing clean in readline" ; \
--      (cd readline && \
--        $(MAKE) $(BASE_FLAGS_TO_PASS) "AR=$${AR}" "AS=$${AS}" \
--                "CC=$${CC}" "CXX=$${CXX}" "LD=$${LD}" "NM=$${NM}" \
--                "RANLIB=$${RANLIB}" \
--                "DLLTOOL=$${DLLTOOL}" "WINDRES=$${WINDRES}" \
--                clean) \
--        || exit 1
--
--
- .PHONY: maybe-clean-release clean-release
- maybe-clean-release:
-@@ -13896,7 +13734,6 @@
-     maybe-distclean-perl \
-     maybe-distclean-prms \
-     maybe-distclean-rcs \
--    maybe-distclean-readline \
-     maybe-distclean-release \
-     maybe-distclean-recode \
-     maybe-distclean-sed \
-@@ -14823,27 +14660,6 @@
-         || exit 1
--.PHONY: maybe-distclean-readline distclean-readline
--maybe-distclean-readline:
--
--distclean-readline: 
--      @[ -f ./readline/Makefile ] || exit 0; \
--      r=`${PWD_COMMAND}`; export r; \
--      s=`cd $(srcdir); ${PWD_COMMAND}`; export s; \
--      $(SET_LIB_PATH) \
--      for flag in $(EXTRA_HOST_FLAGS); do \
--        eval `echo "$$flag" | sed -e "s|^\([^=]*\)=\(.*\)|\1='\2'; export \1|"`; \
--      done; \
--      echo "Doing distclean in readline" ; \
--      (cd readline && \
--        $(MAKE) $(BASE_FLAGS_TO_PASS) "AR=$${AR}" "AS=$${AS}" \
--                "CC=$${CC}" "CXX=$${CXX}" "LD=$${LD}" "NM=$${NM}" \
--                "RANLIB=$${RANLIB}" \
--                "DLLTOOL=$${DLLTOOL}" "WINDRES=$${WINDRES}" \
--                distclean) \
--        || exit 1
--
--
- .PHONY: maybe-distclean-release distclean-release
- maybe-distclean-release:
-@@ -15685,7 +15501,6 @@
-     maybe-maintainer-clean-perl \
-     maybe-maintainer-clean-prms \
-     maybe-maintainer-clean-rcs \
--    maybe-maintainer-clean-readline \
-     maybe-maintainer-clean-release \
-     maybe-maintainer-clean-recode \
-     maybe-maintainer-clean-sed \
-@@ -16612,27 +16427,6 @@
-         || exit 1
--.PHONY: maybe-maintainer-clean-readline maintainer-clean-readline
--maybe-maintainer-clean-readline:
--
--maintainer-clean-readline: 
--      @[ -f ./readline/Makefile ] || exit 0; \
--      r=`${PWD_COMMAND}`; export r; \
--      s=`cd $(srcdir); ${PWD_COMMAND}`; export s; \
--      $(SET_LIB_PATH) \
--      for flag in $(EXTRA_HOST_FLAGS); do \
--        eval `echo "$$flag" | sed -e "s|^\([^=]*\)=\(.*\)|\1='\2'; export \1|"`; \
--      done; \
--      echo "Doing maintainer-clean in readline" ; \
--      (cd readline && \
--        $(MAKE) $(BASE_FLAGS_TO_PASS) "AR=$${AR}" "AS=$${AS}" \
--                "CC=$${CC}" "CXX=$${CXX}" "LD=$${LD}" "NM=$${NM}" \
--                "RANLIB=$${RANLIB}" \
--                "DLLTOOL=$${DLLTOOL}" "WINDRES=$${WINDRES}" \
--                maintainer-clean) \
--        || exit 1
--
--
- .PHONY: maybe-maintainer-clean-release maintainer-clean-release
- maybe-maintainer-clean-release:
-@@ -17531,7 +17325,6 @@
+@@ -812,7 +811,6 @@
+ all-host: maybe-all-perl
+ all-host: maybe-all-prms
+ all-host: maybe-all-rcs
+-all-host: maybe-all-readline
+ all-host: maybe-all-release
+ all-host: maybe-all-recode
+ all-host: maybe-all-sed
+@@ -927,7 +925,6 @@
+ info-host: maybe-info-perl
+ info-host: maybe-info-prms
+ info-host: maybe-info-rcs
+-info-host: maybe-info-readline
+ info-host: maybe-info-release
+ info-host: maybe-info-recode
+ info-host: maybe-info-sed
+@@ -1033,7 +1030,6 @@
+ dvi-host: maybe-dvi-perl
+ dvi-host: maybe-dvi-prms
+ dvi-host: maybe-dvi-rcs
+-dvi-host: maybe-dvi-readline
+ dvi-host: maybe-dvi-release
+ dvi-host: maybe-dvi-recode
+ dvi-host: maybe-dvi-sed
+@@ -1245,7 +1241,6 @@
+ html-host: maybe-html-perl
+ html-host: maybe-html-prms
+ html-host: maybe-html-rcs
+-html-host: maybe-html-readline
+ html-host: maybe-html-release
+ html-host: maybe-html-recode
+ html-host: maybe-html-sed
+@@ -1351,7 +1346,6 @@
+ TAGS-host: maybe-TAGS-perl
+ TAGS-host: maybe-TAGS-prms
+ TAGS-host: maybe-TAGS-rcs
+-TAGS-host: maybe-TAGS-readline
+ TAGS-host: maybe-TAGS-release
+ TAGS-host: maybe-TAGS-recode
+ TAGS-host: maybe-TAGS-sed
+@@ -1457,7 +1451,6 @@
+ install-info-host: maybe-install-info-perl
+ install-info-host: maybe-install-info-prms
+ install-info-host: maybe-install-info-rcs
+-install-info-host: maybe-install-info-readline
+ install-info-host: maybe-install-info-release
+ install-info-host: maybe-install-info-recode
+ install-info-host: maybe-install-info-sed
+@@ -1669,7 +1662,6 @@
+ install-html-host: maybe-install-html-perl
+ install-html-host: maybe-install-html-prms
+ install-html-host: maybe-install-html-rcs
+-install-html-host: maybe-install-html-readline
+ install-html-host: maybe-install-html-release
+ install-html-host: maybe-install-html-recode
+ install-html-host: maybe-install-html-sed
+@@ -1775,7 +1767,6 @@
+ installcheck-host: maybe-installcheck-perl
+ installcheck-host: maybe-installcheck-prms
+ installcheck-host: maybe-installcheck-rcs
+-installcheck-host: maybe-installcheck-readline
+ installcheck-host: maybe-installcheck-release
+ installcheck-host: maybe-installcheck-recode
+ installcheck-host: maybe-installcheck-sed
+@@ -1881,7 +1872,6 @@
+ mostlyclean-host: maybe-mostlyclean-perl
+ mostlyclean-host: maybe-mostlyclean-prms
+ mostlyclean-host: maybe-mostlyclean-rcs
+-mostlyclean-host: maybe-mostlyclean-readline
+ mostlyclean-host: maybe-mostlyclean-release
+ mostlyclean-host: maybe-mostlyclean-recode
+ mostlyclean-host: maybe-mostlyclean-sed
+@@ -1987,7 +1977,6 @@
+ clean-host: maybe-clean-perl
+ clean-host: maybe-clean-prms
+ clean-host: maybe-clean-rcs
+-clean-host: maybe-clean-readline
+ clean-host: maybe-clean-release
+ clean-host: maybe-clean-recode
+ clean-host: maybe-clean-sed
+@@ -2093,7 +2082,6 @@
+ distclean-host: maybe-distclean-perl
+ distclean-host: maybe-distclean-prms
+ distclean-host: maybe-distclean-rcs
+-distclean-host: maybe-distclean-readline
+ distclean-host: maybe-distclean-release
+ distclean-host: maybe-distclean-recode
+ distclean-host: maybe-distclean-sed
+@@ -2199,7 +2187,6 @@
+ maintainer-clean-host: maybe-maintainer-clean-perl
+ maintainer-clean-host: maybe-maintainer-clean-prms
+ maintainer-clean-host: maybe-maintainer-clean-rcs
+-maintainer-clean-host: maybe-maintainer-clean-readline
+ maintainer-clean-host: maybe-maintainer-clean-release
+ maintainer-clean-host: maybe-maintainer-clean-recode
+ maintainer-clean-host: maybe-maintainer-clean-sed
+@@ -2359,7 +2346,6 @@
      maybe-check-perl \
      maybe-check-prms \
      maybe-check-rcs \
@@ -384,7 +142,7 @@ diff -urN gdb-6.0.org/gdb/Makefile.in gdb-6.0/gdb/Makefile.in
      maybe-check-release \
      maybe-check-recode \
      maybe-check-sed \
-@@ -17641,7 +17434,6 @@
+@@ -2491,7 +2477,6 @@
      maybe-install-perl \
      maybe-install-prms \
      maybe-install-rcs \
@@ -392,7 +150,7 @@ diff -urN gdb-6.0.org/gdb/Makefile.in gdb-6.0/gdb/Makefile.in
      maybe-install-release \
      maybe-install-recode \
      maybe-install-sed \
-@@ -17708,7 +17500,6 @@
+@@ -2564,7 +2549,6 @@
      maybe-install-perl \
      maybe-install-prms \
      maybe-install-rcs \
@@ -400,95 +158,19 @@ diff -urN gdb-6.0.org/gdb/Makefile.in gdb-6.0/gdb/Makefile.in
      maybe-install-release \
      maybe-install-recode \
      maybe-install-sed \
-@@ -20631,73 +20422,6 @@
-       (cd rcs && $(MAKE) $(FLAGS_TO_PASS) install)
--.PHONY: configure-readline maybe-configure-readline
--maybe-configure-readline:
--configure-readline:
--      @test ! -f readline/Makefile || exit 0; \
--      [ -d readline ] || mkdir readline; \
--      r=`${PWD_COMMAND}`; export r; \
--      s=`cd $(srcdir); ${PWD_COMMAND}`; export s; \
--      CC="$(CC)"; export CC; \
--      CFLAGS="$(CFLAGS)"; export CFLAGS; \
--      CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
--      CXX="$(CXX)"; export CXX; \
--      CXXFLAGS="$(CXXFLAGS)"; export CXXFLAGS; \
--      AR="$(AR)"; export AR; \
--      AS="$(AS)"; export AS; \
--      CC_FOR_BUILD="$(CC_FOR_BUILD)"; export CC_FOR_BUILD; \
--      DLLTOOL="$(DLLTOOL)"; export DLLTOOL; \
--      LD="$(LD)"; export LD; \
--      NM="$(NM)"; export NM; \
--      RANLIB="$(RANLIB)"; export RANLIB; \
--      WINDRES="$(WINDRES)"; export WINDRES; \
--      OBJCOPY="$(OBJCOPY)"; export OBJCOPY; \
--      OBJDUMP="$(OBJDUMP)"; export OBJDUMP; \
--      echo Configuring in readline; \
--      cd readline || exit 1; \
--      case $(srcdir) in \
--        \.) \
--          srcdiroption="--srcdir=."; \
--          libsrcdir=".";; \
--        /* | [A-Za-z]:[\\/]*) \
--          srcdiroption="--srcdir=$(srcdir)/readline"; \
--          libsrcdir="$$s/readline";; \
--        *) \
--          srcdiroption="--srcdir=../$(srcdir)/readline"; \
--          libsrcdir="$$s/readline";; \
--      esac; \
--      $(SHELL) $${libsrcdir}/configure \
--        $(HOST_CONFIGARGS) $${srcdiroption} \
--        || exit 1
--
--.PHONY: all-readline maybe-all-readline
--maybe-all-readline:
--all-readline: configure-readline
--      @r=`${PWD_COMMAND}`; export r; \
--      s=`cd $(srcdir); ${PWD_COMMAND}`; export s; \
--      $(SET_LIB_PATH) \
--      (cd readline && $(MAKE) $(FLAGS_TO_PASS) all)
--
--.PHONY: check-readline maybe-check-readline
--maybe-check-readline:
--
--check-readline:
--      @r=`${PWD_COMMAND}`; export r; \
--      s=`cd $(srcdir); ${PWD_COMMAND}`; export s; \
--      $(SET_LIB_PATH) \
--      (cd readline && $(MAKE) $(FLAGS_TO_PASS) check)
--
--
--.PHONY: install-readline maybe-install-readline
--maybe-install-readline:
--
--install-readline: installdirs
--      @r=`${PWD_COMMAND}`; export r; \
--      s=`cd $(srcdir); ${PWD_COMMAND}`; export s; \
--      $(SET_LIB_PATH) \
--      (cd readline && $(MAKE) $(FLAGS_TO_PASS) install)
--
--
- .PHONY: configure-release maybe-configure-release
- maybe-configure-release:
- configure-release:
-@@ -23771,7 +23495,7 @@
- # GDB needs to know that the simulator is being built.
- configure-gdb: maybe-configure-itcl maybe-configure-tcl maybe-configure-tk maybe-configure-sim
- GDB_TK = @GDB_TK@
--all-gdb: maybe-all-libiberty maybe-all-opcodes maybe-all-bfd maybe-all-mmalloc maybe-all-readline maybe-all-bison maybe-all-byacc maybe-all-sim $(gdbnlmrequirements) $(GDB_TK)
-+all-gdb: maybe-all-libiberty maybe-all-opcodes maybe-all-bfd maybe-all-mmalloc maybe-all-bison maybe-all-byacc maybe-all-sim $(gdbnlmrequirements) $(GDB_TK)
- install-gdb: maybe-install-tcl maybe-install-tk maybe-install-itcl maybe-install-tix maybe-install-libgui
- configure-libgui: maybe-configure-tcl maybe-configure-tk
- all-libgui: maybe-all-tcl maybe-all-tk maybe-all-itcl
-@@ -23802,7 +23526,7 @@
- install-itcl: maybe-install-tcl
- all-sid: maybe-all-libiberty maybe-all-bfd maybe-all-opcodes maybe-all-tcl maybe-all-tk
- install-sid: maybe-install-tcl maybe-install-tk
--all-sim: maybe-all-libiberty maybe-all-bfd maybe-all-opcodes maybe-all-readline maybe-configure-gdb
-+all-sim: maybe-all-libiberty maybe-all-bfd maybe-all-opcodes maybe-configure-gdb
- configure-tk: maybe-configure-tcl
- all-tk: maybe-all-tcl
- configure-tix: maybe-configure-tcl maybe-configure-tk
+@@ -51494,7 +51478,6 @@
+ all-gdb: maybe-all-intl
+ all-gdb: maybe-all-libiberty
+ all-gdb: maybe-all-opcodes
+-all-gdb: maybe-all-readline
+ all-gdb: maybe-all-build-bison
+ all-gdb: maybe-all-build-byacc
+ all-gdb: maybe-all-sim
+@@ -51826,7 +51809,6 @@
+ all-sim: maybe-all-libiberty
+ all-sim: maybe-all-bfd
+ all-sim: maybe-all-opcodes
+-all-sim: maybe-all-readline
+ all-sim: maybe-configure-gdb
+ all-fastjar: maybe-all-zlib
+ all-fastjar: maybe-all-build-texinfo
This page took 0.183283 seconds and 4 git commands to generate.