]> git.pld-linux.org Git - packages/crossavr-gdb.git/blob - crossavr-gdb.spec
- cleanup
[packages/crossavr-gdb.git] / crossavr-gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
3 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
4 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
5 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
6 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
7 Summary(ru.UTF-8):      Символический отладчик для C и других языков
8 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
9 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
10 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
11 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
12 %define snap    20090126
13 Name:           crossavr-gdb
14 Version:        6.8.50
15 Release:        0.%{snap}.1
16 License:        GPL v3+
17 Group:          Development/Debuggers
18 #Source0:       http://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.bz2
19 Source0:        ftp://sourceware.org/pub/gdb/snapshots/current/gdb-%{version}.%{snap}.tar.bz2
20 # Source0-md5:  f5dd305323b9dac339a7752719d5ac88
21 Patch0:         gdb-readline.patch
22 Patch1:         gdb-info.patch
23 Patch2:         gdb-passflags.patch
24 Patch4:         gdb-gdbinit-stat.patch
25 Patch5:         gdb-pretty-print-by-default.patch
26 Patch6:         gdb-absolute-gnu_debuglink-path.patch
27 URL:            http://www.gnu.org/software/gdb/
28 BuildRequires:  autoconf >= 2.53
29 BuildRequires:  automake
30 BuildRequires:  bison
31 BuildRequires:  flex
32 BuildRequires:  libtool
33 BuildRequires:  ncurses-devel >= 5.2
34 BuildRequires:  readline-devel >= 4.3
35 BuildRequires:  texinfo
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         target          avr
39
40 %description
41 Gdb is a full featured, command driven debugger. Gdb allows you to
42 trace the execution of programs and examine their internal state at
43 any time. Gdb works for C and C++ compiled with the GNU C compiler
44 gcc.
45
46 %description -l de.UTF-8
47 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
48 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
49 kompiliertes C++.
50
51 %description -l es.UTF-8
52 Este es un depurador orientado a comandos repleto de características.
53 Te permite rastrear la ejecución de programas y examinar su estado
54 interno a cualquier momento. Funciona para C y C++ compilado con el
55 compilador GNU C.
56
57 %description -l fr.UTF-8
58 Débugger complet, piloté par commandes. Permet de tracer l'exécution
59 des programmes et d'examiner à tout moment leur état interne.
60 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
61 de GNU, gcc.
62
63 %description -l pl.UTF-8
64 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
65 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
66 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
67 przy pomocy kompilatora GNU (gcc).
68
69 %description -l pt_BR.UTF-8
70 Este é um debugger orientado a comandos repleto de características.
71 Ele permite à você rastrear a execução de programas e examinar o seu
72 estado interno a qualquer momento. Ele funciona para para C e C++
73 compilado com o compilador GNU C.
74
75 %description -l ru.UTF-8
76 Это полноценный отладчик, управляемый командами. Он позволяет
77 трассировать исполнение программ и изучать их внутреннее состояние в
78 любой момент времени. Работает с программами на C и C++,
79 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
80
81 %description -l tr.UTF-8
82 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
83 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
84 verir.
85
86 %description -l uk.UTF-8
87 Це повноцінний відладчик, що керується командами. Він дозволяє
88 трасувати виконання програм та вивчати їх внутрішній стан в довільний
89 момент часу. Працює з програмами на C та C++, зкомпільованими
90 компіляторами GNU C (gcc, egcs, pgcc).
91
92 %prep
93 %setup -q -n gdb-%{version}.%{snap}
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 %patch4 -p0
98 %patch5 -p1
99 %patch6 -p1
100
101 %build
102 for dir in `find gdb/ -name 'configure.in'`; do
103         dir=$(dirname "$dir")
104         olddir=$(pwd)
105         cd $dir
106         rm -f aclocal.m4
107         %{__aclocal}
108         %{__autoconf}
109         cd $olddir
110 done
111 cp -f /usr/share/automake/config.* .
112 # don't --enable-shared here, there would be libs version mismatch with binutils
113 %configure \
114         --target=%{target} \
115         --disable-gdbtk \
116         --disable-shared \
117         --enable-gdbcli \
118         --enable-gdbmi \
119         --enable-multi-ice \
120         --enable-netrom \
121         --enable-nls \
122         --enable-tui \
123         --with-cpu=%{_target_cpu} \
124 %ifnarch alpha
125         --with-mmalloc \
126 %endif
127         --without-included-gettext \
128         --without-included-regex \
129         --without-x
130
131 %{__make}
132 %{__make} info
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT%{_infodir}
137
138 %{__make} install \
139         prefix=$RPM_BUILD_ROOT%{_prefix} \
140         bindir=$RPM_BUILD_ROOT%{_bindir} \
141         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
142         infodir=$RPM_BUILD_ROOT%{_infodir} \
143         includedir=$RPM_BUILD_ROOT%{_includedir} \
144         libdir=$RPM_BUILD_ROOT%{_libdir} \
145         mandir=$RPM_BUILD_ROOT%{_mandir}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %files
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/%{target}-gdb*
153 %{_mandir}/man1/%{target}-gdb*.1*
This page took 0.191855 seconds and 3 git commands to generate.