]> git.pld-linux.org Git - packages/crossavr-gdb.git/blob - crossavr-gdb.spec
- tabs in preamble
[packages/crossavr-gdb.git] / crossavr-gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
3 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
4 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
5 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
6 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
7 Summary(ru.UTF-8):      Символический отладчик для C и других языков
8 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
9 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
10 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
11 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
12 Name:           crossavr-gdb
13 Version:        6.2.1
14 Release:        0.1
15 License:        GPL
16 Group:          Development/Debuggers
17 Source0:        ftp://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.bz2
18 # Source0-md5:  3b3898cfd426e1acd5efc89560aa93ba
19 Patch0:         gdb-ncurses.patch
20 Patch1:         gdb-readline.patch
21 Patch2:         gdb-info.patch
22 Patch3:         gdb-passflags.patch
23 Patch4:         gdb-headers.patch
24 BuildRequires:  XFree86-devel
25 BuildRequires:  autoconf >= 2.53
26 BuildRequires:  automake
27 BuildRequires:  libtool
28 BuildRequires:  ncurses-devel >= 5.2
29 BuildRequires:  readline-devel >= 4.2
30 BuildRequires:  texinfo
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         target          avr
34
35 %description
36 Gdb is a full featured, command driven debugger. Gdb allows you to
37 trace the execution of programs and examine their internal state at
38 any time. Gdb works for C and C++ compiled with the GNU C compiler
39 gcc.
40
41 %description -l de.UTF-8
42 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
43 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
44 kompiliertes C++.
45
46 %description -l es.UTF-8
47 Este es un depurador orientado a comandos repleto de características.
48 Te permite rastrear la ejecución de programas y examinar su estado
49 interno a cualquier momento. Funciona para C y C++ compilado con el
50 compilador GNU C.
51
52 %description -l fr.UTF-8
53 Débugger complet, piloté par commandes. Permet de tracer l'exécution
54 des programmes et d'examiner à tout moment leur état interne.
55 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
56 de GNU, gcc.
57
58 %description -l pl.UTF-8
59 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
60 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
61 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
62 przy pomocy kompilatora GNU (gcc).
63
64 %description -l pt_BR.UTF-8
65 Este é um debugger orientado a comandos repleto de características.
66 Ele permite à você rastrear a execução de programas e examinar o seu
67 estado interno a qualquer momento. Ele funciona para para C e C++
68 compilado com o compilador GNU C.
69
70 %description -l ru.UTF-8
71 Это полноценный отладчик, управляемый командами. Он позволяет
72 трассировать исполнение программ и изучать их внутреннее состояние в
73 любой момент времени. Работает с программами на C и C++,
74 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
75
76 %description -l tr.UTF-8
77 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
78 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
79 verir.
80
81 %description -l uk.UTF-8
82 Це повноцінний відладчик, що керується командами. Він дозволяє
83 трасувати виконання програм та вивчати їх внутрішній стан в довільний
84 момент часу. Працює з програмами на C та C++, зкомпільованими
85 компіляторами GNU C (gcc, egcs, pgcc).
86
87 %prep
88 %setup -q -n gdb-%{version}
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92 %patch3 -p1
93 %patch4 -p1
94
95 %build
96 for dir in `find gdb/ -name 'configure.in'`; do
97         dir=$(dirname "$dir")
98         olddir=$(pwd)
99         cd $dir
100         %{__aclocal}
101         %{__autoconf}
102         cd $olddir
103 done
104 cp -f /usr/share/automake/config.* .
105 # !! Don't enable shared here !!
106 # This will cause serious problems --misiek
107 %configure2_13 \
108         --target=%{target} \
109         --disable-shared \
110         --enable-nls \
111         --without-included-gettext \
112         --without-included-regex \
113         --enable-gdcli \
114         --enable-gdbmi \
115         --enable-multi-ice \
116         --enable-netrom \
117         --with-cpu=%{_target_cpu} \
118         --enable-tui \
119 %ifnarch alpha
120         --with-mmalloc
121 %endif
122
123 # something is wrong after above - e.g. $exeext=="no" - fix it:
124 cd gdb
125 %configure \
126         --target=%{target}
127 cd ..
128
129 %{__make}
130 %{__make} info
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT%{_infodir}
135
136 %{__make} install \
137         prefix=$RPM_BUILD_ROOT%{_prefix} \
138         bindir=$RPM_BUILD_ROOT%{_bindir} \
139         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
140         infodir=$RPM_BUILD_ROOT%{_infodir} \
141         includedir=$RPM_BUILD_ROOT%{_includedir} \
142         libdir=$RPM_BUILD_ROOT%{_libdir} \
143         mandir=$RPM_BUILD_ROOT%{_mandir}
144
145 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %files
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/%{target}-gdb*
153 %{_mandir}/man1/%{target}-gdb*.1*
This page took 0.048103 seconds and 3 git commands to generate.