]> git.pld-linux.org Git - packages/crossavr-gdb.git/blame - crossavr-gdb.spec
- cleanup
[packages/crossavr-gdb.git] / crossavr-gdb.spec
CommitLineData
f6fdc30b 1Summary: A GNU source-level debugger for C, C++ and Fortran
3e4fa848
ER
2Summary(de.UTF-8): Symbolischer Debugger für C und andere Sprachen
3Summary(es.UTF-8): Depurador de programas C y otras lenguajes
4Summary(fr.UTF-8): Débugger symbolique pour C et d'autres langages
5Summary(pl.UTF-8): Symboliczny odpluskwiacz dla C i innych języków
6Summary(pt_BR.UTF-8): Depurador de programas C e outras linguagens
7Summary(ru.UTF-8): Символический отладчик для C и других языков
8Summary(tr.UTF-8): C ve diğer diller için sembolik hata ayıklayıcı
9Summary(uk.UTF-8): Символьний відладчик для С та інших мов
10Summary(zh_CN.UTF-8): [开发]C和其他语言的调试器
11Summary(zh_TW.UTF-8): [.-A開發]C和.$)B其.-A他語.$)B言的調試器
972ab68d 12%define snap 20090126
f6fdc30b 13Name: crossavr-gdb
b60a23d7
BZ
14Version: 6.8.50
15Release: 0.%{snap}.1
16License: GPL v3+
f6fdc30b 17Group: Development/Debuggers
b60a23d7
BZ
18#Source0: http://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.bz2
19Source0: ftp://sourceware.org/pub/gdb/snapshots/current/gdb-%{version}.%{snap}.tar.bz2
972ab68d 20# Source0-md5: f5dd305323b9dac339a7752719d5ac88
dc0c373a 21Patch0: gdb-readline.patch
22Patch1: gdb-info.patch
23Patch2: gdb-passflags.patch
b60a23d7
BZ
24Patch4: gdb-gdbinit-stat.patch
25Patch5: gdb-pretty-print-by-default.patch
26Patch6: gdb-absolute-gnu_debuglink-path.patch
27URL: http://www.gnu.org/software/gdb/
f6fdc30b
AM
28BuildRequires: autoconf >= 2.53
29BuildRequires: automake
b60a23d7
BZ
30BuildRequires: bison
31BuildRequires: flex
f6fdc30b
AM
32BuildRequires: libtool
33BuildRequires: ncurses-devel >= 5.2
b60a23d7 34BuildRequires: readline-devel >= 4.3
972ab68d 35BuildRequires: texinfo
913366b2 36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
f6fdc30b 37
68687887 38%define target avr
f6fdc30b
AM
39
40%description
41Gdb is a full featured, command driven debugger. Gdb allows you to
42trace the execution of programs and examine their internal state at
43any time. Gdb works for C and C++ compiled with the GNU C compiler
44gcc.
45
14ab84e5
JR
46%description -l de.UTF-8
47dem Sie die Ausführung von Programmen verfolgen und jederzeit den
48inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
f6fdc30b
AM
49kompiliertes C++.
50
14ab84e5
JR
51%description -l es.UTF-8
52Este es un depurador orientado a comandos repleto de características.
53Te permite rastrear la ejecución de programas y examinar su estado
f6fdc30b
AM
54interno a cualquier momento. Funciona para C y C++ compilado con el
55compilador GNU C.
56
14ab84e5
JR
57%description -l fr.UTF-8
58Débugger complet, piloté par commandes. Permet de tracer l'exécution
59des programmes et d'examiner à tout moment leur état interne.
60Fonctionne avec les binaires C et C++ compilés avec le compilateur C
f6fdc30b
AM
61de GNU, gcc.
62
14ab84e5
JR
63%description -l pl.UTF-8
64Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
65śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
66umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
f6fdc30b
AM
67przy pomocy kompilatora GNU (gcc).
68
14ab84e5
JR
69%description -l pt_BR.UTF-8
70Este é um debugger orientado a comandos repleto de características.
71Ele permite à você rastrear a execução de programas e examinar o seu
f6fdc30b
AM
72estado interno a qualquer momento. Ele funciona para para C e C++
73compilado com o compilador GNU C.
74
14ab84e5
JR
75%description -l ru.UTF-8
76Это полноценный отладчик, управляемый командами. Он позволяет
77трассировать исполнение программ и изучать их внутреннее состояние в
78любой момент времени. Работает с программами на C и C++,
79скомпилированными GNU компилятором C (gcc, egcs, pgcc).
f6fdc30b 80
14ab84e5
JR
81%description -l tr.UTF-8
82Bir komut arayüzü üzerinden programcıya programını adım adım izleme
83(trace) ve herhangi bir anda programın durumunu inceleme olanağı
f6fdc30b
AM
84verir.
85
14ab84e5
JR
86%description -l uk.UTF-8
87Це повноцінний відладчик, що керується командами. Він дозволяє
88трасувати виконання програм та вивчати їх внутрішній стан в довільний
89момент часу. Працює з програмами на C та C++, зкомпільованими
90компіляторами GNU C (gcc, egcs, pgcc).
f6fdc30b
AM
91
92%prep
b60a23d7 93%setup -q -n gdb-%{version}.%{snap}
f6fdc30b
AM
94%patch0 -p1
95%patch1 -p1
96%patch2 -p1
b60a23d7
BZ
97%patch4 -p0
98%patch5 -p1
99%patch6 -p1
f6fdc30b
AM
100
101%build
102for dir in `find gdb/ -name 'configure.in'`; do
103 dir=$(dirname "$dir")
104 olddir=$(pwd)
105 cd $dir
b60a23d7 106 rm -f aclocal.m4
f6fdc30b
AM
107 %{__aclocal}
108 %{__autoconf}
109 cd $olddir
110done
111cp -f /usr/share/automake/config.* .
b60a23d7
BZ
112# don't --enable-shared here, there would be libs version mismatch with binutils
113%configure \
382c0b27 114 --target=%{target} \
b60a23d7 115 --disable-gdbtk \
f6fdc30b 116 --disable-shared \
b60a23d7 117 --enable-gdbcli \
f6fdc30b
AM
118 --enable-gdbmi \
119 --enable-multi-ice \
120 --enable-netrom \
b60a23d7 121 --enable-nls \
f6fdc30b 122 --enable-tui \
b60a23d7 123 --with-cpu=%{_target_cpu} \
f6fdc30b 124%ifnarch alpha
b60a23d7 125 --with-mmalloc \
f6fdc30b 126%endif
b60a23d7
BZ
127 --without-included-gettext \
128 --without-included-regex \
129 --without-x
f6fdc30b
AM
130
131%{__make}
132%{__make} info
133
134%install
135rm -rf $RPM_BUILD_ROOT
136install -d $RPM_BUILD_ROOT%{_infodir}
137
0da9cde4 138%{__make} install \
f6fdc30b
AM
139 prefix=$RPM_BUILD_ROOT%{_prefix} \
140 bindir=$RPM_BUILD_ROOT%{_bindir} \
141 sbindir=$RPM_BUILD_ROOT%{_sbindir} \
142 infodir=$RPM_BUILD_ROOT%{_infodir} \
143 includedir=$RPM_BUILD_ROOT%{_includedir} \
144 libdir=$RPM_BUILD_ROOT%{_libdir} \
145 mandir=$RPM_BUILD_ROOT%{_mandir}
146
f6fdc30b
AM
147%clean
148rm -rf $RPM_BUILD_ROOT
149
f6fdc30b
AM
150%files
151%defattr(644,root,root,755)
0da9cde4
JB
152%attr(755,root,root) %{_bindir}/%{target}-gdb*
153%{_mandir}/man1/%{target}-gdb*.1*
This page took 0.103 seconds and 4 git commands to generate.