]> git.pld-linux.org Git - packages/crossavr-gdb.git/blame - crossavr-gdb.spec
- sync with gdb.spec
[packages/crossavr-gdb.git] / crossavr-gdb.spec
CommitLineData
f6fdc30b 1Summary: A GNU source-level debugger for C, C++ and Fortran
3e4fa848
ER
2Summary(de.UTF-8): Symbolischer Debugger für C und andere Sprachen
3Summary(es.UTF-8): Depurador de programas C y otras lenguajes
4Summary(fr.UTF-8): Débugger symbolique pour C et d'autres langages
5Summary(pl.UTF-8): Symboliczny odpluskwiacz dla C i innych języków
6Summary(pt_BR.UTF-8): Depurador de programas C e outras linguagens
7Summary(ru.UTF-8): Символический отладчик для C и других языков
8Summary(tr.UTF-8): C ve diğer diller için sembolik hata ayıklayıcı
9Summary(uk.UTF-8): Символьний відладчик для С та інших мов
10Summary(zh_CN.UTF-8): [开发]C和其他语言的调试器
11Summary(zh_TW.UTF-8): [.-A開發]C和.$)B其.-A他語.$)B言的調試器
b60a23d7 12%define snap 20090120
f6fdc30b 13Name: crossavr-gdb
b60a23d7
BZ
14Version: 6.8.50
15Release: 0.%{snap}.1
16License: GPL v3+
f6fdc30b 17Group: Development/Debuggers
b60a23d7
BZ
18#Source0: http://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.bz2
19Source0: ftp://sourceware.org/pub/gdb/snapshots/current/gdb-%{version}.%{snap}.tar.bz2
146557f3 20# Source0-md5: 30a6bf36eded4ae5a152d7d71b86dc14
dc0c373a 21Patch0: gdb-readline.patch
22Patch1: gdb-info.patch
23Patch2: gdb-passflags.patch
b60a23d7
BZ
24Patch4: gdb-gdbinit-stat.patch
25Patch5: gdb-pretty-print-by-default.patch
26Patch6: gdb-absolute-gnu_debuglink-path.patch
27URL: http://www.gnu.org/software/gdb/
f6fdc30b
AM
28BuildRequires: autoconf >= 2.53
29BuildRequires: automake
b60a23d7
BZ
30BuildRequires: bison
31BuildRequires: flex
f6fdc30b
AM
32BuildRequires: libtool
33BuildRequires: ncurses-devel >= 5.2
b60a23d7 34BuildRequires: readline-devel >= 4.3
913366b2 35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
f6fdc30b 36
68687887 37%define target avr
f6fdc30b
AM
38
39%description
40Gdb is a full featured, command driven debugger. Gdb allows you to
41trace the execution of programs and examine their internal state at
42any time. Gdb works for C and C++ compiled with the GNU C compiler
43gcc.
44
14ab84e5
JR
45%description -l de.UTF-8
46dem Sie die Ausführung von Programmen verfolgen und jederzeit den
47inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
f6fdc30b
AM
48kompiliertes C++.
49
14ab84e5
JR
50%description -l es.UTF-8
51Este es un depurador orientado a comandos repleto de características.
52Te permite rastrear la ejecución de programas y examinar su estado
f6fdc30b
AM
53interno a cualquier momento. Funciona para C y C++ compilado con el
54compilador GNU C.
55
14ab84e5
JR
56%description -l fr.UTF-8
57Débugger complet, piloté par commandes. Permet de tracer l'exécution
58des programmes et d'examiner à tout moment leur état interne.
59Fonctionne avec les binaires C et C++ compilés avec le compilateur C
f6fdc30b
AM
60de GNU, gcc.
61
14ab84e5
JR
62%description -l pl.UTF-8
63Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
64śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
65umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
f6fdc30b
AM
66przy pomocy kompilatora GNU (gcc).
67
14ab84e5
JR
68%description -l pt_BR.UTF-8
69Este é um debugger orientado a comandos repleto de características.
70Ele permite à você rastrear a execução de programas e examinar o seu
f6fdc30b
AM
71estado interno a qualquer momento. Ele funciona para para C e C++
72compilado com o compilador GNU C.
73
14ab84e5
JR
74%description -l ru.UTF-8
75Это полноценный отладчик, управляемый командами. Он позволяет
76трассировать исполнение программ и изучать их внутреннее состояние в
77любой момент времени. Работает с программами на C и C++,
78скомпилированными GNU компилятором C (gcc, egcs, pgcc).
f6fdc30b 79
14ab84e5
JR
80%description -l tr.UTF-8
81Bir komut arayüzü üzerinden programcıya programını adım adım izleme
82(trace) ve herhangi bir anda programın durumunu inceleme olanağı
f6fdc30b
AM
83verir.
84
14ab84e5
JR
85%description -l uk.UTF-8
86Це повноцінний відладчик, що керується командами. Він дозволяє
87трасувати виконання програм та вивчати їх внутрішній стан в довільний
88момент часу. Працює з програмами на C та C++, зкомпільованими
89компіляторами GNU C (gcc, egcs, pgcc).
f6fdc30b
AM
90
91%prep
b60a23d7 92%setup -q -n gdb-%{version}.%{snap}
f6fdc30b
AM
93%patch0 -p1
94%patch1 -p1
95%patch2 -p1
b60a23d7
BZ
96%patch4 -p0
97%patch5 -p1
98%patch6 -p1
f6fdc30b
AM
99
100%build
101for dir in `find gdb/ -name 'configure.in'`; do
102 dir=$(dirname "$dir")
103 olddir=$(pwd)
104 cd $dir
b60a23d7 105 rm -f aclocal.m4
f6fdc30b
AM
106 %{__aclocal}
107 %{__autoconf}
108 cd $olddir
109done
110cp -f /usr/share/automake/config.* .
b60a23d7
BZ
111# don't --enable-shared here, there would be libs version mismatch with binutils
112%configure \
113 --target=%{target} \
114 --disable-gdbtk \
f6fdc30b 115 --disable-shared \
b60a23d7 116 --enable-gdbcli \
f6fdc30b
AM
117 --enable-gdbmi \
118 --enable-multi-ice \
119 --enable-netrom \
b60a23d7 120 --enable-nls \
f6fdc30b 121 --enable-tui \
b60a23d7 122 --with-cpu=%{_target_cpu} \
f6fdc30b 123%ifnarch alpha
b60a23d7 124 --with-mmalloc \
f6fdc30b 125%endif
b60a23d7
BZ
126 --without-included-gettext \
127 --without-included-regex \
128 --without-x
f6fdc30b
AM
129
130%{__make}
131%{__make} info
132
133%install
134rm -rf $RPM_BUILD_ROOT
135install -d $RPM_BUILD_ROOT%{_infodir}
136
0da9cde4 137%{__make} install \
f6fdc30b
AM
138 prefix=$RPM_BUILD_ROOT%{_prefix} \
139 bindir=$RPM_BUILD_ROOT%{_bindir} \
140 sbindir=$RPM_BUILD_ROOT%{_sbindir} \
141 infodir=$RPM_BUILD_ROOT%{_infodir} \
142 includedir=$RPM_BUILD_ROOT%{_includedir} \
143 libdir=$RPM_BUILD_ROOT%{_libdir} \
144 mandir=$RPM_BUILD_ROOT%{_mandir}
145
f6fdc30b
AM
146
147%clean
148rm -rf $RPM_BUILD_ROOT
149
f6fdc30b
AM
150%files
151%defattr(644,root,root,755)
0da9cde4
JB
152%attr(755,root,root) %{_bindir}/%{target}-gdb*
153%{_mandir}/man1/%{target}-gdb*.1*
This page took 0.072548 seconds and 4 git commands to generate.