]> git.pld-linux.org Git - packages/crossavr-gcc.git/commitdiff
- fix format string warnings
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 7 Dec 2012 21:39:22 +0000 (22:39 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 7 Dec 2012 21:39:22 +0000 (22:39 +0100)
crossavr-gcc.spec
format-security.patch [new file with mode: 0644]

index eed82f83ad7483ac75ccc711669775fc9d40e7cb..9f60a232ed3a87cb61761d15f096a016114fb516 100644 (file)
@@ -13,6 +13,7 @@ Version:      4.6.2
 Release:       2
 Epoch:         1
 Patch1:                gcc-bug51969.patch
+Patch2:                format-security.patch
 # Patches 1xx are taken form Atmel official AVR8-GNU toolchain version 3.4.0.663.
 Patch100:      200-gcc-libiberty-Makefile.in.patch
 Patch101:      300-gcc-fixedpoint-3-4-2010.patch
@@ -114,6 +115,7 @@ Ten pakiet dodaje obsługę C++ do kompilatora gcc dla AVR.
 %setup -q -n gcc-%{version}
 cd gcc/config/%{target} && %undos -f c,h && cd -
 %patch1 -p2
+%patch2 -p1
 %patch100 -p0
 %patch101 -p0
 %patch102 -p0
diff --git a/format-security.patch b/format-security.patch
new file mode 100644 (file)
index 0000000..b549233
--- /dev/null
@@ -0,0 +1,14 @@
+--- gcc-4.6.2/libcpp/expr.c~   2011-04-29 00:39:59.000000000 +0200
++++ gcc-4.6.2/libcpp/expr.c    2012-12-07 22:38:30.102991906 +0100
+@@ -434,9 +434,9 @@
+                               : N_("use of C99 long long integer constant");
+         if (CPP_OPTION (pfile, c99))
+-            cpp_warning (pfile, CPP_W_LONG_LONG, message);
++            cpp_warning (pfile, CPP_W_LONG_LONG, "%s", message);
+           else
+-            cpp_pedwarning (pfile, CPP_W_LONG_LONG, message);
++            cpp_pedwarning (pfile, CPP_W_LONG_LONG, "%s", message);
+         }
+       result |= CPP_N_INTEGER;
This page took 0.145768 seconds and 4 git commands to generate.