]> git.pld-linux.org Git - packages/crossavr-gcc.git/blobdiff - crossavr-gcc.spec
- updated to 3.4.1, cleanups/unifications
[packages/crossavr-gcc.git] / crossavr-gcc.spec
index dfe5b4c6e22208923be9d8cb92fa2425437a206c..c911386eb16e7f90950bd0734bdf37fe1d79524a 100644 (file)
@@ -5,27 +5,26 @@ Summary(pl):  Skro
 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - AVR gcc
 Summary(tr):    GNU geliþtirme araçlarý - AVR gcc
 Name:          crossavr-gcc
-Version:       3.3.2
+Version:       3.4.1
 Release:       1
 Epoch:         1
 License:       GPL
 Group:         Development/Languages
 Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
-# Source0-md5: 65999f654102f5438ac8562d13a6eced
-BuildRequires: crossavr-binutils
-BuildRequires: flex
-BuildRequires: bison
+# Source0-md5: 31b459062499f9f68d451db9cbf3205c
 BuildRequires: autoconf
 BuildRequires: /bin/bash
+BuildRequires: bison
+BuildRequires: crossavr-binutils
+BuildRequires: flex
 Requires:      crossavr-binutils
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                cxx             0
 %define                target          avr
-%define                _prefix         /usr
 %define                arch            %{_prefix}/%{target}
-%define                gccarch         %{_prefix}/lib/gcc-lib/%{target}
-%define                gcclib          %{_prefix}/lib/gcc-lib/%{target}/%{version}
+%define                gccarch         %{_libdir}/gcc/%{target}
+%define                gcclib          %{_libdir}/gcc/%{target}/%{version}
+%define                _noautostrip    .*%{gcclib}.*/libgc.*\\.a
 
 %description
 This package contains a cross-gcc which allows the creation of
@@ -39,6 +38,18 @@ i386-Rechner Code f
 Ten pakiet zawiera skro¶ny gcc pozwalaj±cy na robienie na maszynach
 i386 binariów do uruchamiania na Atmel AVR.
 
+%package c++
+Summary:       C++ support for avr-gcc
+Summary(pl):   Obs³uga C++ dla avr-gcc
+Group:         Development/Languages
+Requires:      crossavr-gcc = %{epoch}:%{version}-%{release}
+
+%description c++
+This package adds C++ support to the GNU Compiler Collection for AVR.
+
+%description c++ -l pl
+Ten pakiet dodaje obs³ugê C++ do kompilatora gcc dla AVR.
+
 %prep
 %setup -q -n gcc-%{version}
 
@@ -49,63 +60,65 @@ cd obj-%{target}
 
 CFLAGS="%{rpmcflags}" \
 CXXFLAGS="%{rpmcflags}" \
-TEXCONFIG=false ../configure \
+TEXCONFIG=false \
+../configure \
        --prefix=%{_prefix} \
        --infodir=%{_infodir} \
        --mandir=%{_mandir} \
+       --bindir=%{_bindir} \
+       --libdir=%{_libdir} \
+       --libexecdir=%{_libdir} \
        --disable-shared \
-       --enable-languages="c" \
-       --enable-long-long \
+       --enable-languages="c,c++" \
        --with-gnu-as \
        --with-gnu-ld \
        --with-system-zlib \
        --with-multilib \
        --without-x \
+       --build=%{_target_platform} \
+       --host=%{_target_platform} \
        --target=%{target}
 
-PATH=$PATH:/sbin:%{_sbindir}
-
-cd ..
-#LDFLAGS_FOR_TARGET="%{rpmldflags}"
-
-%{__make} -C obj-%{target}
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/lib,%{_datadir},%{_bindir},%{gcclib}}
-
-cd obj-%{target}
-PATH=$PATH:/sbin:%{_sbindir}
 
-%{__make} -C gcc install \
+%{__make} -C obj-%{target} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-# c++filt is provided by binutils
-#rm -f $RPM_BUILD_ROOT%{_bindir}/i386-mipsel-c++filt
-
-# what is this there for???
+# don't want it here
 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
 
-# the same... make hardlink
-#ln -f $RPM_BUILD_ROOT%{arch}/bin/gcc $RPM_BUILD_ROOT%{_bindir}/%{target}-gcc
-
-%{target}-strip -g $RPM_BUILD_ROOT%{gcclib}/libgcc.a
+%if 0%{!?debug:1}
+# strip target libraries
+%{target}-strip -g $RPM_BUILD_ROOT%{gcclib}{,/avr*}/libg*.a
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files
+%files 
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/%{target}-*
+%attr(755,root,root) %{_bindir}/%{target}-gcc*
+%attr(755,root,root) %{_bindir}/%{target}-cpp
+%attr(755,root,root) %{_bindir}/%{target}-gcov
 %dir %{gccarch}
 %dir %{gcclib}
 %attr(755,root,root) %{gcclib}/cc1
-#%attr(755,root,root) %{gcclib}/tradcpp0
-#%attr(755,root,root) %{gcclib}/cpp0
 %attr(755,root,root) %{gcclib}/collect2
-%{gcclib}/libgcc.a
-%{gcclib}/specs*
+%{gcclib}/libg*.a
+%{gcclib}/specs
 %{gcclib}/%{target}*
 %dir %{gcclib}/include
 %{gcclib}/include/*.h
+%{_mandir}/man1/%{target}-cpp.1*
 %{_mandir}/man1/%{target}-gcc.1*
+%{_mandir}/man1/%{target}-gcov.1*
+
+%files c++
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/%{target}-g++
+%attr(755,root,root) %{_bindir}/%{target}-c++
+%attr(755,root,root) %{gcclib}/cc1plus
+%{_mandir}/man1/%{target}-g++.1*
This page took 0.100608 seconds and 4 git commands to generate.