]> git.pld-linux.org Git - packages/crossavr-gcc.git/blob - crossavr-gcc.spec
008051a5072276dad488ce0392005c6e9189b8d2
[packages/crossavr-gcc.git] / crossavr-gcc.spec
1 Summary:        Cross AVR GNU binary utility development utilities - gcc
2 Summary(es):    Utilitarios para desarrollo de binarios de la GNU - AVR gcc
3 Summary(fr):    Utilitaires de développement binaire de GNU - AVR gcc
4 Summary(pl):    Skro¶ne narzêdzia programistyczne GNU dla AVR - gcc
5 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - AVR gcc
6 Summary(tr):    GNU geliþtirme araçlarý - AVR gcc
7 Name:           crossavr-gcc
8 Version:        3.4.1
9 Release:        1
10 Epoch:          1
11 License:        GPL
12 Group:          Development/Languages
13 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
14 # Source0-md5:  31b459062499f9f68d451db9cbf3205c
15 BuildRequires:  autoconf
16 BuildRequires:  /bin/bash
17 BuildRequires:  bison
18 BuildRequires:  crossavr-binutils
19 BuildRequires:  flex
20 Requires:       crossavr-binutils
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         target          avr
24 %define         arch            %{_prefix}/%{target}
25 %define         gccarch         %{_libdir}/gcc/%{target}
26 %define         gcclib          %{_libdir}/gcc/%{target}/%{version}
27 %define         _noautostrip    .*%{gcclib}.*/libgc.*\\.a
28
29 %description
30 This package contains a cross-gcc which allows the creation of
31 binaries to be run on Atmel AVR on other machines.
32
33 %description -l de
34 Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
35 anderem Rechner Code für Atmel AVR zu generieren.
36
37 %description -l pl
38 Ten pakiet zawiera skro¶ny gcc pozwalaj±cy na robienie na innych
39 maszynach binariów do uruchamiania na Atmel AVR.
40
41 %package c++
42 Summary:        C++ support for avr-gcc
43 Summary(pl):    Obs³uga C++ dla avr-gcc
44 Group:          Development/Languages
45 Requires:       %{name} = %{epoch}:%{version}-%{release}
46
47 %description c++
48 This package adds C++ support to the GNU Compiler Collection for AVR.
49
50 %description c++ -l pl
51 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc dla AVR.
52
53 %prep
54 %setup -q -n gcc-%{version}
55
56 %build
57 rm -rf obj-%{target}
58 install -d obj-%{target}
59 cd obj-%{target}
60
61 CFLAGS="%{rpmcflags}" \
62 CXXFLAGS="%{rpmcflags}" \
63 TEXCONFIG=false \
64 ../configure \
65         --prefix=%{_prefix} \
66         --infodir=%{_infodir} \
67         --mandir=%{_mandir} \
68         --bindir=%{_bindir} \
69         --libdir=%{_libdir} \
70         --libexecdir=%{_libdir} \
71         --disable-shared \
72         --enable-languages="c,c++" \
73         --with-gnu-as \
74         --with-gnu-ld \
75         --with-system-zlib \
76         --with-multilib \
77         --without-x \
78         --build=%{_target_platform} \
79         --host=%{_target_platform} \
80         --target=%{target}
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} -C obj-%{target} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 # don't want it here
91 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
92
93 %if 0%{!?debug:1}
94 # strip target libraries
95 %{target}-strip -g $RPM_BUILD_ROOT%{gcclib}{,/avr*}/libg*.a
96 %endif
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files 
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_bindir}/%{target}-gcc*
104 %attr(755,root,root) %{_bindir}/%{target}-cpp
105 %attr(755,root,root) %{_bindir}/%{target}-gcov
106 %dir %{gccarch}
107 %dir %{gcclib}
108 %attr(755,root,root) %{gcclib}/cc1
109 %attr(755,root,root) %{gcclib}/collect2
110 %{gcclib}/libg*.a
111 %{gcclib}/specs
112 %{gcclib}/%{target}*
113 %dir %{gcclib}/include
114 %{gcclib}/include/*.h
115 %{_mandir}/man1/%{target}-cpp.1*
116 %{_mandir}/man1/%{target}-gcc.1*
117 %{_mandir}/man1/%{target}-gcov.1*
118
119 %files c++
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_bindir}/%{target}-g++
122 %attr(755,root,root) %{_bindir}/%{target}-c++
123 %attr(755,root,root) %{gcclib}/cc1plus
124 %{_mandir}/man1/%{target}-g++.1*
This page took 0.06309 seconds and 2 git commands to generate.