]> git.pld-linux.org Git - packages/crossavr-binutils.git/blob - crossavr-binutils.spec
- BR: texinfo
[packages/crossavr-binutils.git] / crossavr-binutils.spec
1 Summary:        Cross AVR GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - AVR binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - AVR binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla AVR - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - AVR binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - AVR binutils
7 Name:           crossavr-binutils
8 Version:        2.17.50.0.14
9 Release:        1
10 License:        GPL
11 Group:          Development/Tools
12 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
13 # Source0-md5:  4ddab973ad9c5169d8f8296bdf67b3f7
14 Patch0:         %{name}-aa.patch
15 Patch1:         %{name}-coff-avr.patch
16 Patch2:         %{name}-newdevices.patch
17 URL:            http://sources.redhat.com/binutils/
18 BuildRequires:  automake
19 BuildRequires:  bash
20 BuildRequires:  bison
21 BuildRequires:  flex
22 BuildRequires:  gettext-devel
23 BuildRequires:  texinfo
24 %ifarch sparc sparc32
25 BuildRequires:  sparc32
26 %endif
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         target          avr
30 %define         arch            %{_prefix}/%{target}
31
32 %description
33 Binutils is a collection of binary utilities, including:
34 - ar - create, modify and extract from archives,
35 - nm - lists symbols from object files,
36 - objcopy - copy and translate object files,
37 - objdump - display information from object files,
38 - ranlib - generate an index for the contents of an archive,
39 - size - list the section sizes of an object or archive file,
40 - strings - list printable strings from files,
41 - strip - discard symbols,
42 - c++filt - a filter for demangling encoded C++ symbols,
43 - addr2line - convert addresses to file and line,
44 - nlmconv - convert object code into an NLM.
45
46 This package contains the cross version for Atmel AVR.
47
48 %description -l pl.UTF-8
49 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
50 programów. Znajdują się tutaj między innymi assembler, konsolidator
51 (linker), a także inne narzędzia do manipulowania binarnymi plikami
52 programów i bibliotek.
53
54 Ten pakiet zawiera wersję skrośną generującą kod dla Atmel AVR.
55
56 %prep
57 %setup -q -n binutils-%{version}
58 %patch0 -p0
59 %patch1 -p0
60 %patch2 -p1
61
62 %build
63 cp /usr/share/automake/config.sub .
64
65 # ldscripts won't be generated properly if SHELL is not bash...
66 CFLAGS="%{rpmcflags}" \
67 LDFLAGS="%{rpmldflags}" \
68 CONFIG_SHELL="/bin/bash" \
69 %ifarch sparc
70 sparc32 \
71 %endif
72 ./configure \
73         --disable-shared \
74         --prefix=%{_prefix} \
75         --libdir=%{_libdir} \
76         --mandir=%{_mandir} \
77         --infodir=%{_infodir} \
78         --target=%{target}
79
80 %{__make} all \
81         tooldir=%{_prefix} \
82         EXEEXT=""
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT%{_prefix}
87
88 %{__make} install \
89         prefix=$RPM_BUILD_ROOT%{_prefix} \
90         mandir=$RPM_BUILD_ROOT%{_mandir} \
91         infodir=$RPM_BUILD_ROOT%{_infodir} \
92         libdir=$RPM_BUILD_ROOT%{_libdir}
93
94 # remove these man pages unless we cross-build for win*/netware platforms.
95 # however, this should be done in Makefiles.
96 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
97
98 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/*.mo
99 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
100 rm -rf $RPM_BUILD_ROOT%{_infodir}
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(644,root,root,755)
107 %doc README
108 %attr(755,root,root) %{_bindir}/%{target}-*
109 %dir %{arch}
110 %dir %{arch}/bin
111 %attr(755,root,root) %{arch}/bin/*
112 %dir %{arch}/lib
113 %dir %{arch}/lib/*
114 %{arch}/lib/*/*
115 %{_mandir}/man?/%{target}-*
This page took 0.03742 seconds and 4 git commands to generate.