]> git.pld-linux.org Git - packages/crossavr-binutils.git/blob - crossavr-binutils.spec
- updated to 2.20.1
[packages/crossavr-binutils.git] / crossavr-binutils.spec
1 Summary:        Cross AVR GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - AVR binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - AVR binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla AVR - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - AVR binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - AVR binutils
7 Name:           crossavr-binutils
8 Version:        2.20.1
9 Release:        1
10 License:        GPL
11 Group:          Development/Tools
12 Source0:        ftp://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.bz2
13 # Source0-md5:  9cdfb9d6ec0578c166d3beae5e15c4e5
14 Patch0:         %{name}-avr-size.patch
15 Patch1:         %{name}-avr-coff.patch
16 Patch2:         %{name}-new-sections.patch
17 Patch3:         %{name}-xmega.patch
18 Patch4:         %{name}-new-devices.patch
19 URL:            http://sources.redhat.com/binutils/
20 BuildRequires:  automake
21 BuildRequires:  bash
22 BuildRequires:  bison
23 BuildRequires:  flex
24 BuildRequires:  gettext-devel
25 BuildRequires:  texinfo
26 %ifarch sparc sparc32
27 BuildRequires:  sparc32
28 %endif
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         target          avr
32 %define         arch            %{_prefix}/%{target}
33
34 %description
35 Binutils is a collection of binary utilities, including:
36 - ar - create, modify and extract from archives,
37 - nm - lists symbols from object files,
38 - objcopy - copy and translate object files,
39 - objdump - display information from object files,
40 - ranlib - generate an index for the contents of an archive,
41 - size - list the section sizes of an object or archive file,
42 - strings - list printable strings from files,
43 - strip - discard symbols,
44 - c++filt - a filter for demangling encoded C++ symbols,
45 - addr2line - convert addresses to file and line,
46 - nlmconv - convert object code into an NLM.
47
48 This package contains the cross version for Atmel AVR.
49
50 %description -l pl.UTF-8
51 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
52 programów. Znajdują się tutaj między innymi assembler, konsolidator
53 (linker), a także inne narzędzia do manipulowania binarnymi plikami
54 programów i bibliotek.
55
56 Ten pakiet zawiera wersję skrośną generującą kod dla Atmel AVR.
57
58 %prep
59 %setup -q -n binutils-%{version}
60 %patch0 -p0
61 %patch1 -p0
62 %patch2 -p0
63 %patch3 -p0
64 %patch4 -p0
65
66 %build
67 cp /usr/share/automake/config.sub .
68
69 # ldscripts won't be generated properly if SHELL is not bash...
70 CFLAGS="%{rpmcflags}" \
71 LDFLAGS="%{rpmldflags}" \
72 CONFIG_SHELL="/bin/bash" \
73 %ifarch sparc
74 sparc32 \
75 %endif
76 ./configure \
77         --disable-shared \
78         --prefix=%{_prefix} \
79         --libdir=%{_libdir} \
80         --mandir=%{_mandir} \
81         --infodir=%{_infodir} \
82         --host=%{_target_platform} \
83         --build=%{_target_platform} \
84         --target=%{target}
85
86 # We have to regenerate headers after patching.
87 %{__make} configure-host \
88         tooldir=%{_prefix} \
89         EXEEXT=""
90
91 %{__make} -C bfd headers \
92         tooldir=%{_prefix} \
93         EXEEXT=""
94
95 %{__make} all \
96         tooldir=%{_prefix} \
97         EXEEXT=""
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 install -d $RPM_BUILD_ROOT%{_prefix}
102
103 %{__make} install \
104         prefix=$RPM_BUILD_ROOT%{_prefix} \
105         mandir=$RPM_BUILD_ROOT%{_mandir} \
106         infodir=$RPM_BUILD_ROOT%{_infodir} \
107         libdir=$RPM_BUILD_ROOT%{_libdir}
108
109 # remove these man pages unless we cross-build for win*/netware platforms.
110 # however, this should be done in Makefiles.
111 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
112
113 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/*.mo
114 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
115 rm -rf $RPM_BUILD_ROOT%{_infodir}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %doc README
123 %attr(755,root,root) %{_bindir}/%{target}-*
124 %dir %{arch}
125 %dir %{arch}/bin
126 %attr(755,root,root) %{arch}/bin/*
127 %dir %{arch}/lib
128 %dir %{arch}/lib/*
129 %{arch}/lib/*/*
130 %{_mandir}/man?/%{target}-*
This page took 0.065782 seconds and 4 git commands to generate.