]> git.pld-linux.org Git - packages/crossavr-binutils.git/blob - crossavr-binutils.spec
- massive attack: adding Source-md5
[packages/crossavr-binutils.git] / crossavr-binutils.spec
1 Summary:        GNU Binary Utility Development Utilities
2 Summary(de):    GNU Binary Utility Development Utilities
3 Summary(es):    Utilitarios para desarrollo de binarios de la GNU
4 Summary(fr):    Utilitaires de développement binaire de GNU
5 Summary(pl):    Narzêdzia GNU dla programistów
6 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU
7 Summary(tr):    GNU geliþtirme araçlarý
8 Name:           crossavr-binutils
9 Version:        2.13.90.0.4
10 Release:        1
11 License:        GPL
12 Group:          Development/Tools
13 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
14 # Source0-md5:  afe2cc264f9a263e93d28a279d9ebb8a
15 URL:            http://sourceware.cygnus.com/binutils/
16 Prereq:         /sbin/ldconfig
17 BuildRequires:  flex
18 BuildRequires:  bison
19 BuildRequires:  perl-devel
20 BuildRequires:  bash
21 %ifarch sparc sparc32
22 BuildRequires:  sparc32
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         target          avr
27 %define         arch            %{_prefix}/%{target}
28
29 %description
30 Binutils is a collection of binary utilities, including:
31 - ar - create, modify and extract from archives,
32 - nm - lists symbols from object files,
33 - objcopy - copy and translate object files,
34 - objdump - display information from object files,
35 - ranlib - generate an index for the contents of an archive,
36 - size - list the section sizes of an object or archive file,
37 - strings - list printable strings from files,
38 - strip - discard symbols,
39 - c++filt - a filter for demangling encoded C++ symbols,
40 - addr2line - convert addresses to file and line,
41 - nlmconv - convert object code into an NLM.
42
43 Cross version for Atmel AVR.
44
45 %description -l pl
46 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê
47 programów. Znajduj± siê tutaj miêdzy innymi assembler, konsolidator
48 (linker), a tak¿e inne narzêdzia do manipulowania binarnymi plikami
49 programów i bibliotek.
50
51 Wersja cross generuj±ca dla Atmel AVR.
52
53 %prep
54 %setup -q -n binutils-%{version}
55
56 %build
57 # ldscripts won't be generated properly if SHELL is not bash...
58 CFLAGS="%{rpmcflags}" LDFLAGS="%{rpmldflags}" \
59 CONFIG_SHELL="/bin/bash" \
60 %ifarch sparc
61 sparc32 \
62 %endif
63 ./configure \
64         --disable-shared \
65         --prefix=%{_prefix} \
66         --infodir=%{_infodir} \
67         --mandir=%{_mandir} \
68         --target=%{target}
69
70 %{__make} tooldir=%{_prefix} EXEEXT="" all
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT%{_prefix}
75
76 %{__make} install \
77         prefix=$RPM_BUILD_ROOT%{_prefix} \
78         mandir=$RPM_BUILD_ROOT%{_mandir} \
79         infodir=$RPM_BUILD_ROOT%{_infodir}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_bindir}/%{target}-*
87 %dir %{arch}/bin
88 %attr(755,root,root) %{arch}/bin/*
89 %dir %{arch}/lib
90 %dir %{arch}/lib/*
91 %{arch}/lib/*/*
92 %{_mandir}/man?/%{target}-*
This page took 0.066096 seconds and 4 git commands to generate.