]> git.pld-linux.org Git - packages/crossavr-binutils.git/blob - crossavr-binutils.spec
- fixed build for non-i686 machines
[packages/crossavr-binutils.git] / crossavr-binutils.spec
1 Summary:        Cross AVR GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - AVR binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - AVR binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla AVR - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - AVR binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - AVR binutils
7 Name:           crossavr-binutils
8 Version:        2.18.50.0.4
9 Release:        1
10 License:        GPL
11 Group:          Development/Tools
12 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
13 # Source0-md5:  163ca01262dc530f7bf8e83bc43e65ab
14 Patch0:         %{name}-aa.patch
15 Patch1:         %{name}-coff-avr.patch
16 URL:            http://sources.redhat.com/binutils/
17 BuildRequires:  automake
18 BuildRequires:  bash
19 BuildRequires:  bison
20 BuildRequires:  flex
21 BuildRequires:  gettext-devel
22 BuildRequires:  texinfo
23 %ifarch sparc sparc32
24 BuildRequires:  sparc32
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         target          avr
29 %define         arch            %{_prefix}/%{target}
30
31 %description
32 Binutils is a collection of binary utilities, including:
33 - ar - create, modify and extract from archives,
34 - nm - lists symbols from object files,
35 - objcopy - copy and translate object files,
36 - objdump - display information from object files,
37 - ranlib - generate an index for the contents of an archive,
38 - size - list the section sizes of an object or archive file,
39 - strings - list printable strings from files,
40 - strip - discard symbols,
41 - c++filt - a filter for demangling encoded C++ symbols,
42 - addr2line - convert addresses to file and line,
43 - nlmconv - convert object code into an NLM.
44
45 This package contains the cross version for Atmel AVR.
46
47 %description -l pl.UTF-8
48 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
49 programów. Znajdują się tutaj między innymi assembler, konsolidator
50 (linker), a także inne narzędzia do manipulowania binarnymi plikami
51 programów i bibliotek.
52
53 Ten pakiet zawiera wersję skrośną generującą kod dla Atmel AVR.
54
55 %prep
56 %setup -q -n binutils-%{version}
57 %patch0 -p0
58 %patch1 -p1
59
60 %build
61 cp /usr/share/automake/config.sub .
62
63 # ldscripts won't be generated properly if SHELL is not bash...
64 CFLAGS="%{rpmcflags}" \
65 LDFLAGS="%{rpmldflags}" \
66 CONFIG_SHELL="/bin/bash" \
67 %ifarch sparc
68 sparc32 \
69 %endif
70 ./configure \
71         --enable-shared \
72         --prefix=%{_prefix} \
73         --libdir=%{_libdir} \
74         --mandir=%{_mandir} \
75         --infodir=%{_infodir} \
76         --host=%{_host} \
77         --build=%{_build} \
78         --target=%{target}
79
80 %{__make} all \
81         tooldir=%{_prefix} \
82         EXEEXT=""
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT%{_prefix}
87
88 %{__make} install \
89         prefix=$RPM_BUILD_ROOT%{_prefix} \
90         mandir=$RPM_BUILD_ROOT%{_mandir} \
91         infodir=$RPM_BUILD_ROOT%{_infodir} \
92         libdir=$RPM_BUILD_ROOT%{_libdir}
93 cd bfd
94 %{__make} install_libbfd DESTDIR=$RPM_BUILD_ROOT
95 cd ..
96 cd opcodes      
97 %{__make} install_libopcodes DESTDIR=$RPM_BUILD_ROOT
98 cd ..
99
100 # remove these man pages unless we cross-build for win*/netware platforms.
101 # however, this should be done in Makefiles.
102 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
103
104 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/*.mo
105 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
106 rm -rf $RPM_BUILD_ROOT%{_infodir}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %doc README
114 %attr(755,root,root) %{_bindir}/%{target}-*
115 %dir %{arch}
116 %dir %{arch}/bin
117 %attr(755,root,root) %{arch}/bin/*
118 %dir %{arch}/lib
119 %dir %{arch}/lib/*
120 %{arch}/lib/*/*
121 %{_mandir}/man?/%{target}-*
122 %attr(755,root,root) %{_prefix}/%{_host}/avr/lib/lib*.so
This page took 0.049339 seconds and 4 git commands to generate.