]> git.pld-linux.org Git - packages/crossavr-binutils.git/blob - crossavr-binutils.spec
- 2.23.1
[packages/crossavr-binutils.git] / crossavr-binutils.spec
1 Summary:        Cross AVR GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - AVR binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - AVR binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla AVR - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - AVR binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - AVR binutils
7 Name:           crossavr-binutils
8 Version:        2.23.1
9 Release:        1
10 Epoch:          1
11 Patch0:         am.patch
12 # Patches 1xx are taken form Atmel official AVR8-GNU toolchain version 3.4.2
13 # http://distribute.atmel.no/tools/opensource/Atmel-AVR-Toolchain-3.4.2/avr/avr-patches.tar.gz
14 Patch100:       001-xmega-Makefile_am-typo.patch
15 Patch101:       002-tinycore-support.patch
16 Patch102:       003-RMW-insn-constriant.patch
17 Patch103:       004-new-part-supports.patch
18 Patch104:       005-additional-part-supports.patch
19 Patch105:       006-xmega-showuage-typo.patch
20 Patch106:       007-ata6289-architecture-correction.patch
21 Patch107:       008-add-usersig-section.patch
22 Patch108:       009-dwarf-relax-fix.patch
23 Patch109:       010-disable-demand-paging.patch
24 Patch110:       200-binutils-avr-size.patch
25 Patch111:       201-binutils-dwarf2-AVRStudio-workaround.patch
26 Patch112:       202-binutils-bug13113.patch
27 Patch113:       400-binutils-atmxt336s.patch
28 Patch114:       401-binutils-atmega48hvf.patch
29 Patch115:       402-binutils-atmega26hvg.patch
30 Patch116:       403-binutils-atmxt224_224e.patch
31 Patch117:       404-binutils-atmxt112sl.patch
32 Patch118:       405-binutils-atmxt540s.patch
33 Patch119:       406-binutils-ata5831.patch
34 Patch120:       407-binutils-attiny841.patch
35 Patch121:       408-binutils-atmegarfa2.patch
36 Patch122:       409-binutils-ata5790n.patch
37 Patch123:       410-binutils-atmega64hve2.patch
38 Patch124:       411-binutils-attiny474.patch
39 Patch125:       412-binutils-atmxts200.patch
40 Patch126:       500-binutils-avrtc530-backported.patch
41 License:        GPL
42 Group:          Development/Tools
43 Source0:        ftp://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.bz2
44 # Source0-md5:  33adb18c3048d057ac58d07a3f1adb38
45 URL:            http://sources.redhat.com/binutils/
46 BuildRequires:  automake
47 BuildRequires:  bash
48 BuildRequires:  bison
49 BuildRequires:  flex
50 BuildRequires:  gettext-devel
51 BuildRequires:  gcc-c++
52 BuildRequires:  perl-tools-pod
53 BuildRequires:  texinfo
54 %ifarch sparc sparc32
55 BuildRequires:  sparc32
56 %endif
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         target          avr
60 %define         arch            %{_prefix}/%{target}
61
62 %description
63 Binutils is a collection of binary utilities, including:
64 - ar - create, modify and extract from archives,
65 - nm - lists symbols from object files,
66 - objcopy - copy and translate object files,
67 - objdump - display information from object files,
68 - ranlib - generate an index for the contents of an archive,
69 - size - list the section sizes of an object or archive file,
70 - strings - list printable strings from files,
71 - strip - discard symbols,
72 - c++filt - a filter for demangling encoded C++ symbols,
73 - addr2line - convert addresses to file and line,
74 - nlmconv - convert object code into an NLM.
75
76 This package contains the cross version for Atmel AVR.
77
78 %description -l pl.UTF-8
79 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
80 programów. Znajdują się tutaj między innymi assembler, konsolidator
81 (linker), a także inne narzędzia do manipulowania binarnymi plikami
82 programów i bibliotek.
83
84 Ten pakiet zawiera wersję skrośną generującą kod dla Atmel AVR.
85
86 %prep
87 %setup -q -n binutils-%{version}
88 %patch0 -p1
89 %patch100 -p0
90 %patch101 -p0
91 %patch102 -p0
92 %patch103 -p0
93 %patch104 -p0
94 %patch105 -p0
95 %patch106 -p0
96 %patch107 -p0
97 %patch108 -p0
98 %patch109 -p0
99 %patch110 -p0
100 %patch111 -p0
101 %patch112 -p0
102 %patch113 -p0
103 %patch114 -p0
104 %patch115 -p0
105 %patch116 -p0
106 %patch117 -p0
107 %patch118 -p0
108 %patch119 -p0
109 %patch120 -p0
110 %patch121 -p0
111 %patch122 -p0
112 %patch123 -p0
113 %patch124 -p0
114 %patch125 -p0
115 %patch126 -p0
116
117 # Remove hacks for specific autoconf version.
118 echo > config/override.m4
119
120 %build
121 %{__aclocal}
122 %{__autoconf}
123 for subdir in bfd binutils ld; do
124         cd $subdir
125         %{__aclocal} -I.. -I../bfd -I../config
126         %{__automake}
127         %{__autoconf}
128         cd -
129 done
130
131 # ldscripts won't be generated properly if SHELL is not bash...
132 CFLAGS="%{rpmcflags}" \
133 LDFLAGS="%{rpmldflags}" \
134 CONFIG_SHELL="/bin/bash" \
135 %ifarch sparc
136 sparc32 \
137 %endif
138 ./configure \
139         --enable-gold \
140         --disable-shared \
141         --disable-werror \
142         --prefix=%{_prefix} \
143         --libdir=%{_libdir} \
144         --mandir=%{_mandir} \
145         --infodir=%{_infodir} \
146         --host=%{_target_platform} \
147         --build=%{_target_platform} \
148         --target=%{target}
149
150 # We have to regenerate headers after patching.
151 %{__make} configure-host \
152         tooldir=%{_prefix} \
153         EXEEXT=""
154
155 %{__make} -C bfd headers \
156         tooldir=%{_prefix} \
157         EXEEXT=""
158
159 %{__make} all \
160         tooldir=%{_prefix} \
161         EXEEXT=""
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165 install -d $RPM_BUILD_ROOT%{_prefix}
166
167 %{__make} install \
168         prefix=$RPM_BUILD_ROOT%{_prefix} \
169         mandir=$RPM_BUILD_ROOT%{_mandir} \
170         infodir=$RPM_BUILD_ROOT%{_infodir} \
171         libdir=$RPM_BUILD_ROOT%{_libdir}
172
173 # remove these man pages unless we cross-build for win*/netware platforms.
174 # however, this should be done in Makefiles.
175 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
176
177 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/*.mo
178 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
179 rm -rf $RPM_BUILD_ROOT%{_infodir}
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %files
185 %defattr(644,root,root,755)
186 %doc README
187 %attr(755,root,root) %{_bindir}/%{target}-*
188 %dir %{arch}
189 %dir %{arch}/bin
190 %attr(755,root,root) %{arch}/bin/*
191 %dir %{arch}/lib
192 %dir %{arch}/lib/*
193 %{arch}/lib/*/*
194 %{_mandir}/man?/%{target}-*
This page took 0.077203 seconds and 4 git commands to generate.