]> git.pld-linux.org Git - packages/crossavr-binutils.git/blob - crossavr-binutils.spec
- updated to 2.17.50.0.14
[packages/crossavr-binutils.git] / crossavr-binutils.spec
1 Summary:        Cross AVR GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - AVR binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - AVR binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla AVR - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - AVR binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - AVR binutils
7 Name:           crossavr-binutils
8 Version:        2.17.50.0.14
9 Release:        1
10 License:        GPL
11 Group:          Development/Tools
12 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
13 # Source0-md5:  4ddab973ad9c5169d8f8296bdf67b3f7
14 Patch0:         %{name}-aa.patch
15 Patch1:         %{name}-coff-avr.patch
16 Patch2:         %{name}-newdevices.patch
17 URL:            http://sources.redhat.com/binutils/
18 BuildRequires:  automake
19 BuildRequires:  bash
20 BuildRequires:  bison
21 BuildRequires:  flex
22 BuildRequires:  gettext-devel
23 %ifarch sparc sparc32
24 BuildRequires:  sparc32
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         target          avr
29 %define         arch            %{_prefix}/%{target}
30
31 %description
32 Binutils is a collection of binary utilities, including:
33 - ar - create, modify and extract from archives,
34 - nm - lists symbols from object files,
35 - objcopy - copy and translate object files,
36 - objdump - display information from object files,
37 - ranlib - generate an index for the contents of an archive,
38 - size - list the section sizes of an object or archive file,
39 - strings - list printable strings from files,
40 - strip - discard symbols,
41 - c++filt - a filter for demangling encoded C++ symbols,
42 - addr2line - convert addresses to file and line,
43 - nlmconv - convert object code into an NLM.
44
45 This package contains the cross version for Atmel AVR.
46
47 %description -l pl.UTF-8
48 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
49 programów. Znajdują się tutaj między innymi assembler, konsolidator
50 (linker), a także inne narzędzia do manipulowania binarnymi plikami
51 programów i bibliotek.
52
53 Ten pakiet zawiera wersję skrośną generującą kod dla Atmel AVR.
54
55 %prep
56 %setup -q -n binutils-%{version}
57 %patch0 -p0
58 %patch1 -p0
59 %patch2 -p1
60
61 %build
62 cp /usr/share/automake/config.sub .
63
64 # ldscripts won't be generated properly if SHELL is not bash...
65 CFLAGS="%{rpmcflags}" \
66 LDFLAGS="%{rpmldflags}" \
67 CONFIG_SHELL="/bin/bash" \
68 %ifarch sparc
69 sparc32 \
70 %endif
71 ./configure \
72         --disable-shared \
73         --prefix=%{_prefix} \
74         --libdir=%{_libdir} \
75         --mandir=%{_mandir} \
76         --infodir=%{_infodir} \
77         --target=%{target}
78
79 %{__make} all \
80         tooldir=%{_prefix} \
81         EXEEXT=""
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT%{_prefix}
86
87 %{__make} install \
88         prefix=$RPM_BUILD_ROOT%{_prefix} \
89         mandir=$RPM_BUILD_ROOT%{_mandir} \
90         infodir=$RPM_BUILD_ROOT%{_infodir} \
91         libdir=$RPM_BUILD_ROOT%{_libdir}
92
93 # remove these man pages unless we cross-build for win*/netware platforms.
94 # however, this should be done in Makefiles.
95 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
96
97 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/*.mo
98 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
99 rm -rf $RPM_BUILD_ROOT%{_infodir}
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files
105 %defattr(644,root,root,755)
106 %doc README
107 %attr(755,root,root) %{_bindir}/%{target}-*
108 %dir %{arch}
109 %dir %{arch}/bin
110 %attr(755,root,root) %{arch}/bin/*
111 %dir %{arch}/lib
112 %dir %{arch}/lib/*
113 %{arch}/lib/*/*
114 %{_mandir}/man?/%{target}-*
This page took 0.092822 seconds and 4 git commands to generate.