]> git.pld-linux.org Git - packages/crossavr-binutils.git/blob - crossavr-binutils.spec
- sync summaries / descriptions; some BR fixed
[packages/crossavr-binutils.git] / crossavr-binutils.spec
1 Summary:        Cross AVR GNU binary utility development utilities - binutils
2 Summary(es):    Utilitarios para desarrollo de binarios de la GNU - AVR binutils
3 Summary(fr):    Utilitaires de développement binaire de GNU - AVR binutils
4 Summary(pl):    Skro¶ne narzêdzia programistyczne GNU dla AVR - binutils
5 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - AVR binutils
6 Summary(tr):    GNU geliþtirme araçlarý - AVR binutils
7 Name:           crossavr-binutils
8 Version:        2.13.90.0.4
9 Release:        1
10 License:        GPL
11 Group:          Development/Tools
12 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
13 # Source0-md5:  afe2cc264f9a263e93d28a279d9ebb8a
14 URL:            http://sourceware.cygnus.com/binutils/
15 Prereq:         /sbin/ldconfig
16 BuildRequires:  flex
17 BuildRequires:  bison
18 BuildRequires:  perl-devel
19 BuildRequires:  bash
20 %ifarch sparc sparc32
21 BuildRequires:  sparc32
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         target          avr
26 %define         arch            %{_prefix}/%{target}
27
28 %description
29 Binutils is a collection of binary utilities, including:
30 - ar - create, modify and extract from archives,
31 - nm - lists symbols from object files,
32 - objcopy - copy and translate object files,
33 - objdump - display information from object files,
34 - ranlib - generate an index for the contents of an archive,
35 - size - list the section sizes of an object or archive file,
36 - strings - list printable strings from files,
37 - strip - discard symbols,
38 - c++filt - a filter for demangling encoded C++ symbols,
39 - addr2line - convert addresses to file and line,
40 - nlmconv - convert object code into an NLM.
41
42 This package contains the cross version for Atmel AVR.
43
44 %description -l pl
45 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê
46 programów. Znajduj± siê tutaj miêdzy innymi assembler, konsolidator
47 (linker), a tak¿e inne narzêdzia do manipulowania binarnymi plikami
48 programów i bibliotek.
49
50 Ten pakiet zawiera wersjê skro¶n± generuj±c± kod dla Atmel AVR.
51
52 %prep
53 %setup -q -n binutils-%{version}
54
55 %build
56 # ldscripts won't be generated properly if SHELL is not bash...
57 CFLAGS="%{rpmcflags}" LDFLAGS="%{rpmldflags}" \
58 CONFIG_SHELL="/bin/bash" \
59 %ifarch sparc
60 sparc32 \
61 %endif
62 ./configure \
63         --disable-shared \
64         --prefix=%{_prefix} \
65         --infodir=%{_infodir} \
66         --mandir=%{_mandir} \
67         --target=%{target}
68
69 %{__make} tooldir=%{_prefix} EXEEXT="" all
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT%{_prefix}
74
75 %{__make} install \
76         prefix=$RPM_BUILD_ROOT%{_prefix} \
77         mandir=$RPM_BUILD_ROOT%{_mandir} \
78         infodir=$RPM_BUILD_ROOT%{_infodir}
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %attr(755,root,root) %{_bindir}/%{target}-*
86 %dir %{arch}/bin
87 %attr(755,root,root) %{arch}/bin/*
88 %dir %{arch}/lib
89 %dir %{arch}/lib/*
90 %{arch}/lib/*/*
91 %{_mandir}/man?/%{target}-*
This page took 0.074204 seconds and 4 git commands to generate.