]> git.pld-linux.org Git - packages/crossavr-binutils.git/blob - crossavr-binutils.spec
- updated to 2.17.50.0.18
[packages/crossavr-binutils.git] / crossavr-binutils.spec
1 Summary:        Cross AVR GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - AVR binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - AVR binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla AVR - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - AVR binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - AVR binutils
7 Name:           crossavr-binutils
8 Version:        2.17.50.0.18
9 Release:        1
10 License:        GPL
11 Group:          Development/Tools
12 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
13 # Source0-md5:  98e21a7c0d82b318fe29f2e04d273344
14 Patch0:         %{name}-aa.patch
15 Patch1:         %{name}-coff-avr.patch
16 URL:            http://sources.redhat.com/binutils/
17 BuildRequires:  automake
18 BuildRequires:  bash
19 BuildRequires:  bison
20 BuildRequires:  flex
21 BuildRequires:  gettext-devel
22 BuildRequires:  texinfo
23 %ifarch sparc sparc32
24 BuildRequires:  sparc32
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         target          avr
29 %define         arch            %{_prefix}/%{target}
30
31 %description
32 Binutils is a collection of binary utilities, including:
33 - ar - create, modify and extract from archives,
34 - nm - lists symbols from object files,
35 - objcopy - copy and translate object files,
36 - objdump - display information from object files,
37 - ranlib - generate an index for the contents of an archive,
38 - size - list the section sizes of an object or archive file,
39 - strings - list printable strings from files,
40 - strip - discard symbols,
41 - c++filt - a filter for demangling encoded C++ symbols,
42 - addr2line - convert addresses to file and line,
43 - nlmconv - convert object code into an NLM.
44
45 This package contains the cross version for Atmel AVR.
46
47 %description -l pl.UTF-8
48 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
49 programów. Znajdują się tutaj między innymi assembler, konsolidator
50 (linker), a także inne narzędzia do manipulowania binarnymi plikami
51 programów i bibliotek.
52
53 Ten pakiet zawiera wersję skrośną generującą kod dla Atmel AVR.
54
55 %prep
56 %setup -q -n binutils-%{version}
57 %patch0 -p0
58 %patch1 -p1
59
60 %build
61 cp /usr/share/automake/config.sub .
62
63 # ldscripts won't be generated properly if SHELL is not bash...
64 CFLAGS="%{rpmcflags}" \
65 LDFLAGS="%{rpmldflags}" \
66 CONFIG_SHELL="/bin/bash" \
67 %ifarch sparc
68 sparc32 \
69 %endif
70 ./configure \
71         --enable-shared \
72         --prefix=%{_prefix} \
73         --libdir=%{_libdir} \
74         --mandir=%{_mandir} \
75         --infodir=%{_infodir} \
76         --target=%{target}
77
78 %{__make} all \
79         tooldir=%{_prefix} \
80         EXEEXT=""
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{_prefix}
85
86 %{__make} install \
87         prefix=$RPM_BUILD_ROOT%{_prefix} \
88         mandir=$RPM_BUILD_ROOT%{_mandir} \
89         infodir=$RPM_BUILD_ROOT%{_infodir} \
90         libdir=$RPM_BUILD_ROOT%{_libdir}
91 cd bfd
92 %{__make} install_libbfd DESTDIR=$RPM_BUILD_ROOT
93 cd ..
94 cd opcodes      
95 %{__make} install_libopcodes DESTDIR=$RPM_BUILD_ROOT
96 cd ..
97
98 # remove these man pages unless we cross-build for win*/netware platforms.
99 # however, this should be done in Makefiles.
100 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
101
102 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/*.mo
103 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
104 rm -rf $RPM_BUILD_ROOT%{_infodir}
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 %doc README
112 %attr(755,root,root) %{_bindir}/%{target}-*
113 %dir %{arch}
114 %dir %{arch}/bin
115 %attr(755,root,root) %{arch}/bin/*
116 %dir %{arch}/lib
117 %dir %{arch}/lib/*
118 %{arch}/lib/*/*
119 %{_mandir}/man?/%{target}-*
120 %attr(755,root,root) %{_prefix}/i686-pc-linux-gnu/avr/lib/lib*.so
This page took 0.048374 seconds and 4 git commands to generate.