]> git.pld-linux.org Git - packages/crossavr-binutils.git/blob - crossavr-binutils.spec
cd87ccc748ea3f6af6ed7c631b263d36f7e83b45
[packages/crossavr-binutils.git] / crossavr-binutils.spec
1 Summary:        Cross AVR GNU binary utility development utilities - binutils
2 Summary(es):    Utilitarios para desarrollo de binarios de la GNU - AVR binutils
3 Summary(fr):    Utilitaires de développement binaire de GNU - AVR binutils
4 Summary(pl):    Skro¶ne narzêdzia programistyczne GNU dla AVR - binutils
5 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - AVR binutils
6 Summary(tr):    GNU geliþtirme araçlarý - AVR binutils
7 Name:           crossavr-binutils
8 Version:        2.15.91.0.1
9 Release:        1
10 License:        GPL
11 Group:          Development/Tools
12 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
13 # Source0-md5:  0d64d65d33a7f305e5ef8351086b9a3a
14 URL:            http://sources.redhat.com/binutils/
15 BuildRequires:  automake
16 BuildRequires:  bash
17 BuildRequires:  bison
18 BuildRequires:  flex
19 BuildRequires:  gettext-devel
20 %ifarch sparc sparc32
21 BuildRequires:  sparc32
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         target          avr
26 %define         arch            %{_prefix}/%{target}
27
28 %description
29 Binutils is a collection of binary utilities, including:
30 - ar - create, modify and extract from archives,
31 - nm - lists symbols from object files,
32 - objcopy - copy and translate object files,
33 - objdump - display information from object files,
34 - ranlib - generate an index for the contents of an archive,
35 - size - list the section sizes of an object or archive file,
36 - strings - list printable strings from files,
37 - strip - discard symbols,
38 - c++filt - a filter for demangling encoded C++ symbols,
39 - addr2line - convert addresses to file and line,
40 - nlmconv - convert object code into an NLM.
41
42 This package contains the cross version for Atmel AVR.
43
44 %description -l pl
45 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê
46 programów. Znajduj± siê tutaj miêdzy innymi assembler, konsolidator
47 (linker), a tak¿e inne narzêdzia do manipulowania binarnymi plikami
48 programów i bibliotek.
49
50 Ten pakiet zawiera wersjê skro¶n± generuj±c± kod dla Atmel AVR.
51
52 %prep
53 %setup -q -n binutils-%{version}
54
55 %build
56 cp /usr/share/automake/config.sub .
57
58 # ldscripts won't be generated properly if SHELL is not bash...
59 CFLAGS="%{rpmcflags}" \
60 LDFLAGS="%{rpmldflags}" \
61 CONFIG_SHELL="/bin/bash" \
62 %ifarch sparc
63 sparc32 \
64 %endif
65 ./configure \
66         --disable-shared \
67         --prefix=%{_prefix} \
68         --libdir=%{_libdir} \
69         --mandir=%{_mandir} \
70         --infodir=%{_infodir} \
71         --target=%{target}
72
73 %{__make} all \
74         tooldir=%{_prefix} \
75         EXEEXT=""
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT%{_prefix}
80
81 %{__make} install \
82         prefix=$RPM_BUILD_ROOT%{_prefix} \
83         mandir=$RPM_BUILD_ROOT%{_mandir} \
84         infodir=$RPM_BUILD_ROOT%{_infodir} \
85         libdir=$RPM_BUILD_ROOT%{_libdir}
86
87 # remove these man pages unless we cross-build for win*/netware platforms.
88 # however, this should be done in Makefiles.
89 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %attr(755,root,root) %{_bindir}/%{target}-*
97 %dir %{arch}/bin
98 %attr(755,root,root) %{arch}/bin/*
99 %dir %{arch}/lib
100 %dir %{arch}/lib/*
101 %{arch}/lib/*/*
102 %{_mandir}/man?/%{target}-*
This page took 0.083136 seconds and 2 git commands to generate.