]> git.pld-linux.org Git - packages/crossarmdarwin-binutils.git/blob - crossarmdarwin-binutils.spec
- test x86_64
[packages/crossarmdarwin-binutils.git] / crossarmdarwin-binutils.spec
1 # DOCS
2 # - http://aakash-bapna.blogspot.com/2007/10/iphone-non-official-sdk-aka-toolchain.html
3 # - http://code.google.com/p/iphone-dev/wiki/Building
4 #  - ...
5 #  - csu (crt1.o, dylib1.o, and bundle1.o) + bootstrap
6 #  - ...
7 # TO MAKE TARBALL(s):
8 # svn co http://iphone-dev.googlecode.com/svn/trunk/odcctools odcctools
9 # tar --exclude=.svn -cjf odcctools-r280.tar.bz2 odcctools
10 # TODO
11 # - name of this cross platform? crossarm-darwin? crossarm-darwin9?
12 # - not built from binutils source, should we name package differently?
13 # - On 64-bit architectures there are currently compilation and linking problems with structs; as a workaround, try the following:
14 # - export CFLAGS="-m32"; export LDFLAGS="-m32"
15 Summary:        Cross ARM Apple Darwin development utilities - binutils
16 Name:           crossarmdarwin-binutils
17 Version:        0.152
18 Release:        0.1
19 License:        GPL v2
20 Group:          Development/Tools
21 Source0:        odcctools-r280.tar.bz2
22 # Source0-md5:  8a49b63a883219705de5b4a95265ffca
23 URL:            http://developer.berlios.de/projects/iphone-binutils/
24 BuildRequires:  bison
25 BuildRequires:  flex
26 %ifarch %{x8664}
27 # SILLY! there should had been %{target_base_arch} if any at all
28 BuildRequires:  glibc-devel(athlon)
29 %endif
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         target          arm-apple-darwin
33 %define         arch            %{_prefix}/%{target}
34
35 %description
36 Binutils is a collection of binary utilities, including:
37 - ar - create, modify and extract from archives,
38 - nm - lists symbols from object files,
39 - objcopy - copy and translate object files,
40 - objdump - display information from object files,
41 - ranlib - generate an index for the contents of an archive,
42 - size - list the section sizes of an object or archive file,
43 - strings - list printable strings from files,
44 - strip - discard symbols,
45 - c++filt - a filter for demangling encoded C++ symbols,
46 - addr2line - convert addresses to file and line,
47 - nlmconv - convert object code into an NLM.
48
49 This is a toolchain to produce arm/Mach-O binaries.
50
51 %description -l pl.UTF-8
52 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
53 programów. Znajdują się tutaj między innymi assembler, konsolidator
54 (linker), a także inne narzędzia do manipulowania binarnymi plikami
55 programów i bibliotek.
56
57 %prep
58 %setup -qcT -a0
59
60 %build
61 install -d build/odcctools
62 cd build/odcctools
63 ../../odcctools/%configure \
64 %ifarch %{x8664}
65         CFLAGS="%{rpmcflags} -m32" \
66         LDFLAGS="%{rpmldflags} -m32" \
67 %endif
68         --prefix=%{arch} \
69         --libexecdir=%{arch} \
70         --target=%{target} \
71         --disable-ld64
72 %{__make}
73 cd -
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT%{_prefix}
78
79 %{__make} -C build/odcctools install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 # prefix manpages
83 for a in $RPM_BUILD_ROOT%{_mandir}/man?/*; do
84         n=${a##*/} s=${a##*.} d=${a%/*}
85         mv $a $d/%{target}-$n.$s
86 done
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %attr(755,root,root) %{_bindir}/%{target}-*
94 %dir %{arch}
95 %dir %{arch}/as
96 %dir %{arch}/as/*
97 %attr(755,root,root) %{arch}/as/*/as
98
99 %{_mandir}/man?/%{target}-*
100 %dir %{_includedir}/mach-o
101 %{_includedir}/mach-o/arch.h
102 %{_includedir}/mach-o/fat.h
103 %{_includedir}/mach-o/loader.h
104 %{_includedir}/mach-o/machine.h
105 %{_libdir}/libmacho.a
This page took 0.059161 seconds and 3 git commands to generate.