]> git.pld-linux.org Git - packages/crossarm-binutils.git/blob - crossarm-binutils.spec
- updated to 2.16.90.0.3.
[packages/crossarm-binutils.git] / crossarm-binutils.spec
1 #
2 # Conditional build:
3 %bcond_with     eabi            # build with Embedded ABI support
4 #
5 Summary:        Cross ARM GNU binary utility development utilities - binutils
6 Summary(es):    Utilitarios para desarrollo de binarios de la GNU - ARM binutils
7 Summary(fr):    Utilitaires de développement binaire de GNU - ARM binutils
8 Summary(pl):    Skro¶ne narzêdzia programistyczne GNU dla ARM - binutils
9 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - ARM binutils
10 Summary(tr):    GNU geliþtirme araçlarý - ARM binutils
11 Name:           crossarm-binutils
12 Version:        2.16.90.0.3
13 Release:        1%{?with_eabi:eabi}
14 License:        GPL
15 Group:          Development/Tools
16 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
17 # Source0-md5:  46637559faa3157b189e0835a9bed08b
18 URL:            http://sources.redhat.com/binutils/
19 BuildRequires:  automake
20 BuildRequires:  bash
21 BuildRequires:  bison
22 BuildRequires:  flex
23 %{?with_eabi:Provides:  crossarm-binutils(eabi)}
24 ExcludeArch:    arm
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         target          arm-linux%{?with_eabi:-eabi}
28 %define         arch            %{_prefix}/%{target}
29
30 %description
31 Binutils is a collection of binary utilities, including:
32 - ar - create, modify and extract from archives,
33 - nm - lists symbols from object files,
34 - objcopy - copy and translate object files,
35 - objdump - display information from object files,
36 - ranlib - generate an index for the contents of an archive,
37 - size - list the section sizes of an object or archive file,
38 - strings - list printable strings from files,
39 - strip - discard symbols,
40 - c++filt - a filter for demangling encoded C++ symbols,
41 - addr2line - convert addresses to file and line,
42 - nlmconv - convert object code into an NLM.
43
44 This package contains the cross version for ARM.
45
46 %description -l pl
47 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê
48 programów. Znajduj± siê tutaj miêdzy innymi assembler, konsolidator
49 (linker), a tak¿e inne narzêdzia do manipulowania binarnymi plikami
50 programów i bibliotek.
51
52 Ten pakiet zawiera wersjê skro¶n± generuj±c± kod dla ARM.
53
54 %prep
55 %setup -q -n binutils-%{version}
56
57 %build
58 cp -f /usr/share/automake/config.sub .
59
60 # ldscripts won't be generated properly if SHELL is not bash...
61 CFLAGS="%{rpmcflags}" \
62 LDFLAGS="%{rpmldflags}" \
63 CONFIG_SHELL="/bin/bash" \
64 ./configure \
65         --disable-shared \
66         --disable-nls \
67         --prefix=%{_prefix} \
68         --libdir=%{_libdir} \
69         --mandir=%{_mandir} \
70         --infodir=%{_infodir} \
71         --target=%{target}
72
73 %{__make} all \
74         tooldir=%{_prefix} \
75         EXEEXT=""
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT%{_prefix}
80
81 %{__make} install \
82         prefix=$RPM_BUILD_ROOT%{_prefix} \
83         mandir=$RPM_BUILD_ROOT%{_mandir} \
84         infodir=$RPM_BUILD_ROOT%{_infodir} \
85         libdir=$RPM_BUILD_ROOT%{_libdir}
86
87 # remove these man pages unless we cross-build for win*/netware platforms.
88 # however, this should be done in Makefiles.
89 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %doc README
97 %attr(755,root,root) %{_bindir}/%{target}-*
98 %dir %{arch}
99 %dir %{arch}/bin
100 %attr(755,root,root) %{arch}/bin/*
101 %dir %{arch}/lib
102 %dir %{arch}/lib/*
103 %{arch}/lib/ldscripts/*
104 %{_mandir}/man?/%{target}-*
This page took 0.089185 seconds and 3 git commands to generate.