]> git.pld-linux.org Git - packages/crossarm-binutils.git/blob - crossarm-binutils.spec
- from binutils list
[packages/crossarm-binutils.git] / crossarm-binutils.spec
1 #
2 # Conditional build:
3 %bcond_with     eabi            # build with Embedded ABI support
4 #
5 Summary:        Cross ARM GNU binary utility development utilities - binutils
6 Summary(es):    Utilitarios para desarrollo de binarios de la GNU - ARM binutils
7 Summary(fr):    Utilitaires de développement binaire de GNU - ARM binutils
8 Summary(pl):    Skro¶ne narzêdzia programistyczne GNU dla ARM - binutils
9 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - ARM binutils
10 Summary(tr):    GNU geliþtirme araçlarý - ARM binutils
11 Name:           crossarm-binutils
12 Version:        2.15.94.0.2.2
13 Release:        1%{?with_eabi:eabi}
14 License:        GPL
15 Group:          Development/Tools
16 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
17 # Source0-md5:  e9bcf84d9e6b5a2d840e76f22a3fce5f
18 URL:            http://sources.redhat.com/binutils/
19 BuildRequires:  automake
20 BuildRequires:  bash
21 BuildRequires:  bison
22 BuildRequires:  flex
23 BuildRequires:  gettext-devel
24 %{?with_eabi:Provides:  crossarm-binutils(eabi)}
25 ExcludeArch:    arm
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         target          arm-linux%{?with_eabi:-eabi}
29 %define         arch            %{_prefix}/%{target}
30
31 %description
32 Binutils is a collection of binary utilities, including:
33 - ar - create, modify and extract from archives,
34 - nm - lists symbols from object files,
35 - objcopy - copy and translate object files,
36 - objdump - display information from object files,
37 - ranlib - generate an index for the contents of an archive,
38 - size - list the section sizes of an object or archive file,
39 - strings - list printable strings from files,
40 - strip - discard symbols,
41 - c++filt - a filter for demangling encoded C++ symbols,
42 - addr2line - convert addresses to file and line,
43 - nlmconv - convert object code into an NLM.
44
45 This package contains the cross version for ARM.
46
47 %description -l pl
48 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê
49 programów. Znajduj± siê tutaj miêdzy innymi assembler, konsolidator
50 (linker), a tak¿e inne narzêdzia do manipulowania binarnymi plikami
51 programów i bibliotek.
52
53 Ten pakiet zawiera wersjê skro¶n± generuj±c± kod dla ARM.
54
55 %prep
56 %setup -q -n binutils-%{version}
57
58 %build
59 cp -f /usr/share/automake/config.sub .
60
61 # ldscripts won't be generated properly if SHELL is not bash...
62 CFLAGS="%{rpmcflags}" \
63 LDFLAGS="%{rpmldflags}" \
64 CONFIG_SHELL="/bin/bash" \
65 ./configure \
66         --disable-shared \
67         --prefix=%{_prefix} \
68         --libdir=%{_libdir} \
69         --mandir=%{_mandir} \
70         --infodir=%{_infodir} \
71         --enable-64-bit-bfd \
72         --target=%{target}
73
74 %{__make} all \
75         tooldir=%{_prefix} \
76         EXEEXT=""
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT%{_prefix}
81
82 %{__make} install \
83         prefix=$RPM_BUILD_ROOT%{_prefix} \
84         mandir=$RPM_BUILD_ROOT%{_mandir} \
85         infodir=$RPM_BUILD_ROOT%{_infodir} \
86         libdir=$RPM_BUILD_ROOT%{_libdir}
87
88 # remove these man pages unless we cross-build for win*/netware platforms.
89 # however, this should be done in Makefiles.
90 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc README
98 %attr(755,root,root) %{_bindir}/%{target}-*
99 %dir %{arch}
100 %dir %{arch}/bin
101 %attr(755,root,root) %{arch}/bin/*
102 %dir %{arch}/lib
103 %dir %{arch}/lib/*
104 %{arch}/lib/ldscripts/*
105 %{_mandir}/man?/%{target}-*
This page took 0.852023 seconds and 3 git commands to generate.