]> git.pld-linux.org Git - packages/cronie.git/blobdiff - cronie.spec
- Titanium will not support upstart
[packages/cronie.git] / cronie.spec
index 485a77074f601377c3af3adc056af09c04aa5563..9bcaf311841555e5fd662424f0ec2d1752baa850 100644 (file)
@@ -1,6 +1,8 @@
 # TODO
 # - update paths in manuals (create .in files and send upstream)
 # - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
+# - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
+#   Mar  3 09:30:01 ravenous CROND[2528]: 4ΓΏ
 #
 # Conditional build:
 %bcond_without inotify         # without inotify support
 
 Summary:       Cron daemon for executing programs at set times
 Name:          cronie
-Version:       1.4.4
+Version:       1.4.6
 Release:       3
 License:       MIT and BSD and GPL v2
 Group:         Daemons
 Source0:       https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
-# Source0-md5: eb9834c5f87cca9efeed68e6fed3fe3d
+# Source0-md5: 968e3d3e7c8e1d0588d533883482d3fa
 Source1:       %{name}.init
 Source2:       cron.logrotate
 Source3:       cron.sysconfig
 Source4:       %{name}.crontab
 Source5:       %{name}.pam
+Source6:       %{name}.upstart
 Patch0:                inotify-nosys.patch
 Patch1:                %{name}-nosyscrontab.patch
 Patch2:                sendmail-path.patch
@@ -35,7 +38,7 @@ BuildRequires:        automake
 %{?with_selinux:BuildRequires: libselinux-devel}
 BuildRequires: pam-devel
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: rpmbuild(macros) >= 1.561
 Requires(post):        fileutils
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
@@ -44,7 +47,7 @@ Requires(pre):        /usr/sbin/groupadd
 Requires:      /bin/run-parts
 Requires:      /sbin/chkconfig
 Requires:      psmisc >= 20.1
-Requires:      rc-scripts >= 0.4.0.19
+Requires:      rc-scripts >= 0.4.3.0
 %{?with_inotify:Requires:      uname(release) >= 2.6.13}
 Provides:      crondaemon
 Provides:      crontabs = 1.7
@@ -76,6 +79,19 @@ Anacron becames part of cronie. Anacron is used only for running
 regular jobs. The default settings execute regular jobs by anacron,
 however this could be overloaded in settings.
 
+%package upstart
+Summary:       Upstart job description for Cronie
+Summary(pl.UTF-8):     Opis zadania Upstart dla Cronie
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+Requires:      upstart >= 0.6
+
+%description upstart
+Upstart job description for Cronie.
+
+%description upstart -l pl.UTF-8
+Opis zadania Upstart dla Cronie.
+
 %prep
 %setup -q
 %patch0 -p1
@@ -102,7 +118,7 @@ however this could be overloaded in settings.
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir}} \
-       $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
+       $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
 
 %{__make} install \
@@ -115,6 +131,7 @@ cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
+cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
 
 touch $RPM_BUILD_ROOT/var/log/cron
 
@@ -137,10 +154,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %post
 if [ ! -f /var/log/cron ]; then
-       umask 027
-       touch /var/log/cron
-       chgrp crontab /var/log/cron
-       chmod 660 /var/log/cron
+       install -m 660 -g crontab /dev/null /var/log/cron
 fi
 /sbin/chkconfig --add crond
 %service crond restart "Cron Daemon"
@@ -156,6 +170,13 @@ if [ "$1" = "0" ]; then
        %groupremove crontab
 fi
 
+%triggerin -- pam
+# restart crond if pam is upgraded
+# (crond is linked with old libpam but tries to open modules linked with new libpam)
+if [ "$2" != 1 ]; then
+       %service -q crond restart
+fi
+
 %triggerun -- hc-cron,fcron,vixie-cron
 # Prevent preun from crond from working
 chmod a-x /etc/rc.d/init.d/crond
@@ -167,6 +188,12 @@ chmod 754 /etc/rc.d/init.d/crond
 /sbin/chkconfig --del crond
 /sbin/chkconfig --add crond
 
+%post upstart
+%upstart_post crond
+
+%postun upstart
+%upstart_postun crond
+
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog README
@@ -197,3 +224,9 @@ chmod 754 /etc/rc.d/init.d/crond
 %{_mandir}/man8/anacron.8*
 
 %attr(1730,root,crontab) /var/spool/anacron
+
+%if "%{pld_release}" != "ti"
+%files upstart
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
+%endif
This page took 0.075233 seconds and 4 git commands to generate.