]> git.pld-linux.org Git - packages/cronie.git/blobdiff - cronie.spec
- few todo
[packages/cronie.git] / cronie.spec
index f9a7e4068ec39287a79884bcb55512f58c14d70a..4b96cfded189f1d9a36619ff7a82cf2f1f0cb99e 100644 (file)
@@ -1,11 +1,21 @@
+# TODO
+# - update paths in manuals (create .in files and send upstream)
+# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
 #
 # Conditional build:
 #
 # Conditional build:
+%bcond_without inotify         # without inotify support
+%if "%{pld_release}" == "ac"
+%bcond_with            selinux         # without SELinux support
+%bcond_with            audit           # without audit support
+%else
 %bcond_without selinux         # without SELinux support
 %bcond_without selinux         # without SELinux support
-#
+%bcond_without audit           # without audit support
+%endif
+
 Summary:       Cron daemon for executing programs at set times
 Name:          cronie
 Version:       1.4.1
 Summary:       Cron daemon for executing programs at set times
 Name:          cronie
 Version:       1.4.1
-Release:       2
+Release:       3
 License:       MIT and BSD and GPLv2
 Group:         Daemons
 Source0:       %{name}-%{version}.tar.gz
 License:       MIT and BSD and GPLv2
 Group:         Daemons
 Source0:       %{name}-%{version}.tar.gz
@@ -15,10 +25,14 @@ Source2:    cron.logrotate
 Source3:       cron.sysconfig
 Source4:       %{name}.crontab
 Source5:       %{name}.pam
 Source3:       cron.sysconfig
 Source4:       %{name}.crontab
 Source5:       %{name}.pam
+Patch0:                inotify-nosys.patch
 URL:           https://fedorahosted.org/cronie/
 URL:           https://fedorahosted.org/cronie/
-BuildRequires: audit-libs-devel
+%{?with_audit:BuildRequires:   audit-libs-devel}
+BuildRequires: autoconf
+BuildRequires: automake
 %{?with_selinux:BuildRequires: libselinux-devel}
 BuildRequires: pam-devel
 %{?with_selinux:BuildRequires: libselinux-devel}
 BuildRequires: pam-devel
+BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.268
 Requires(post):        fileutils
 Requires(post,preun):  /sbin/chkconfig
 BuildRequires: rpmbuild(macros) >= 1.268
 Requires(post):        fileutils
 Requires(post,preun):  /sbin/chkconfig
@@ -30,13 +44,18 @@ Requires:   /bin/run-parts
 Requires:      /sbin/chkconfig
 Requires:      psmisc >= 20.1
 Requires:      rc-scripts
 Requires:      /sbin/chkconfig
 Requires:      psmisc >= 20.1
 Requires:      rc-scripts
+%{?with_inotify:Requires:      uname(release) >= 2.6.13}
 Provides:      crondaemon
 Provides:      crontabs = 1.7
 Provides:      group(crontab)
 Provides:      crondaemon
 Provides:      crontabs = 1.7
 Provides:      group(crontab)
+%if "%{pld_release}" == "th"
 Provides:      vixie-cron = 4:4.4
 Provides:      vixie-cron = 4:4.4
+%endif
 Obsoletes:     crondaemon
 Obsoletes:     crontabs
 Obsoletes:     crondaemon
 Obsoletes:     crontabs
+%if "%{pld_release}" == "th"
 Obsoletes:     vixie-cron <= 4:4.3
 Obsoletes:     vixie-cron <= 4:4.3
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -58,16 +77,21 @@ however this could be overloaded in settings.
 
 %prep
 %setup -q
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 
 %build
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 %configure \
        SYSCRONTAB=/etc/cron.d/crontab \
        SYS_CROND_DIR=/etc/cron.d \
        --sysconfdir=/etc/cron \
        --with-pam \
        --with%{!?with_selinux:out}-selinux \
 %configure \
        SYSCRONTAB=/etc/cron.d/crontab \
        SYS_CROND_DIR=/etc/cron.d \
        --sysconfdir=/etc/cron \
        --with-pam \
        --with%{!?with_selinux:out}-selinux \
-       --with-audit \
-       --with-inotify \
+       --with%{!?with_audit:out}-audit \
+       --with%{!?with_inotify:out}-inotify \
        --enable-anacron
 
 %{__make}
        --enable-anacron
 
 %{__make}
@@ -79,6 +103,7 @@ install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir}} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
 
 %{__make} install \
        $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
 
 %{__make} install \
+       pamdir=/etc/pam.d \
        DESTDIR=$RPM_BUILD_ROOT
 
 install contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
        DESTDIR=$RPM_BUILD_ROOT
 
 install contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
This page took 0.072107 seconds and 4 git commands to generate.