]> git.pld-linux.org Git - packages/cronie.git/blame_incremental - cronie.spec
Rel 7; report script filename if it produces any output.
[packages/cronie.git] / cronie.spec
... / ...
CommitLineData
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
4# - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5# Mar 3 09:30:01 ravenous CROND[2528]: 4ÿ
6#
7# Conditional build:
8%bcond_without inotify # without inotify support
9%if "%{pld_release}" == "ac"
10%bcond_with selinux # with SELinux support
11%bcond_with audit # with audit support
12%else
13%bcond_without selinux # without SELinux support
14%bcond_without audit # without audit support
15%endif
16
17Summary: Cron daemon for executing programs at set times
18Summary(pl.UTF-8): Demon cron do uruchamiania programów o zadanym czasie
19Name: cronie
20Version: 1.5.7
21Release: 7
22License: MIT and BSD and GPL v2
23Group: Daemons
24Source0: https://github.com/cronie-crond/cronie/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
25# Source0-md5: 544f141aa4e34e0a176529be08441756
26Source1: %{name}.init
27Source3: cron.sysconfig
28Source4: %{name}.crontab
29Source5: %{name}.pam
30Source6: crond.service
31Patch0: inotify-nosys.patch
32Patch1: sendmail-path.patch
33URL: https://github.com/cronie-crond/cronie/
34%{?with_audit:BuildRequires: audit-libs-devel}
35BuildRequires: autoconf >= 2.60
36BuildRequires: automake
37BuildRequires: glibc-devel >= 6:2.21
38%{?with_selinux:BuildRequires: libselinux-devel}
39BuildRequires: pam-devel
40BuildRequires: rpm >= 4.4.9-56
41BuildRequires: rpmbuild(macros) >= 1.647
42Requires(post): fileutils
43Requires(post,preun): /sbin/chkconfig
44Requires(postun): /usr/sbin/groupdel
45Requires(pre): /usr/bin/getgid
46Requires(pre): /usr/sbin/groupadd
47Requires: /bin/run-parts
48Requires: psmisc >= 20.1
49Requires: rc-scripts >= 0.4.3.0
50%if "%{pld_release}" != "ac"
51Requires(post,preun,postun): systemd-units >= 38
52Requires: systemd-units >= 38}
53%endif
54%{?with_inotify:Requires: uname(release) >= 2.6.13}
55Provides: crondaemon
56Provides: crontabs = 1.7
57Provides: cronjobs
58Provides: group(crontab)
59%if "%{pld_release}" == "th"
60Provides: vixie-cron = 4.3-1
61%endif
62Obsoletes: crondaemon
63Obsoletes: cronie-systemd
64Obsoletes: crontabs
65Obsoletes: cronjobs
66%if "%{pld_release}" == "th"
67Obsoletes: vixie-cron < 4.3-1
68%endif
69Conflicts: sysklogd < 1.5.1-2
70Conflicts: syslog-ng < 3.6.4-3
71Conflicts: rsyslog < 5.10.1-4
72BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74%description
75Cronie contains the standard UNIX daemon crond that runs specified
76programs at scheduled times and related tools. It is based on the
77original cron and has security and configuration enhancements like the
78ability to use PAM and SELinux.
79
80%description -l pl.UTF-8
81Cronie zawiera standardowego demona uniksowego crond, uruchamiającego
82podane programy o zadanym czasie, oraz powiązane narzędzia. Jest
83oparty na oryginalnym cronie i zawiera rozszerzenia bezpieczeństwa i
84konfiguracji, takie jak możliwość wykorzystania mechanizmów PAM i
85SELinux.
86
87%package anacron
88Summary: Utility for running regular jobs
89Summary(pl.UTF-8): Narzędzie do uruchamiania regularnych zadań
90Group: Base
91Provides: anacron = 2.4
92Obsoletes: anacron <= 2.3
93
94%description anacron
95Anacron becames part of cronie. Anacron is used only for running
96regular jobs. The default settings execute regular jobs by anacron,
97however this could be overloaded in settings.
98
99%description anacron -l pl.UTF-8
100Anacron stał się częścią cronie. Służy tylko do uruchamiania
101regularnych zadań. Domyślne ustawienia wykonują zadania przy użyciu
102anacrona, ale może to być zmienione w ustawieniach.
103
104%prep
105%setup -q
106%patch0 -p1
107%patch1 -p1
108
109%build
110%{__aclocal}
111%{__autoconf}
112%{__autoheader}
113%{__automake}
114%configure \
115 SYSCRONTAB=/etc/crontab \
116 SYS_CROND_DIR=/etc/cron.d \
117 --sysconfdir=/etc/cron \
118 --with-editor=/bin/vi \
119 --with-audit%{!?with_audit:=no} \
120 --with-inotify%{!?with_inotify:=no} \
121 --with-pam \
122 --with-selinux%{!?with_selinux:=no} \
123 --disable-silent-rules \
124 --disable-syscrontab \
125 --enable-anacron \
126%if "%{cc_version}" >= "3.4"
127 --enable-pie \
128%endif
129 --enable-relro
130
131%{__make}
132
133%install
134rm -rf $RPM_BUILD_ROOT
135install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitdir}}\
136 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
137 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
138
139%{__make} install \
140 pamdir=/etc/pam.d \
141 DESTDIR=$RPM_BUILD_ROOT
142
143cp -p %{SOURCE5} crond.pam
144
145%if %{without audit}
146# remove recording user's login uid to the process attribute
147%{__sed} -i -e '/pam_loginuid.so/d' crond.pam
148%endif
149
150install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
151cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
152cp -a contrib/anacrontab $RPM_BUILD_ROOT/etc/cron/anacrontab
153cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
154cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
155cp -a crond.pam $RPM_BUILD_ROOT/etc/pam.d/crond
156cp -a %{SOURCE6} $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
157
158cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
159# cron.allow This file describes the names of the users which are
160# allowed to use the local cron daemon
161root
162EOF
163
164cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
165# cron.deny This file describes the names of the users which are
166# NOT allowed to use the local cron daemon
167EOF
168
169cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/check-crond << 'EOF'
170#!/bin/sh
171
172# ugly and limited hack. make cronie restart itself
173if [ -x /bin/awk -a -x /bin/grep -a -f /var/log/cron ]; then
174 LC_ALL=C /bin/awk -v d="$(LC_ALL=C date "+%b %e")" ' $1 " " $2 ~ d' /var/log/cron \
175 | /bin/grep -qE "PAM.*(Modu. jest nieznany|Module is unknown)" \
176 && echo "crond is failing on PAM, restarting ( https://github.com/cronie-crond/cronie/issues/87 )" >&2 \
177 && /sbin/service crond condrestart
178fi
179exit 0
180EOF
181
182%clean
183rm -rf $RPM_BUILD_ROOT
184
185%pre
186%groupadd -g 117 -r -f crontab
187
188%post
189/sbin/chkconfig --add crond
190%service crond restart "Cron Daemon"
191%systemd_post crond.service
192
193%preun
194if [ "$1" = "0" ]; then
195 %service crond stop
196 /sbin/chkconfig --del crond
197fi
198%systemd_preun crond.service
199
200%postun
201if [ "$1" = "0" ]; then
202 %groupremove crontab
203fi
204%systemd_reload
205
206%triggerpostun -- cronie < 1.4.8-13
207if [ -f /etc/sysconfig/cron ]; then
208 . /etc/sysconfig/cron
209 __CROND_ARGS=
210 [ "$CROND_SYSLOG_RESULT" = "yes" ] && __CROND_ARGS="-s"
211 [ -n "$CROND_MAIL_PROG" ] && __CROND_ARGS="$__CROND_ARGS -m $CROND_MAIL_PROG"
212 if [ -n "$__CROND_ARGS" ]; then
213 %{__cp} -f /etc/sysconfig/cron{,.rpmsave}
214 echo >>/etc/sysconfig/cron
215 echo "# Added by rpm trigger" >>/etc/sysconfig/cron
216 echo "CROND_ARGS=\"$CROND_ARGS $__CROND_ARGS\"" >>/etc/sysconfig/cron
217 fi
218fi
219%systemd_trigger crond.service
220
221%triggerun -- hc-cron,fcron,vixie-cron < 4.3-1
222# Prevent preun from crond from working
223chmod a-x /etc/rc.d/init.d/crond
224
225%triggerpostun -- hc-cron,fcron,vixie-cron < 4.3-1
226# Restore what triggerun removed
227chmod 754 /etc/rc.d/init.d/crond
228# reinstall crond init.d links, which could be different
229/sbin/chkconfig --del crond
230/sbin/chkconfig --add crond
231
232%files
233%defattr(644,root,root,755)
234%doc AUTHORS ChangeLog README
235%attr(750,root,crontab) %dir /etc/cron
236%attr(750,root,crontab) %dir /etc/cron.daily
237%attr(750,root,root) /etc/cron.daily/check-crond
238%attr(750,root,crontab) %dir /etc/cron.hourly
239%attr(750,root,crontab) %dir /etc/cron.monthly
240%attr(750,root,crontab) %dir /etc/cron.weekly
241%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
242%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
243%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
244%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
245%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
246%attr(754,root,root) /etc/rc.d/init.d/crond
247%{systemdunitdir}/crond.service
248%attr(755,root,root) %{_sbindir}/crond
249%attr(2755,root,crontab) %{_bindir}/cronnext
250%attr(2755,root,crontab) %{_bindir}/crontab
251
252%{_mandir}/man8/crond.8*
253%{_mandir}/man8/cron.8*
254%{_mandir}/man5/crontab.5*
255%{_mandir}/man1/cronnext.1*
256%{_mandir}/man1/crontab.1*
257
258%attr(1730,root,crontab) /var/spool/cron
259
260%files anacron
261%defattr(644,root,root,755)
262%attr(755,root,root) %{_sbindir}/anacron
263%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
264%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) /etc/cron/anacrontab
265%{_mandir}/man5/anacrontab.5*
266%{_mandir}/man8/anacron.8*
267
268%attr(1730,root,crontab) /var/spool/anacron
This page took 0.037761 seconds and 4 git commands to generate.