]> git.pld-linux.org Git - packages/cronie.git/blame_incremental - cronie.spec
- mention why is restarted
[packages/cronie.git] / cronie.spec
... / ...
CommitLineData
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
4# - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5# Mar 3 09:30:01 ravenous CROND[2528]: 4ΓΏ
6#
7# Conditional build:
8%bcond_without inotify # without inotify support
9%if "%{pld_release}" == "ac"
10%bcond_with selinux # without SELinux support
11%bcond_with audit # without audit support
12%else
13%bcond_without selinux # without SELinux support
14%bcond_without audit # without audit support
15%endif
16
17Summary: Cron daemon for executing programs at set times
18Name: cronie
19Version: 1.4.6
20Release: 2
21License: MIT and BSD and GPL v2
22Group: Daemons
23Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
24# Source0-md5: 968e3d3e7c8e1d0588d533883482d3fa
25Source1: %{name}.init
26Source2: cron.logrotate
27Source3: cron.sysconfig
28Source4: %{name}.crontab
29Source5: %{name}.pam
30Source6: %{name}.upstart
31Patch0: inotify-nosys.patch
32Patch1: %{name}-nosyscrontab.patch
33Patch2: sendmail-path.patch
34URL: https://fedorahosted.org/cronie/
35%{?with_audit:BuildRequires: audit-libs-devel}
36BuildRequires: autoconf
37BuildRequires: automake
38%{?with_selinux:BuildRequires: libselinux-devel}
39BuildRequires: pam-devel
40BuildRequires: rpm >= 4.4.9-56
41BuildRequires: rpmbuild(macros) >= 1.561
42Requires(post): fileutils
43Requires(post,preun): /sbin/chkconfig
44Requires(postun): /usr/sbin/groupdel
45Requires(pre): /usr/bin/getgid
46Requires(pre): /usr/sbin/groupadd
47Requires: /bin/run-parts
48Requires: /sbin/chkconfig
49Requires: psmisc >= 20.1
50Requires: rc-scripts >= 0.4.3.0
51%{?with_inotify:Requires: uname(release) >= 2.6.13}
52Provides: crondaemon
53Provides: crontabs = 1.7
54Provides: group(crontab)
55%if "%{pld_release}" == "th"
56Provides: vixie-cron = 4:4.4
57%endif
58Obsoletes: crondaemon
59Obsoletes: crontabs
60%if "%{pld_release}" == "th"
61Obsoletes: vixie-cron <= 4:4.3
62%endif
63BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65%description
66Cronie contains the standard UNIX daemon crond that runs specified
67programs at scheduled times and related tools. It is based on the
68original cron and has security and configuration enhancements like the
69ability to use pam and SELinux.
70
71%package anacron
72Summary: Utility for running regular jobs
73Group: Base
74Provides: anacron = 2.4
75Obsoletes: anacron <= 2.3
76
77%description anacron
78Anacron becames part of cronie. Anacron is used only for running
79regular jobs. The default settings execute regular jobs by anacron,
80however this could be overloaded in settings.
81
82%package upstart
83Summary: Upstart job description for Cronie
84Summary(pl.UTF-8): Opis zadania Upstart dla Cronie
85Group: Daemons
86Requires: %{name} = %{version}-%{release}
87Requires: upstart >= 0.6
88
89%description upstart
90Upstart job description for Cronie.
91
92%description upstart -l pl.UTF-8
93Opis zadania Upstart dla Cronie.
94
95%prep
96%setup -q
97%patch0 -p1
98%patch1 -p1
99%patch2 -p1
100
101%build
102%{__aclocal}
103%{__autoconf}
104%{__autoheader}
105%{__automake}
106%configure \
107 SYSCRONTAB=/etc/crontab \
108 SYS_CROND_DIR=/etc/cron.d \
109 --sysconfdir=/etc/cron \
110 --with-pam \
111 --with%{!?with_selinux:out}-selinux \
112 --with%{!?with_audit:out}-audit \
113 --with%{!?with_inotify:out}-inotify \
114 --enable-anacron
115
116%{__make}
117
118%install
119rm -rf $RPM_BUILD_ROOT
120install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir}} \
121 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
122 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
123
124%{__make} install \
125 pamdir=/etc/pam.d \
126 DESTDIR=$RPM_BUILD_ROOT
127
128install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
129cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
130cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
131cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
132cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
133cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
134cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
135
136touch $RPM_BUILD_ROOT/var/log/cron
137
138cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
139# cron.allow This file describes the names of the users which are
140# allowed to use the local cron daemon
141root
142EOF
143
144cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
145# cron.deny This file describes the names of the users which are
146# NOT allowed to use the local cron daemon
147EOF
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%pre
153%groupadd -g 117 -r -f crontab
154
155%post
156if [ ! -f /var/log/cron ]; then
157 install -m 660 -g crontab /dev/null /var/log/cron
158fi
159/sbin/chkconfig --add crond
160%service crond restart "Cron Daemon"
161
162%preun
163if [ "$1" = "0" ]; then
164 %service crond stop
165 /sbin/chkconfig --del crond
166fi
167
168%postun
169if [ "$1" = "0" ]; then
170 %groupremove crontab
171fi
172
173%triggerin -- pam
174# restart crond if pam is upgraded
175# (crond is linked with old libpam but tries to open modules linked with new libpam)
176if [ "$2" != 1 ]; then
177 %service -q crond restart
178fi
179
180%triggerun -- hc-cron,fcron,vixie-cron
181# Prevent preun from crond from working
182chmod a-x /etc/rc.d/init.d/crond
183
184%triggerpostun -- hc-cron,fcron,vixie-cron
185# Restore what triggerun removed
186chmod 754 /etc/rc.d/init.d/crond
187# reinstall crond init.d links, which could be different
188/sbin/chkconfig --del crond
189/sbin/chkconfig --add crond
190
191%post upstart
192%upstart_post crond
193
194%postun upstart
195%upstart_postun crond
196
197%files
198%defattr(644,root,root,755)
199%doc AUTHORS ChangeLog README
200%attr(750,root,crontab) %dir %{_sysconfdir}/cron*
201%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
202%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
203%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
204%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
205%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
206%attr(754,root,root) /etc/rc.d/init.d/crond
207%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
208%attr(755,root,root) %{_sbindir}/crond
209%attr(2755,root,crontab) %{_bindir}/crontab
210
211%{_mandir}/man8/crond.8*
212%{_mandir}/man8/cron.8*
213%{_mandir}/man5/crontab.5*
214%{_mandir}/man1/crontab.1*
215
216%attr(1730,root,crontab) /var/spool/cron
217%attr(660,root,crontab) %ghost /var/log/cron
218
219%files anacron
220%defattr(644,root,root,755)
221%attr(755,root,root) %{_sbindir}/anacron
222%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
223%{_mandir}/man5/anacrontab.5*
224%{_mandir}/man8/anacron.8*
225
226%attr(1730,root,crontab) /var/spool/anacron
227
228%files upstart
229%defattr(644,root,root,755)
230%config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
This page took 0.033362 seconds and 4 git commands to generate.