]> git.pld-linux.org Git - packages/criterion.git/blob - criterion.spec
drop debug leftover
[packages/criterion.git] / criterion.spec
1 # TODO:
2 # - system boxfort (when released): https://github.com/diacritic/BoxFort
3 # - system libcsptr (when some post-2017 release made): https://github.com/Snaipe/libcsptr
4 #
5 # Conditional build:
6 %bcond_without  tests           # build without tests
7 #
8 Summary:        A cross-platform C and C++ unit testing framework for the 21th century
9 Summary(pl.UTF-8):      Wieloplatformowy szkielet do testów jednostkowych dla C i C++ w XXI wieku
10 Name:           criterion
11 Version:        2.4.1
12 Release:        1
13 License:        LGPL v2.1+
14 Group:          Libraries
15 #Source0Download: https://github.com/Snaipe/Criterion/releases
16 Source0:        https://github.com/Snaipe/Criterion/releases/download/v%{version}/%{name}-%{version}.tar.xz
17 # Source0-md5:  93e91812837a68524d76339409ed2008
18 Patch0:         x32.patch
19 URL:            https://github.com/Snaipe/Criterion
20 BuildRequires:  dyncall >= 1.0
21 BuildRequires:  libffi-devel
22 BuildRequires:  libgit2-devel
23 BuildRequires:  meson >= 0.51.0
24 BuildRequires:  nanomsg-devel >= 1.0.0
25 BuildRequires:  ninja
26 BuildRequires:  rpmbuild(macros) >= 1.736
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 A dead-simple, yet extensible, C and C++ unit testing framework.
33
34 %description -l pl.UTF-8
35 Bardzo prosty, ale rozszerzalny szkielet testów jednostkowych dla C i
36 C++.
37
38 %package devel
39 Summary:        Header files for criterion library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki criterion
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       libstdc++-devel
44
45 %description devel
46 Header files for criterion library.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki criterion.
50
51 %prep
52 %setup -q
53 %patch0 -p1
54
55 %build
56 %meson build \
57         -Dtests=%{__true_false tests}
58
59 %ninja_build -C build
60 %{?with_tests:%ninja_test -C build}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %ninja_install -C build
66
67 %find_lang criterion
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post   -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %files -f criterion.lang
76 %defattr(644,root,root,755)
77 %doc ChangeLog doc/*.txt
78 %attr(755,root,root) %{_libdir}/libcriterion.so.*.*.*
79 %attr(755,root,root) %ghost %{_libdir}/libcriterion.so.3
80
81 %files devel
82 %defattr(644,root,root,755)
83 %attr(755,root,root) %{_libdir}/libcriterion.so
84 %{_includedir}/criterion
85 %{_pkgconfigdir}/criterion.pc
This page took 0.170908 seconds and 3 git commands to generate.