]> git.pld-linux.org Git - packages/createrepo.git/blob - createrepo.spec
turn off buffering on stdout; bash-completions 2.0
[packages/createrepo.git] / createrepo.spec
1 Summary:        Creates a common metadata repository
2 Summary(pl.UTF-8):      Tworzenie wspólnego repozytorium metadanych
3 Name:           createrepo
4 Version:        0.9.9
5 Release:        3
6 License:        GPL v2
7 Group:          Applications/System
8 Source0:        http://createrepo.baseurl.org/download/%{name}-%{version}.tar.gz
9 # Source0-md5:  10641f19a40e9f633b300e23dde00349
10 Patch0:         %{name}-head.patch
11 URL:            http://createrepo.baseurl.org/
12 BuildRequires:  python-devel
13 BuildRequires:  python-modules
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  sed >= 4.0
16 Requires:       python
17 Requires:       python-deltarpm
18 Requires:       python-libxml2
19 Requires:       python-pylzma
20 Requires:       python-rpm
21 Requires:       yum >= 3.2.23
22 Requires:       yum-metadata-parser >= 1.1.1-3
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This utility will generate a common metadata repository from a
28 directory of RPM packages.
29
30 %description -l pl.UTF-8
31 To narzędzie tworzy wspólne repozytorium metadanych z katalogu
32 pakietów RPM.
33
34 %package -n bash-completion-%{name}
35 Summary:        bash-completion for createrepo
36 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla createrepo
37 Group:          Applications/Shells
38 Requires:       %{name}
39 Requires:       bash-completion >= 2.0
40
41 %description -n bash-completion-%{name}
42 bash-completion for createrepo.
43
44 %description -n bash-completion-%{name} -l pl.UTF-8
45 bashowe uzupełnianie nazw dla createrepo.
46
47 %prep
48 %setup -q
49 %patch0 -p1
50
51 %{__sed} -i -e '1s,#!.*python,#!%{__python},' modifyrepo.py
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 %{__make} install \
56         sysconfdir=%{_sysconfdir} \
57         PKGDIR=%{py_sitescriptdir}/%{name} \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
61 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
62 %py_postclean
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc ChangeLog README
70 %attr(755,root,root) %{_bindir}/createrepo
71 %attr(755,root,root) %{_bindir}/mergerepo
72 %attr(755,root,root) %{_bindir}/modifyrepo
73 %{_mandir}/man1/mergerepo.1*
74 %{_mandir}/man1/modifyrepo.1*
75 %{_mandir}/man8/createrepo.8*
76 %dir %{_datadir}/%{name}
77 # note that these DO NEED executable bit set!
78 %attr(755,root,root) %{_datadir}/%{name}/genpkgmetadata.py
79 %attr(755,root,root) %{_datadir}/%{name}/mergerepo.py
80 %attr(755,root,root) %{_datadir}/%{name}/modifyrepo.py
81 %attr(755,root,root) %{_datadir}/%{name}/worker.py
82 %{_datadir}/%{name}/*.py[co]
83 %dir %{py_sitescriptdir}/%{name}
84 %{py_sitescriptdir}/%{name}/*.py[co]
85
86 %files -n bash-completion-%{name}
87 %defattr(644,root,root,755)
88 %{_datadir}/bash-completion/completions/createrepo
89 %{_datadir}/bash-completion/completions/genpkgmetadata.py
90 %{_datadir}/bash-completion/completions/mergerepo
91 %{_datadir}/bash-completion/completions/mergerepo.py
92 %{_datadir}/bash-completion/completions/modifyrepo
93 %{_datadir}/bash-completion/completions/modifyrepo.py
This page took 0.080952 seconds and 4 git commands to generate.