]> git.pld-linux.org Git - packages/createrepo.git/blob - createrepo.spec
- updated to 0.10.1
[packages/createrepo.git] / createrepo.spec
1 Summary:        Creates a common metadata repository
2 Summary(pl.UTF-8):      Tworzenie wspólnego repozytorium metadanych
3 Name:           createrepo
4 Version:        0.10.1
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/System
8 Source0:        http://createrepo.baseurl.org/download/%{name}-%{version}.tar.gz
9 # Source0-md5:  eaeb274284172d10d41600e22bce9320
10 Patch1:         rpm5-caps.patch
11 URL:            http://createrepo.baseurl.org/
12 BuildRequires:  python-devel
13 BuildRequires:  python-modules
14 BuildRequires:  rpmbuild(macros) >= 1.673
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  sed >= 4.0
17 Requires:       python
18 Requires:       python-deltarpm
19 Requires:       python-libxml2
20 Requires:       python-pylzma
21 Requires:       python-rpm
22 Requires:       yum >= 3.2.23
23 Requires:       yum-metadata-parser >= 1.1.1-3
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This utility will generate a common metadata repository from a
29 directory of RPM packages.
30
31 %description -l pl.UTF-8
32 To narzędzie tworzy wspólne repozytorium metadanych z katalogu
33 pakietów RPM.
34
35 %package -n bash-completion-%{name}
36 Summary:        bash-completion for createrepo commands
37 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla poleceń createrepo
38 Group:          Applications/Shells
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       bash-completion >= 2.0
41
42 %description -n bash-completion-%{name}
43 bash-completion for createrepo commands.
44
45 %description -n bash-completion-%{name} -l pl.UTF-8
46 bashowe uzupełnianie nazw dla poleceń createrepo.
47
48 %prep
49 %setup -q
50 %patch1 -p1
51
52 %{__sed} -i -e '1s,#!.*python,#!%{__python},' modifyrepo.py
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 %{__make} install \
57         compdir=%{bash_compdir} \
58         sysconfdir=%{_sysconfdir} \
59         PKGDIR=%{py_sitescriptdir}/%{name} \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
63 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
64 %py_postclean
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc ChangeLog README
72 %attr(755,root,root) %{_bindir}/createrepo
73 %attr(755,root,root) %{_bindir}/mergerepo
74 %attr(755,root,root) %{_bindir}/modifyrepo
75 %{_mandir}/man1/mergerepo.1*
76 %{_mandir}/man1/modifyrepo.1*
77 %{_mandir}/man8/createrepo.8*
78 %dir %{_datadir}/%{name}
79 # note that these DO NEED executable bit set!
80 %attr(755,root,root) %{_datadir}/%{name}/genpkgmetadata.py
81 %attr(755,root,root) %{_datadir}/%{name}/mergerepo.py
82 %attr(755,root,root) %{_datadir}/%{name}/modifyrepo.py
83 %attr(755,root,root) %{_datadir}/%{name}/worker.py
84 %{_datadir}/%{name}/*.py[co]
85 %dir %{py_sitescriptdir}/%{name}
86 %{py_sitescriptdir}/%{name}/*.py[co]
87
88 %files -n bash-completion-%{name}
89 %defattr(644,root,root,755)
90 %{_datadir}/bash-completion/completions/createrepo
91 %{_datadir}/bash-completion/completions/genpkgmetadata.py
92 %{_datadir}/bash-completion/completions/mergerepo
93 %{_datadir}/bash-completion/completions/mergerepo.py
94 %{_datadir}/bash-completion/completions/modifyrepo
95 %{_datadir}/bash-completion/completions/modifyrepo.py
This page took 0.0761 seconds and 3 git commands to generate.