]> git.pld-linux.org Git - packages/cproto.git/blob - cproto.spec
- added using %%{__make} macro.
[packages/cproto.git] / cproto.spec
1 Summary:        C Prototype Utility
2 Summary(de):    C-Prototyp-Dienstprogramm
3 Summary(fr):    Utilitaire de prototypage C
4 Summary(pl):    Narzêdzia dla prototypów C
5 Summary(tr):    C prototip aracý
6 Name:           cproto
7 Version:        4.6
8 Release:        4
9 License:        Public Domain
10 Group:          Development/Tools
11 Group(fr):      Development/Outils
12 Group(pl):      Programowanie/Narzêdzia
13 Source0:        ftp://ftp.oce.com/pub/cproto/%{name}-%{version}.tar.gz
14 Patch0:         cproto.patch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Cproto generates function prototypes for functions defined in the
19 specified C source files to the standard output. The function
20 definitions may be in the old style or ANSI C style. Optionally,
21 cproto also outputs declarations for variables defined in the files.
22 If no file argument is given, cproto reads its input from the standard
23 input.
24
25 %description -l de
26 Cproto erzeugt Funktionsprototypen für in C-Quelldateien definierte
27 Funktionen für die Standardausgabe. Die Funktionsdefinitionen können
28 im alten oder ANSI-C-Format vorliegen. cproto kann auch Deklarationen
29 für in den Dateien definierten Variablen ausgeben. Wird kein
30 Dateiargument angegeben, liest cproto die Eingabe aus der
31 Standardeingabe.
32
33 %description -l fr
34 Cproto génére des prototypes de fonction définies dans sources C
35 spécifiées sur la sortie standard. Les fonctions défines peuvent être
36 en vieux style ou en style C ANSI. Optionnelement, cproto affiche
37 aussi les déclarations pour les variables définies dans ces sources.
38 Si aucun argument ne lui est donné, cproto lit ses entrées depuis
39 l'entrée standard.
40
41 %description -l pl
42 Cproto jest programem do generowania prototypów funkcji,
43 zdefiniowanych w plikach ¼ród³owtch C. Definicje funkcji mog± byæ
44 zarówno zgodne z ANSI C jak i ze starszymi. Cproto mo¿e tak¿e
45 dodatkowo tworzyæ wynik deklaracji dla ro¿nych zmiennych
46 zdefiniowanych w pliku. Je¿eli argumentem nie jest plik, cproto
47 pobiera argumenty ze standardowego wej¶cia (stdin).
48
49 %description -l tr
50 Cproto, verilen C kaynak dosyalarýnda tanýmlanmýþ fonksiyonlar için
51 standart çýktýda prototipler oluþturur. Ýstenirse dosyalardaki
52 deðiþken tanýmlamalarýný da çýkartabilir. Programa hiçbir argüman
53 verilmemiþse, cproto girdi olarak standart giriþten bilgi okur.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 %build
60 autoconf
61 CPP="/lib/cpp"
62 LDFLSGS="-s"
63 export CPP export
64 %configure \
65         --prefix=%{_prefix} \
66         --exec-prefix=%{_prefix}
67 make
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
72
73 %{__make} install \
74         bindir=$RPM_BUILD_ROOT%{_bindir} \
75         mandir=$RPM_BUILD_ROOT%{_mandir}/man1
76
77 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/* \
78         README CHANGES
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc *.gz
86 %attr(755,root,root) %{_bindir}/cproto
87 %{_mandir}/man1/*
This page took 0.08877 seconds and 4 git commands to generate.