]> git.pld-linux.org Git - packages/cppunit.git/blob - cppunit.spec
- use http for sources from sourceforge
[packages/cppunit.git] / cppunit.spec
1 Summary:        The C++ Unit Test Library
2 Summary(pl):    Biblioteka testowa do C++
3 Name:           cppunit
4 Version:        1.8.0
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/cppunit/%{name}-%{version}.tar.gz
9 URL:            http://cppunit.sourceforge.net/
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  doxygen
13 BuildRequires:  libstdc++-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 CppUnit is the C++ port of the famous JUnit framework for unit
18 testing.
19
20 %description -l pl
21 CppUnit jest portem C++ s³ynnego ¶rodowiska testowego JUnit.
22
23 %package devel
24 Summary:        cppunit header files
25 Summary(pl):    Pliki nag³ówkowe cppunit
26 Group:          Development/Libraries
27 Requires:       %{name} = %{version}
28
29 %description devel
30 cppunit header files.
31
32 %description devel -l pl
33 Pliki nag³ówkowe cppunit.
34
35 %package static
36 Summary:        cppunit static library
37 Summary(pl):    Statyczna biblioteka cppunit
38 Group:          Development/Libraries
39 Requires:       %{name}-devel = %{version}
40
41 %description static
42 cppunit static library.
43
44 %description static -l pl
45 Statyczna biblioteka cppunit.
46
47 %prep
48 %setup -q
49
50 echo 'libcppunit_la_LIBADD = -lstdc++ -lpthread' >> src/cppunit/Makefile.am
51
52 %build
53 rm -f missing
54 %{__aclocal} -I config
55 %{__autoconf}
56 %{__automake}
57 %configure
58
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install DESTDIR=$RPM_BUILD_ROOT
65
66 rm -rf $RPM_BUILD_ROOT%{_includedir}/cppunit/{ui/mfc,ui/qt,config-[bm]*}
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post   -p /sbin/ldconfig
72 %postun -p /sbin/ldconfig
73
74 %files
75 %defattr(644,root,root,755)
76 %doc AUTHORS BUGS NEWS README THANKS TODO
77 %attr(755,root,root) %{_libdir}/lib*.so.*.*
78
79 %files devel
80 %defattr(644,root,root,755)
81 %doc doc/FAQ doc/html
82 %attr(755,root,root) %{_bindir}/cppunit-config
83 %{_libdir}/lib*.la
84 %attr(755,root,root) %{_libdir}/lib*.so
85 %{_includedir}/cppunit
86 %{_aclocaldir}/cppunit.m4
87 %{_mandir}/man1/cppunit-config.1*
88
89 %files static
90 %defattr(644,root,root,755)
91 %{_libdir}/lib*.a
This page took 0.042523 seconds and 4 git commands to generate.