]> git.pld-linux.org Git - packages/cppunit.git/blob - cppunit.spec
- converted to UTF-8
[packages/cppunit.git] / cppunit.spec
1 Summary:        The C++ Unit Test Library
2 Summary(pl.UTF-8):   Biblioteka testowa do C++
3 Name:           cppunit
4 Version:        1.12.0
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/cppunit/%{name}-%{version}.tar.gz
9 # Source0-md5:  7493718733ded49a96cf763c5d3eea7f
10 URL:            http://cppunit.sourceforge.net/
11 BuildRequires:  autoconf >= 2.50
12 BuildRequires:  automake >= 1.4
13 BuildRequires:  doxygen
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool >= 2:1.4d
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 CppUnit is the C++ port of the famous JUnit framework for unit
20 testing.
21
22 %description -l pl.UTF-8
23 CppUnit jest portem C++ słynnego środowiska testowego JUnit.
24
25 %package devel
26 Summary:        cppunit header files
27 Summary(pl.UTF-8):   Pliki nagłówkowe cppunit
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30 Requires:       libstdc++-devel
31
32 %description devel
33 cppunit header files.
34
35 %description devel -l pl.UTF-8
36 Pliki nagłówkowe cppunit.
37
38 %package static
39 Summary:        cppunit static library
40 Summary(pl.UTF-8):   Statyczna biblioteka cppunit
41 Group:          Development/Libraries
42 Requires:       %{name}-devel = %{version}-%{release}
43
44 %description static
45 cppunit static library.
46
47 %description static -l pl.UTF-8
48 Statyczna biblioteka cppunit.
49
50 %prep
51 %setup -q
52
53 echo 'libcppunit_la_LIBADD = -ldl' >> src/cppunit/Makefile.am
54
55 %build
56 %{__libtoolize}
57 %{__aclocal} -I config
58 %{__autoconf}
59 %{__autoheader}
60 %{__automake}
61 %configure
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 rm -rf $RPM_BUILD_ROOT%{_includedir}/cppunit/{ui/mfc,ui/qt,config/config-[bm]*}
71 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post   -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(644,root,root,755)
81 %doc AUTHORS BUGS NEWS README THANKS TODO
82 %attr(755,root,root) %{_bindir}/DllPlugInTester
83 %attr(755,root,root) %{_libdir}/lib*.so.*.*
84
85 %files devel
86 %defattr(644,root,root,755)
87 %doc doc/FAQ doc/html
88 %attr(755,root,root) %{_bindir}/cppunit-config
89 %attr(755,root,root) %{_libdir}/lib*.so
90 %{_libdir}/lib*.la
91 %{_includedir}/cppunit
92 %{_aclocaldir}/cppunit.m4
93 %{_pkgconfigdir}/cppunit.pc
94 %{_mandir}/man1/cppunit-config.1*
95
96 %files static
97 %defattr(644,root,root,755)
98 %{_libdir}/lib*.a
This page took 0.075242 seconds and 4 git commands to generate.